Slow loading web pages in browsers

I have two PC, Suse 42.3 and Leap 15. The same issue. Web pages are very slow loading. Doesn’t matter which browser. Windows and Android works well in my network. I tried to find solutions, no success. I use Network manager to connect. Disabling IPV6 didn’t help.
Could you help me, please?

There are web sites on the internet where you can test your down- and upload speeds. You could compare with other systems in your network. That would provide some more factual information on the difference between the systems as well as a possible difference between straight downloading and web-browsers.

Thanks for reply.
It’s really strange. NtB OpenSuse 42.3 via wifi: ping 34 ms, down 24 Mb, up 30 Mb. Same Ntb Win 10 via wifi: 20ms 27/40. My desktop Leap 15 via ethernet cable: 31ms 2/25. I tried it several times. Only Win10 (an Android too) load pages quickly (less than 1s) every others load pages longer than 7s. Does’t matter which browser.

Yes, strange. Just guessing. Is your DNS operating correct?

In my router is DNS and one alternativ. I think that is ok. Win10 abd Android works normally. If I remember well, once was everything OK. What could I change?

Main procedure to analyze your web browser performance is to monitor what is displayed in your status bar (The bottom left corner of your web browser). Unless it’s disabled (see your browser settings), it should tell you what your browser is trying to do that moment, eg trying to connect, waiting for response, etc.

That should generally point you in the right direction for any major issues like network problems, web server problems, name resolution, etc. Ordinarily nothing should display for more than a second at most.

If you see something that displays unusually long and don’t know what it should indicate, post that and someone will suggest a fix.

If what you see in the status bar doesn’t tell you enough, you can open the Developer Tools pane (CTL-SHFT-J in most browsers, otherwise you can invoke with a browser menu option). One of the standard options is a horizontal histogram(bar graph) displaying the load times for every component on your page. This would be more to satisfy your curiosity though and to verify that page components are just slow to load… It’s unlikely that you as the end user can do anything about it except point out the problem to the website creator.


Am I correct in reading that your Leap 15 machine is connected via wired ethernet, and other devices being checked against are all connected via wifi?

If so, check that the negotiation parameters are as expected. Run the following command and report back

/usr/sbin/ethtool eth0

I watched status bar, there are information in my native language, I can’t translate preciously. Connesting security TSL , recognaising host. I tried to re-configure my reouter, tried to chanege some parameters in OS. No success.
In the evening was everything good. The response of both PC was correct. I cant say why. My home network is connected to large, (very advanced) wifi network. (It’s pretty usual in my country). There must be some explanation.
Why is Win10 (dual-boot on NtB ) was correct and on same machine with OpenSuse 42.3 was so slow response? Why had desktop so low download ?

IMHO the provider had to change some parameters in setup of his devices, maybe in firewall.

Thanks a lot …

Yes, desktop is connected via ethernet, rest is wireless. It’s pity that today works everything fine. I can’t get to know whats wrong. Reason of my problems had to be at provider side, I think.

I ran command:

tom@linux-DuoCore:~> /usr/sbin/ethtool eth0Settings for eth0:
        Supported ports:  TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes


Perhaps. In any case your ethernet negotiation is output reports 100Mb/s full duplex, which should be ok. (You can check your router ethernet port speed to make sure it matches as mismatched speeds can cause problems.) Autonegoitation can be turned on in the NetworkManager connection profile if required.