slow internet (or maybe mysterious traffic shaping) on tumbleweed

Hi, I have problem with one of my tumbleweed machines, internet works only about 8/6mbit instead of 100/100. When I reboot into windows (cough cough), everything works as it should on the same IPv4. I tried to set IPv4 manually and via dhcp, disabled firewall, but it has no effect. I have played with wondershaper in the past, but I don’t have it installed at the moment, I tried to reset tc rules with

sudo tc qdisc del dev enp31s0 root
Error: Cannot delete qdisc with handle of zero.

but it is probably not set. What can I check and reset to defaults, if there’s some “forgotten” shaping? Maybe wrong MTU?
I have this very common card:

1f:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)

At one time, I had very poor performance with an RTL interface. This was on Tumbleweed. Performance was fine on Leap 15.1.

So I switched to “wicked” instead of NetworkManager. And then it worked well.

I then deleted all settings and cached data for NetworkManager (in “/etc/NetworkManager/system-connections” and in “/var/lib/NetworkManager”. Then I switched back to NetworkManager, and all was fine.

I don’t know whether that will help in your case, but it might be worth trying.

I can confirm, this indeed fixes the issue, thank you! Maybe problem with network manager? Ubuntu 19.10 now uses netplan and it works fine too on the very same machine, except ubuntu does not have yast, so I cannot easily replace it :frowning:

In the past few years, I was quite happy with different distros, because the basic things were common, I mean systemd, network manager, etc, but this is starting to fragment again, ubuntu is enforcing netplan, opensuse is pushing wicked, but at least leaves me a choice… It is probably safer to accept the change, stay with the mainstream and get used to new things.