Slow internet (bcm4318)

I finally have my wireless internet up and running using bcm4318 card. However, when I first start my computer it takes ~5 minutes for the internet to connect and work, even though it says it’s connected right when I start my computer. Then, when it does start working it goes slow in the form of connecting to any website.

When I go to any website, in the lower left it will say “Looking up [such and such website]” It does this for roughly 10 seconds, finds it, and loads it instantly.

I have had XP, Vista, and Fedora on this same computer and have never experienced this before. So I know it’s not our actual internet connection. My router is using WPA2/WPA PSK security. Here are some commands if this helps:

linux-qipx:/home/jordan # dhclient wlan0
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:0c:41:69:32:f6
Sending on   LPF/wlan0/00:0c:41:69:32:f6
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to port 67 interval 5
DHCPREQUEST on wlan0 to port 67
bound to -- renewal in 1555 seconds.

linux-qipx:/home/jordan # ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:0C:41:69:32:F6  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::20c:41ff:fe69:32f6/64 Scope:Link
          RX packets:95680 errors:0 dropped:0 overruns:0 frame:0
          TX packets:69937 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:99780149 (95.1 Mb)  TX bytes:8561179 (8.1 Mb)

linux-qipx:/home/jordan # iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"Bachelor Pad"  
          Mode:Managed  Frequency:2.452 GHz  Access Point: 00:1C:DF:03:DC:06   
          Bit Rate=1 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:[TOP SECRET]   Security mode:open
          Power Management:off
          Link Quality=76/100  Signal level:-37 dBm  Noise level=-71 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

         Cell 02 - Address: 00:1C:DF:03:DC:06
                    ESSID:"Bachelor Pad"
                    Frequency:2.452 GHz (Channel 9)
                    Quality=71/100  Signal level:-43 dBm  Noise level=-70 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2D1A4E101BFFFF000000000000000000000000000000000000000000
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra: Last beacon: 44ms ago

Please help!


Try Yast>Network Devices>Network Settings>Global Options>Then uncheck “Enable IPV6”

Then start Firefox, type ***about:config ***in the address bar, press enter twice then type ipv6

If disable IPV6 is set to false double click it to change it to true.

Close FF, then reboot.

Thanks for the quick post, but unfortunately that did not work. However, in the global options tab there was an option for user and network manager control. Choosing that option did the trick for me :slight_smile:

Glad you got it it solved. :slight_smile: