Slow inet.

Hello,

I’m having some issues with my internet speeds - they are criminally slow. Under windows I can max out at around 820k/s. Here I’m getting on average about 6k/s, with the worst speeds in mere bytes. Netbeans for example, through the package manager, was only coming down at 100b/s - I ended up wget’ting it from the 10.3 repository at 11k/s. Even surfing to this forum was a painful, time consuming, exercise.

I was really happy after installing OpenSuse because it found my wireless adapter and installed it automatically. I have no complaints about that.

My question is about configuration, as I assume this is the problem. I’m relatively new to linux so the information I provide is probably patchy, my apologies for that.

lspci dumps:


/home/geoff/downs # lspci
00:00.0 Host bridge: ATI Technologies Inc Radeon Xpress 200 Host Bridge (rev 01)
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:19.0 PCI bridge: ALi Corporation M5249 HTT to PCI Bridge
00:1c.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:1c.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:1c.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:1c.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
00:1d.0 Audio device: ALi Corporation High Definition Audio/AC'97 Host Controller
00:1e.0 ISA bridge: ALi Corporation PCI to LPC Controller (rev 31)
00:1e.1 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:1f.0 IDE interface: ALi Corporation M5229 IDE (rev c7)
00:1f.1 RAID bus controller: ALi Corporation ULi 5287 SATA (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8500 GT (rev a1)
02:11.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
02:14.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)

RTL-8185 is correct. So is the audio mind - this doesn’t work at all, even with firmware packages installed.

ifconfig dumps:


ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:60 errors:0 dropped:0 overruns:0 frame:0
          TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3844 (3.7 Kb)  TX bytes:3844 (3.7 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:0E:2E:C1:55:2E  
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20e:2eff:fec1:552e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:728399 errors:0 dropped:0 overruns:0 frame:0
          TX packets:783043 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:578961507 (552.1 Mb)  TX bytes:455892841 (434.7 Mb)

wmaster0  Link encap:UNSPEC  HWaddr 00-0E-2E-C1-55-2E-35-32-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

A simple ping produces varied results:


 ping www.google.co.uk
PING www.l.google.com (66.102.9.99) 56(84) bytes of data.
64 bytes from 66.102.9.99: icmp_seq=1 ttl=246 time=131 ms
64 bytes from 66.102.9.99: icmp_seq=3 ttl=246 time=2892 ms
64 bytes from 66.102.9.99: icmp_seq=4 ttl=246 time=2263 ms
64 bytes from 66.102.9.99: icmp_seq=5 ttl=246 time=1825 ms
64 bytes from 66.102.9.99: icmp_seq=6 ttl=246 time=1334 ms
64 bytes from 66.102.9.99: icmp_seq=7 ttl=246 time=496 ms
^C
--- www.l.google.com ping statistics ---
7 packets transmitted, 6 received, 14% packet loss, time 6013ms
rtt min/avg/max/mdev = 131.840/1490.854/2892.385/960.281 ms, pipe 3

I am not using the network manager. If I try too use that it just constantly asks me for my router key( no matter how many times I enter it ). I am using ifup, IPv6 is enabled.

I tried downloading drivers from RealTek and installing them, but it just errors out. This is the output of the latest drivers I could find:


~/rtl8185_linux_26.1027.0823.2007 # ./makedrv
./ieee80211/
./ieee80211/ieee80211_module.c
./ieee80211/ieee80211_rx.c
./ieee80211/tags
./ieee80211/Makefile
./ieee80211/ieee80211_crypt_tkip.c
./ieee80211/ieee80211_softmac.c
./ieee80211/readme
./ieee80211/ieee80211_crypt_ccmp.c
./ieee80211/ieee80211.h
./ieee80211/ieee80211_tx.c
./ieee80211/ieee80211_softmac_wx.c
./ieee80211/ieee80211_crypt.h
./ieee80211/ieee80211_wx.c
./ieee80211/license
./ieee80211/ieee80211_crypt_wep.c
./ieee80211/ieee80211_crypt.c
rtl8185/
rtl8185/README.adhoc
rtl8185/r8180_sa2400.h
rtl8185/Makefile
rtl8185/copying
rtl8185/README.master
rtl8185/r8180.h
rtl8185/install
rtl8185/r8180_max2820.h
rtl8185/r8180_max2820.c
rtl8185/r8180_rtl8225.h
rtl8185/r8180_wx.h
rtl8185/authors
rtl8185/tags
rtl8185/r8180_pm.c
rtl8185/r8180_hw.h
rtl8185/r8180_gct.c
rtl8185/r8180_gct.h
rtl8185/r8180_rtl8225.c
rtl8185/readme
rtl8185/r8180_93cx6.h
rtl8185/ieee80211.h
rtl8185/license
rtl8185/r8180_pm.h
rtl8185/changes
rtl8185/r8180_rtl8225z2.c
rtl8185/r8180_wx.c
rtl8185/r8180_rtl8255.c
rtl8185/r8180_93cx6.c
rtl8185/r8180_sa2400.c
rtl8185/r8180_core.c
rtl8185/r8180_rtl8255.h
rtl8185/ieee80211_crypt.h
rm -f *.mod.c *.mod *.o .*.cmd *.ko 
rm -rf /root/rtl8185_linux_26.1027.0823.2007/ieee80211/tmp
make -C /lib/modules/2.6.25.11-0.1-pae/build M=/root/rtl8185_linux_26.1027.0823.2007/ieee80211 CC=gcc modules
make[1]: Entering directory `/usr/src/linux-2.6.25.11-0.1-obj/i386/pae'
make[1]: *** No rule to make target `modules'.  Stop.
make[1]: Leaving directory `/usr/src/linux-2.6.25.11-0.1-obj/i386/pae'
make: *** [modules] Error 2
rm -f *.mod.c *.mod *.o .*.cmd *.ko *~
rm -rf /root/rtl8185_linux_26.1027.0823.2007/rtl8185/tmp
make -C /lib/modules/2.6.25.11-0.1-pae/build M=/root/rtl8185_linux_26.1027.0823.2007/rtl8185 CC=gcc modules
make[1]: Entering directory `/usr/src/linux-2.6.25.11-0.1-obj/i386/pae'
make[1]: *** No rule to make target `modules'.  Stop.
make[1]: Leaving directory `/usr/src/linux-2.6.25.11-0.1-obj/i386/pae'
make: *** [modules] Error 2

Does anybody have any advice for me?

If you need more information, tell me how to obtain it and I’ll post it up. :slight_smile:

Thanks.

What output do you get from iwconfig (as root). This will give a little more info on your wireless connection.

Also, what do you have in /var/log/messages (tail -100 /var/log/messages)

iwconfig as root.


lo        no wireless extensions.



eth0      no wireless extensions.



wmaster0  no wireless extensions.



wlan0     IEEE 802.11g  ESSID:"SKY07074"  

          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:1E:74:5B:1B:A3   

          Bit Rate=1 Mb/s   Tx-Power=27 dBm   

          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   

          Encryption key:77CE-AF2C-C8CE-3AE9-352E-5138-2AD8-C756-167A-7E95-0B4D-8371-1077-1C41-DA64-B2F6 [2]

          Link Signal level=16/65  

          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0

          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


I have to post the messages in a seperate post because of the char limit. It’ll take me 1-2 minutes to do that for obvious reasons :D.

Messages:


Aug  1 01:16:15 esoteric gconfd (root-5651): GConf server is not in use, shutting down.
Aug  1 01:16:15 esoteric gconfd (root-5651): Exiting
Aug  1 01:33:58 esoteric gconfd (root-8249): starting (version 2.22.0), pid 8249 user 'root'
Aug  1 01:33:58 esoteric gconfd (root-8249): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Aug  1 01:33:58 esoteric gconfd (root-8249): Resolved address "xml:readwrite:/root/.gconf" to a writable configuration source at position 1
Aug  1 01:33:58 esoteric gconfd (root-8249): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Aug  1 01:33:58 esoteric gconfd (root-8249): Resolved address "xml:readonly:/etc/gconf/gconf.xml.vendor" to a read-only configuration source at position 3
Aug  1 01:33:58 esoteric gconfd (root-8249): Resolved address "xml:readonly:/etc/gconf/gconf.xml.schemas" to a read-only configuration source at position 4
Aug  1 01:33:59 esoteric smartd[3907]: Device: /dev/sda, SMART Prefailure Attribute: 8 Seek_Time_Performance changed from 248 to 249
Aug  1 01:33:59 esoteric smartd[3907]: Device: /dev/sdc, SMART Usage Attribute: 209 Offline_Seek_Performnce changed from 196 to 195
Aug  1 01:43:56 esoteric su: (to root) geoff on /dev/pts/0
Aug  1 01:45:55 esoteric kernel: skge eth0: enabling interface
Aug  1 01:45:55 esoteric kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Aug  1 01:46:50 esoteric kernel: skge eth0: disabling interface
Aug  1 01:46:53 esoteric SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Aug  1 01:46:53 esoteric SuSEfirewall2: using default zone 'ext' for interface eth0
Aug  1 01:46:53 esoteric SuSEfirewall2: using default zone 'ext' for interface wmaster0
Aug  1 01:46:53 esoteric SuSEfirewall2: batch committing...
Aug  1 01:46:53 esoteric SuSEfirewall2: Firewall rules successfully set
Aug  1 01:46:53 esoteric su: (to root) root on none
Aug  1 01:46:56 esoteric SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Aug  1 01:46:56 esoteric SuSEfirewall2: using default zone 'ext' for interface eth0
Aug  1 01:46:56 esoteric SuSEfirewall2: using default zone 'ext' for interface wmaster0
Aug  1 01:46:57 esoteric SuSEfirewall2: batch committing...
Aug  1 01:46:57 esoteric SuSEfirewall2: Firewall rules successfully set
Aug  1 02:21:53 esoteric kernel: psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
Aug  1 02:31:38 esoteric gdm[2466]: WARNING: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Aug  1 02:31:56 esoteric gnome-keyring-daemon[11214]: adding removable location: volume_label_SU1100_001 at /media/SU1100.001
Aug  1 02:31:58 esoteric gconfd (root-8249): GConf server is not in use, shutting down.
Aug  1 02:31:58 esoteric gconfd (root-8249): Exiting
Aug  1 02:31:59 esoteric gconfd (geoff-2579): Resolved address "xml:readwrite:/home/geoff/.gconf" to a writable configuration source at position 0
Aug  1 02:32:03 esoteric pulseaudio[11451]: pid.c: Daemon already running.
Aug  1 02:32:03 esoteric pulseaudio[11451]: main.c: pa_pid_file_create() failed.
Aug  1 02:33:57 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 02:45:40 esoteric gnome-power-manager: (geoff) Power Manager is already running in this session.
Aug  1 02:45:40 esoteric gnome-power-manager: (geoff) Power Manager is already running in this session.
Aug  1 02:58:19 esoteric kernel: wlan0: switched to short barker preamble (BSSID=00:1e:74:5b:1b:a3)
Aug  1 03:33:57 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 03:33:59 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 82 to 85
Aug  1 03:34:00 esoteric smartd[3907]: Device: /dev/sdd, SMART Prefailure Attribute: 8 Seek_Time_Performance changed from 251 to 250
Aug  1 04:03:59 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 85 to 88
Aug  1 04:07:38 esoteric su: (to root) geoff on /dev/pts/0
Aug  1 04:33:57 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 05:03:59 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 88 to 85
Aug  1 05:33:57 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 06:31:16 esoteric su: (to root) geoff on /dev/tty1
Aug  1 06:31:20 esoteric init: Switching to runlevel: 3
Aug  1 06:31:21 esoteric kernel: compiz[11412]: segfault at 48 ip b7d52992 sp bfc76410 error 4 in libICE.so.6.3.0[b7d4b000+16000]
Aug  1 06:31:33 esoteric gnome-keyring-daemon[15815]: adding removable location: volume_label_SU1100_001 at /media/SU1100.001
Aug  1 06:31:35 esoteric gconfd (geoff-2579): Resolved address "xml:readwrite:/home/geoff/.gconf" to a writable configuration source at position 0
Aug  1 06:31:39 esoteric pulseaudio[15977]: pid.c: Daemon already running.
Aug  1 06:31:39 esoteric pulseaudio[15977]: main.c: pa_pid_file_create() failed.
Aug  1 06:33:57 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 06:37:45 esoteric kernel: wlan0: switched to long barker preamble (BSSID=00:1e:74:5b:1b:a3)
Aug  1 06:42:57 esoteric kernel: wlan0: switched to short barker preamble (BSSID=00:1e:74:5b:1b:a3)
Aug  1 07:03:59 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 85 to 88
Aug  1 07:03:59 esoteric smartd[3907]: Device: /dev/sdd, SMART Prefailure Attribute: 8 Seek_Time_Performance changed from 250 to 251
Aug  1 07:33:57 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 07:34:00 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 88 to 91
Aug  1 08:04:00 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 91 to 94
Aug  1 08:04:00 esoteric smartd[3907]: Device: /dev/sdd, SMART Prefailure Attribute: 8 Seek_Time_Performance changed from 251 to 250
Aug  1 08:33:57 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 08:33:59 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 94 to 91
Aug  1 09:04:00 esoteric smartd[3907]: Device: /dev/sdd, SMART Prefailure Attribute: 8 Seek_Time_Performance changed from 250 to 249
Aug  1 09:33:58 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 10:04:00 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 91 to 88
Aug  1 10:04:00 esoteric smartd[3907]: Device: /dev/sdd, SMART Prefailure Attribute: 8 Seek_Time_Performance changed from 249 to 248
Aug  1 10:33:58 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 10:34:00 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 88 to 91
Aug  1 10:40:10 esoteric kernel: wlan0: switched to long barker preamble (BSSID=00:1e:74:5b:1b:a3)
Aug  1 11:04:00 esoteric smartd[3907]: Device: /dev/sdd, SMART Prefailure Attribute: 8 Seek_Time_Performance changed from 248 to 247
Aug  1 11:33:58 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 11:33:59 esoteric smartd[3907]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 91 to 88
Aug  1 12:03:59 esoteric smartd[3907]: Device: /dev/sdd, SMART Prefailure Attribute: 8 Seek_Time_Performance changed from 247 to 246
Aug  1 12:33:44 esoteric dhcpcd[3402]: wlan0: renewing lease of 192.168.0.2
Aug  1 12:33:44 esoteric dhcpcd[3402]: wlan0: leased 192.168.0.2 for 86400 seconds
Aug  1 12:33:44 esoteric dhcpcd[3402]: wlan0: no renewal time supplied, assuming 43200 seconds
Aug  1 12:33:44 esoteric dhcpcd[3402]: wlan0: no rebind time supplied, assuming 75600 seconds
Aug  1 12:33:44 esoteric dhcpcd[3402]: wlan0: removing route to 169.254.0.0/16 metric 0
Aug  1 12:33:44 esoteric dhcpcd[3402]: wlan0: adding IP address 192.168.0.2/24
Aug  1 12:33:44 esoteric dhcpcd[3402]: wlan0: adding default route via 192.168.0.1 metric 0
Aug  1 12:33:44 esoteric dhcpcd[3402]: wlan0: adding route to 169.254.0.0/16 metric 0
Aug  1 12:33:44 esoteric modify_resolvconf: Service dhcpcd modified /etc/resolv.conf. See info block in this file
Aug  1 12:33:44 esoteric dhcpcd[3402]: wlan0: Failed to lookup hostname via DNS: Name or service not known
Aug  1 12:33:44 esoteric ifup:     wlan0     device: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
Aug  1 12:33:45 esoteric SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Aug  1 12:33:45 esoteric SuSEfirewall2: using default zone 'ext' for interface eth0
Aug  1 12:33:45 esoteric SuSEfirewall2: using default zone 'ext' for interface wmaster0
Aug  1 12:33:45 esoteric SuSEfirewall2: batch committing...
Aug  1 12:33:45 esoteric SuSEfirewall2: Firewall rules successfully set
Aug  1 12:33:46 esoteric syslog-ng[1788]: SIGHUP received, restarting syslog-ng
Aug  1 12:33:47 esoteric syslog-ng[1788]: new configuration initialized
Aug  1 12:34:48 esoteric kernel: klogd 1.4.1, ---------- state change ---------- 
Aug  1 13:33:48 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 14:33:48 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 15:33:48 esoteric syslog-ng[1788]: STATS: dropped 0
Aug  1 15:34:00 esoteric smartd[3907]: Device: /dev/sdd, SMART Prefailure Attribute: 8 Seek_Time_Performance changed from 246 to 248
Aug  1 15:36:29 esoteric su: (to root) geoff on /dev/pts/1
Aug  1 15:41:55 esoteric kernel: skge eth0: enabling interface
Aug  1 15:41:55 esoteric kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready


It appears as though you just have a poor connection (degraded and weak signal). Here is what my wireless connection looks like (iwconfig). The two things that stand out to me are bolded:

linux-scuq:~ # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"My Wireless"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:09:5B:D6:C5:46
          **Bit Rate=36 Mb/s**   Tx-Power=27 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:YARIGHT
          **Link Quality=75/100**  Signal level=-54 dBm  Noise level=-68 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.

1 megabit is actually only 128 kilobytes. Take the tcp overhead of 20-40 bytes off the top and you are looking at a pretty slow connection.

Yes, I hadn’t noticed that. Under windows it is usually 54mb. Do you have any ideas as to what could cause this?

The router position hasn’t changed and this is the same system upon which I run windows.

Is there a way to renew/refresh the adapter?

Off a hunch, I restarted my system.


iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"SKY07074"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:1E:74:5B:1B:A3   
          Bit Rate=54 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:77CE-AF2C-C8CE-3AE9-352E-5138-2AD8-C756-167A-7E95-0B4D-8371-1077-1C41-DA64-B2F6 [2]
          Link Signal level=17/65  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

By the time I got here to post that information it has already dropped too.


 iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"SKY07074"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:1E:74:5B:1B:A3   
          Bit Rate=11 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:77CE-AF2C-C8CE-3AE9-352E-5138-2AD8-C756-167A-7E95-0B4D-8371-1077-1C41-DA64-B2F6 [2]
          Link Signal level=18/65  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

54MB is g
11MB is b
1MB is a

It looks like it is having some sort of trouble with the g connection so its defaulting back to b. I honestly do not know. It may be a driver issue, but at this point its a bit over my head, I’ve never had problems like this myself :frowning:

Thanks anyway. I appreciate the help. :slight_smile:

I don’t know anything specific regarding the 8185 driver, but the MAC layer that
it uses is very responsive to the error rate. If it backed off from 54Mbs to 11,
then your connection is pretty flaky. Each driver in Windows uses its own
algorithm, and we have no way of knowing what happens there.

Do you have access to another Linux computer in your local network? If so, I
would suggest acquiring the source for a program called tcpperf and using it to
test your connection. It has the advantage of not having a lot of overhead.

I use the RTL8187B device. It doesn’t work with standard kernels until
2.6.27-rc1. It has a transmit rate of 16.8 Mb/s using tcpperf. That is a lot
faster than my cable modem’s rate of 8 Mbs.

Larry

It’s pretty stable atm at 54M. I keep checking it every so often. I have actually become suspicious of Monsoon. If I start it, my connection drops to 1M and never recovers. It’s probably in my head, but it seems pretty consistent at dropping the rate.

I’m convinced this is a driver thing. I went off and found rtl8185 drivers here: RepoView: MSI U100 (SLE_10-SP2)

I add them to the repository with the url: Index of /repositories/home:/civ75:/U100/SLE_10-SP2

I did a search for realtek via “Install Software” and it found them all. Yet, if I try to install any of them I get the warning message:


nothing provides kernel(kernel_irq) = 38604384a386996c needed by rtl8185-xxxxxxx-i586.rpm

I also tried ndiswrapper, I got the WinXP driver installed fine but the network config doesn’t find the ndiswrapper module.