Slow boot dumps me at console

My LEAP 15 Desktop was update from 42.3 using zypper dup procedure.
Nothing seemed unusual as the update proceeded.

The boot process takes a very long time buy openSUSE standards, something fails and I am dumped to a level 3 console.
I login as root, issue init 5 and system immediately displays a Greeter and login from there as user proceeds normally.
Once up, system seems very responsive and all functionality tried so far is fine.

I did pull this info after hacking about in various Forum items

Startup finished in 3min 31.590s (firmware) + 41.794s (loader) + 1.129s (kernel) + 1.385s (initrd) + 3min 39.368s (userspace) = 7min 55.268s

I have no idea where else to look for info on what is going on during boot.
Is there a way to monitor the console during boot, i.e. un-hide it from behind the “bouncing diamond above down carot” screen?

Sorry, not much to go on, but I am unsure what would be useful information.

I am running from the KF5 and QT5 repos,

The easiest way is to hit the ESC key as soon as you see that graphic.

However: I had a similar problem for one of my installs. And hitting ESC did not reveal the problem.

Another option: On the boot menu, hit the ‘e’ key. That gets you into an editor window to edit the boot commands.
Scroll down until you find a line starting “linux” (or might be “linuxefi”). Perhaps hit the END key to get to the end of that line. But then back up a little. Find the string “splash=silent” and remove that string. Then continue booting (CTRL-X).

That should give more detail. That’s how I found the problem on my one system that had difficulties. (It was doing a 90 second delay waiting for a file system that was never going to show up – essentially the same problem as in bug 1071354).

… in my case, I just change it to “splash=verbose”.

Maybe Plymouth hangs once in a while. I added at the end of the boot line


and booted (hit ctrl-x or F10). Result: booted in less than 10 seconds. I’ll put this line into the kernel parameters of the bootloader gui of Yast2.

Thanks for the suggestions.
I’ll give them a try

Well, that was interesting.
I went the splash=verbose route.

The time from entering my HDD crypto password to Greeter screen was maybe 3 seconds.
Fast enough for me.

I guess that says my problem was a Plymouth hang, …?
BTW, ESC was not working, likely because it was already hung when I tried it.
Thanks for your help

You can make that permanent by editing “/etc/default/grub” and then regenerating the grub menu (as described at the top of “/etc/default/grub”).

Plymouth can be a PIA at times. I have long since quit using it.

Instead, on each install, I remove Plymouth entirely and taboo it.

However, I do that less for the Plymouth problems and more for the sense of "awesome" watching the scrolling lines to see what openSUSE is doing during those seconds of boot time.

… or by using the Yast=>Boot Loader module and changing the line in there for the kernel parameters.

Does setting splash=verbose kill Plymouth, or just modify its behavior a bit?

As splash= is an optional kernel parameter, splash=verbose equates to splash=0, as well as the null string nrickert “applied”. I don’t know whether it directly affects Plymouth at all, since I never have it installed, but any of those equivalents turn off the boot message suppression that splash=silent causes.

In my case, I’m pretty sure that plymouth is still running, but it isn’t showing its splash screen. So I see the boot messages. These include a message that password requests (for crypto) are being passed to plymouth.

The reason I ask is that the boot process would hang with probability = 1 if I leave splash=silent and probability 0 if I set splash=verbose.

I was sort of expecting to see something to worry about/work on during the boot process.

Whatever the hang was occurred after the request for crypto information to unlock my HDD, which worked OK.

So, unfortunately, I don’t see a way to help the debuggers with and useful documentation on what is hanging

It is probably a plymouth bug. I’m pretty sure that there are several plymouth bugs open at the bugzilla. Some people are more affected than others, which probably depends on the graphics card.

If I see a Plymouth update wander by I’ll give it a try again

Splash=verbose works for me. :slight_smile: