Slow Boot. 90 seconds timeout

Hello.

My system stuck during boot after (I am not sure) changing the hostname. Checking the messages log I can see that the source of the problem is that the cr_backup.service timeouts. That is the 90 seconds boot freeze. You can see an extract of the log here [1]

Any advice in order to fix it?. I am not sure where I should start.

Thank you in advance.

Best.

Miguel

[1] Private Paste - Pastie

On 01/02/2012 01:46 PM, migmartri wrote:
>
> Any advice in order to fix it?. I am not sure where I should start.

you could start by providing more information…

-is your hardware a nettop, laptop, clustered super-computer or ???
-is this a headless server?
-please state your operating system and version
-are you using a desktop environment? which, and what version?
-please tell, are you using any of the following:
–RAID (which level and fake? software? hardwaree?
–LVM
–Btrfs
–Reiserfs
–NTFS
–IDF drives
–SATA drives
–partitions/drives attached via USB
–an encrypted file system
–networked partitions/drives which must mount during boot (where does
this “backup device” reside? and how is it connected?)
–any non-ext_ file system on your linux root partition (like NTFS)


DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

Hello.

Thank you for your reply.

I am using Opensuse 12.1, clean installed in a laptop. Ext4 FS for my root partition. My HD is an intel SSD 320.

Finally my DE is KDE 4.7.4.

Thank you.

Best.

Miguel

On 01/02/2012 03:56 PM, migmartri wrote:
> My HD is an intel SSD 320.

hmmmmmm…i’m not ‘up’ on SSDs, i guess there are something that need to
be followed, but overall i guess it should not be the source of a
timeout, especially not one saying

"backup.device/start failed with result ‘timeout’ "

well, see i don’t know, maybe a backup.device is exactly what to expect
with an SSD … but, if so where is it and why is it not playing the game?

so, did you recently set up an automatic backup routine or application
of some sort!

and, in your first post you wrote “after (I am not sure) changing the
hostname” so, i wonder what happens if you undo that change… while you
wait on a SSD guru to happen along, that is…)

frankly, i don’t have a clue what is causing the timeout but am thinking
maybe the cause will be seen in one of these:

please show us the terminal input/output from


zypper lr -d
df -hlT
cat /proc/partitions
cat /etc/fstab
mount
sudo /sbin/fdisk -l
sudo cat /boot/grub/menu.lst
cat /etc/hosts
cat /etc/hosts.YaST2save

copy/paste the in/output back to this thread using the instructions
here: http://goo.gl/i3wnr


DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

Hello.

I have just applied the patch regarding systemV that came via online update and the issue seems to be fixed now. The system boots without waiting to timeout.

Thank you for your help.

Best.

Miguel

To see a big picture (very big actually) of your boot process:

  • add a bootchart entry to your Grub menu with:
updategrub -i -b

bootchart should get installed the first time you use the option “-b”
See details here: http://forums.opensuse.org/english/other-forums/development/programming-scripting/458234-updategrub-opensuse-legacy-grub-not-update-grub-2.html#post2421328

  • Reboot and select the “(bootchart)” entry.
  • Open the file /var/log/bootchart.png with an image viewer.
  • Try to figure out … :wink:
  • Don’t know how bootchart is reliable with systemd … but it’s nice.