Slow access to USB3 attached NFS share


I do not have a lot experience with NFS shares and I am experiencing a really slow NFS access. Here below are my setup.

I have a decent laptop running openSUSE 13.1 and I connect a USB3 hard drive (formatted as NTFS) to the USB3 port of the laptop. I configured NFS shares as below.


When I try to access the USB3 share from a android based TV set top box wirelessly, the file listing, video playback (I do have some blue ray rips though) are really slow and sometime not even responsive…

I tuned NFS by increasing the read and write memory allocation but it does not seem help. Is there any special USB3 driver I should install on openSUSE? The laptop is wired into my network and set top box is connected via 802.11n WIFI (showing 72mbps for speed)

Any other tweak I should apply?

Suggestions are appreciated.


Some questions:

  1. Have you tried creating a share on the laptop itself? (Just to exclude the USB- connected storage from being the problem.)

  2. When the USB storage media is attached, is it being handled as a USB3 device? For diagnostic purposes, you can check how it is handled from a terminal with

sudo tail -f /var/log/messages

then attach the device and observe.

Despite the wireless set top box showing 72mbps, I suspect the issue may be network related and not really NFS itself, or even the related to access speeds you are seeing from the USB drive.

I would start at the bottom of the stack and work up to higher levels.

You could run iostat, bonnie++ or other performance tools on the NFS areas to establishe if there is a device or file system performance issue. Even USB 2.0 speeds should suffice to steam video (though I’m not sure what format you are streaming, etc.). I’m willing to bet local file system performance is fine, but still worth validating.

If those tests demonstrate good results, I would then suspect the wireless network. Wireless can just suck. Do you have another system you can test network performance with? If you don’t have another computer to test with, can you install iperf from Android on the set to box, or even a phone, etc. and see what kind of throughput you are getting? You could also try adjusting the channel and other tweaks (if available) in your wireless router.

If both device / file system performance tests, and network performance tests show no issues then I would look at NFS specific issues.

As another option to NFS, does the set top support DLNA? If so, you might try setting up a DLNA server and see what performance you might get that way.

i will do the performance test later today. I can not install IPERF though on the set top box.

My set top box supports NFS, Network Neighbour and UPnP, no DLNA. I guess i could try to get UPnP setup to see if any difference.

i did try to run bonnie++ to benchmark the USB3 hard drive with following command but it crashed my system…
bonnie++ -d /media/USB3/ -s 16G -n 0 -m TEST -f -b -u user*

I had to hard reboot the laptop…I guess something is not right with the hard drive or usb port…

I did just that but nothing helpful was really showing the log…it is indeed recognized as USB3 device.

I ran the bonnie++ again and this time it finished with the same command. However the output is not really that impressive.

Screenshot is here

Any suggestion on how to improve the performance of my USB3 hard drive? It is 1TB and I do not have another 1TB hard drive available So reformatting it to linux partition may not be an options for me.:(:(:frowning:

From the initial Bonnie++ results I’m not seeing any performance issue with the drive or USB bottleneck.

The 16GB sequential read results were 92440K/sec = 90MB/sec

You could run the same test on a non-USB file system mount point for comparison, but 90MB/sec on a single (rotational) drive is within expected performance results, even for direct attach SATA little loan over USB3.

What speed results are you expecting to see?

Can you install iperf on another device to test the wireless network throughput to your file server? I’m still suspicious of an issue here more than NFS.

As another experiment, is there any way to connect the set top box (temporarily) and the server to the same switch? Run a long cat5 just to try and eliminate wifi?