Sleep Causes Reboot

Sony VPCCW21FX - OpenSuse 12.1 KDE 4.7

Will seem to go to sleep but upon an attempt to wake it will reboot. Hibernate works almost all the time but occasionally I get a black screen. I only really need the sleep to work.
If somebody could point me in the right direction I’d be grateful, googling didn’t turn up much and what it did didn’t work.

Audio

Sound System : Intel® High Definition Audio

Expansion Slots

Multimedia Card Reader : One Memory Stick PRO™ media slot (Standard/Duo) with MagicGate® functionality One ExpressCard® /34 media slot One Secure Digital (SD memory card) media slot

Hardware

Camera : Built-in MOTION EYE® camera and microphone with face-tracking technology
Keyboard : QWERTY, 82 keys with 2.0mm stroke and 19.05mm pitch

Optical Drive

CD Support : Read / Write (CD/-R/-RW)
DVD Support : Read / Write (DVD±R/±RW/±R DL/-RAM)

Storage

Speed : 5400rpm
Storage Capacity : 500GB2
Storage Type : Serial ATA

Display

Backlight Technology : LED
Resolution : 1366x768
Screen Size : 14"4

General

Action Buttons : VAIO, Assist, Wireless on / off, Display Off
Computer Type : Notebook
Pointing Device : Electro-static touchpad (Multi-Finger)
Type of Use : Portable

Inputs and Outputs

DC-In : 1
Ethernet Connection(s) : 1
HDMI® Output(s) : 1
Headphone Output : 1
Internal Microphone : 1
Microphone Input : 1
USB Port(s) : 3 (2.0 compliant)
VGA Output(s) : 1
i.LINK® Connection : 1 (4pin) i.LINK® connector (IEEE 1394)6

Power

Battery Type : Standard Capacity Lithium-ion Battery
Power Requirements : 108W or less
Estimated Battery Life : Up to 4 hours7Standard Capacity Battery Up to 6 hours7Large Capacity Battery

Weights and Measurements

Dimensions (Approx.) : 13.44"(W) x 1.09-1.52"(H) x 9.18"(D)5
Weight (Approx.) : 5.3 lbs (with standard battery)

Environmental Information

ENERGY STAR® : 5.0
EPEAT™ : Gold
ROHS® : Compliant

Graphics

Chipset : Mobile Intel® PM55 Express Chipset
Graphics Processor : NVIDIA® GeForce® 310M GPU with Total Available Graphics Memory of 2007MB (max.)12
Graphics Video RAM : 256MB dedicated video RAM
Max. External Display Resolution via HDMI™ : 1920x108015
Max. External Resolution via VGA : 2048x1536

Memory

Installed Memory : 4GB (2GBx2)
Memory Type/Speed : DDR3/1066
Max. Memory : 8GB

Processor

Processor Cache : 3MB
Processor Speed : 2.13GHz1
Processor Technology : Intel® Hyper-Threading Technology20
Processor Type : Intel® Core™ i3 - 330M

Start-up Times

Average Boot Time : 60 sec18
Average Resume Time from Suspend : 2 sec18
First Boot Time : 5 min19

Wireless/Networking

Bluetooth® Technology : Integrated Stereo A2DP (2.1 + EDR) 11
Ethernet Protocol : 10Base-T/100Base-TX/1000Base-T
Ethernet Speed : Fast Ethernet (RJ-45)
Wi-Fi : 802.11 b/g/n3

I saw one option that called for you to try adding in the kernel load option ** hpet=disable** in your /boot/grub/menu.lst (as root) on the normal startup line for the openSUSE kernel load command. You can also look at your BIOS setup to see if you can disable HPET support in your BIOS under Power Management. Its the one suggestion I found for kernel 3.1 and suspend/sleep mode problems and worth a try anyway.

Thank You,

Modified by YaST2. Last modification on Mon Jan 16 17:08:51 PST 2012

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,7)/boot/suse.elegant
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title Desktop – openSUSE 12.1 - 3.1.0-1.2
root (hd0,7)
kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part8 resume=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part5 splash=silent quiet showopts vga=0x314
initrd /boot/initrd-3.1.0-1.2-desktop
hpet=disable

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 12.1 - 3.1.0-1.2
root (hd0,7)
kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part8 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
initrd /boot/initrd-3.1.0-1.2-desktop

###Don’t change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
rootnoverify (hd0,0)
chainloader +1

###Don’t change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
rootnoverify (hd0,1)
chainloader +1

It didn’t work, still the same as before. My BIOS is really locked down. Let me know if I put the option in the wrong place.

Modified by YaST2. Last modification on Mon Jan 16 17:08:51 PST 2012

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,7)/boot/suse.elegant
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title Desktop – openSUSE 12.1 - 3.1.0-1.2
root (hd0,7)
kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part8 resume=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part5 splash=silent quiet showopts vga=0x314 hpet=disable
initrd /boot/initrd-3.1.0-1.2-desktop

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 12.1 - 3.1.0-1.2
root (hd0,7)
kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part8 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
initrd /boot/initrd-3.1.0-1.2-desktop

###Don’t change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
rootnoverify (hd0,0)
chainloader +1

###Don’t change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
rootnoverify (hd0,1)
chainloader +1

Tried this too.

So this looks OK though I normally put such a command before showopts unless you need the ability to remove the command before you press enter alot of the time. The vga=0x314 is after so you could change the video mode number if you wanted to. I would like for you to give us a look at your fstab file and a few other commands. Open up a terminal session and do the following commands:

free
cat /etc/fstab
sudo /sbin/fdisk -l

Post the results here for us to see. I normally use the advanced editor mode, paste each text into a message, highlight that text and press the # code option. It will show up in a code block as the commands above. As for not working, often device drivers are listed as the reason such does not work and is also related to the desktop that you are using, both of which can have an effect on your computer’s ability to suspend properly. It is also possible to update the kernel to 3.2.2 if we had reason to think that could help.

Thank You,

I had the same problem under ubuntu and I just followed these instructions [1] and worked like a charm.

The main difference I guess with your Opensuse box is that you are using grub 1.

Best.

Miguel

[1] video - Sony Vaio FW350 reboots instead of waking up after sleep/suspend - Ask Ubuntu - Stack Exchange

# Modified by YaST2. Last modification on Mon Jan 16 17:08:51 PST 2012
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,7)/boot/suse.elegant
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 12.1 - 3.1.0-1.2
root (hd0,7)
kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part8 resume=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part5 splash=silent quiet **acpi_sleep=nonvs** showopts vga=0x314
initrd /boot/initrd-3.1.0-1.2-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 12.1 - 3.1.0-1.2
root (hd0,7)
kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part8 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
initrd /boot/initrd-3.1.0-1.2-desktop

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
rootnoverify (hd0,0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
rootnoverify (hd0,1)
chainloader +1

So then, we have a new option command to try and it is: acpi_sleep=nonvs, so let us know if this does anything for you.

Thank You,

# Modified by YaST2. Last modification on Mon Jan 16 17:08:51 PST 2012
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,7)/boot/suse.elegant
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 12.1 - 3.1.0-1.2
    root (hd0,7)
    kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part8 resume=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part5 splash=silent quiet acpi_sleep=nonvs showopts vga=0x314
    initrd /boot/initrd-3.1.0-1.2-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 12.1 - 3.1.0-1.2
    root (hd0,7)
    kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part8 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
    initrd /boot/initrd-3.1.0-1.2-desktop

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
    rootnoverify (hd0,0)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
    rootnoverify (hd0,1)
    chainloader +1
fait@linux-wxiv:~> free
             total       used       free     shared    buffers     cached
Mem:       3970876    1464692    2506184          0      28820     470512
-/+ buffers/cache:     965360    3005516
Swap:      4193276       1144    4192132
fait@linux-wxiv:~> cat /etc/fstab
/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part8 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part9 /data                ext4       acl,user_xattr        1 2
/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part6 /home                ext4       acl,user_xattr        1 2
/dev/disk/by-id/ata-ST9500325AS_5VE7HVFR-part7 /usr                 ext4       acl,user_xattr        1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
ait@linux-wxiv:~> sudo /sbin/fdisk -l
root's password:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc2fdcae6

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048   209922047   104960000    7  HPFS/NTFS/exFAT
/dev/sda2       209922048   314984447    52531200    7  HPFS/NTFS/exFAT
/dev/sda3   *   314984448   976773119   330894336    f  W95 Ext'd (LBA)
/dev/sda5       968366080   976752639     4193280   82  Linux swap / Solaris
/dev/sda6       314984450   891703890   288359720+  83  Linux
/dev/sda7       891705344   947384319    27839488   83  Linux
/dev/sda8       947386368   957876223     5244928   83  Linux
/dev/sda9       957878272   968366079     5243904   83  Linux

Partition table entries are not in disk order

OMG! It works! I have been struggling with that for seemingly forever. Thank You SO Much!

Happy to hear you found the right solution. You have migmartri to thank for finding and posting it here.

Thank You,

You are more than welcome :slight_smile: