SLED11 beta - problem with grub, lilo & xp (HELP!)

Hi guys.

In order to use my usb cellphone modem (alcatel x030) and connect to the internet, i have been eagerly waiting for this release to test whether this usb modem works and ditch xp to browse the internet (remaining as a gaming station only and a couple more things).

i guess it should function because of the new kernel and new network manager (this usb-modem works correctly under ubuntu)… but, ¿should i need gnome-ppp, kinternet or wvdial at the same time or should i use only NetworkManager?

First of all, download SLED11 beta here:

Returning to the main topic, I dind’t have the chance to test my usb modem because of the following rant, searching for serious help now:

My problem is (as i anticipated it in a previous post a few months ago), that my hardware doesn’t like grub at all!!
Since the time of 9.1 personal, later 9.1 professional and lastly SLED10, whenever i tried grub, my system became unusable (meaning unbootable for xp or both); only LILO came to my rescue for an error free booting and peaceful coexistance for all these years (SLED & XP).

Now, when installing SLED11 beta, after a message telling me that lilo support was droppped, i decided to continue using lilo; to my surprise, the same settings i used when installing SLED10 now won’t work in SLED11, forcing me to use grub (a message saying something about /boot/message > 65536 prevents lilo from being my boot loader).

now grub have messed up my mbr and cannot get rid of it (i placed grub first in my mbr, then i regretted it and now i can’t get it out of it. Later i installed grub correctly in the / partition [/sda7] but the one installed in the mbr is still there no matter how many times i have run the boot loader script) to force it out of the mbr.

Currently I only have access to SLED11, as grub wiped out the XP title entry on the OS selection screen. I have been reading hints and putting them into action on how to get XP title back and how to make lilo my preferred boot manager and my efforts have come to a halt.

fixmbr, fdisk /mbr, fixboot have not helped either, when i tried the xp commands, fixmbr didn’t work (grub remained there)… but when i used fixboot, it crashed the hdd, and told me that there was no disk or something like that. i had to reinstalled grub again to gain access to SLED11 at least.

Then i decided to try swerdna’s tips to regain access to xp with the very same grub and also tried on the other side, to let xp loader take control of the boot process; in both cases XP won’t run, but the data are still accesible from within SLED.

This is not what i want, i’d like to run xp correctly using either lilo or the xp boot loader; not grub that have failed for my hardware many times…

if you need outputs from command line, fstab, etc; let me know to give you more information on the case.

thanks a lot for your quick replies. i need to solve this inconvenience asap. i’m becoming desperate (stayed up late trying to figure this out and couldn’t sleep well last night because of this)


You might want to try this link:

SUSE Linux Enterprise Desktop (SLED) - NOVELL FORUMS

Its where the SLED forums are. And SLED-11 isn’t officially out yet. I believe the current SLED-11 release is for evaluation purposes only.

Imagine/pretend that I have opensuse 11.1

¿How would you solve this problem?

Thanks in advance for your replies.


This is going too far. There’s already enough real problems and questions to be solved and answered.
So, here’s my answer:

Imagine/pretend that you do have openSUSE 11.1, and there would be no problem at all ?

Serious: start trying and ask for help. There’s numerous people wanting to help you.

The problem i had is that SLED11’s grub damaged the mbr and wouldn’t accept other choices (only wanted to stay in the mbr, not the /root partition) plus erasing/damaging the xp entry in my hard drive.

i had a working dual boot system using lilo, xp & SLED10.

as SLED11 won’t accept lilo, i had to comply with grub, then nightmare began.

in the end i had to /fixboot, /fixmbr many times, then reformat & reinstall xp. there was no way i could enter xp again with the newest grub (i think it’s the very same grub shipped with os11.1) the way lilo successfully did previously.

i believe the main issue is the faulty grub (the only “functioning” option presented when installing).
why won’t they let me use a working lilo with SLED11?

i hope they get this fixed by the time SLED11 gets officially released (hopefully with a working lilo, of course).

thanks and waiting for your comments.