Skypeforlinux (RPM) is broken

The RPM download for Skypeforlinux is broken:

Error: INVALID:skypeforlinux- (file-7b329a59): Signature verification failed [4-Signatures public key is not available] Header V4 RSA/SHA1 Signature, key ID df7587c3: NOKEY
Header SHA1 digest: OK (f39a8d01e8103d4d1195b35aef1ef8dd075091b9)
V4 RSA/SHA1 Signature, key ID df7587c3: NOKEY
MD5 digest: OK (7b0e0ab027970292f202d35ecf30a160)

I reported this on the Skype website.

Its not broken, you do not have the key so zypper can not confirm it.

Try to ignore it.

I was not using zypper but YaST. YaST has installed the previous version and this version on another computer without any problems.

Yast and zypper are using both libzypp.

there is nothing really to report that’s not an error but a warning as you don’t have their public pgp sign key
after initial install the skype rpm will add the skype repo which I do believe provides that key as I’ve had updates and had no missing key warnings

zypper ar -f

select yes when asked weather or not to trust the key
then just pull skype with zypper (or yast)

zypper in skypeforlinux

or import the key

rpm --import

and then install it how ever you want to

Thanks. I am seeing the newbie tomorrow. So that is good timing. I was going to try and get the information off another newbie’s computer where it had installed fine (I don’t use it).

Worked fine using zypper as described above.

Sorry, but since the last upgrade – I have received this certificate error using for the NVIDIA and Skype repo’s …

Removing the repo and importing the certificate key did not resolve the problem (only the NVIDIA started to work).

The repo for skype always returns the cert. error. Ignoring it does not help

Gee - every upgrade the same – more problems and hours to fix em …
and I am not mentioning here the reoccuring crashes and problems using NVIDIA

Comment: Sorry guys, but other distros do well better

Comment: Sorry guys, but other distros do well better

skype is not an official openSUSE package, its build by Microsoft…
Also the Repo is not hosted by openSUSE.

Also Nvidia…

You have installed Leap?
And upgraded from which Leap version to which new Version?

Which error?

42.3 has been running fine (NVIDIA and Skype) … did an upgrade yesterday and both errors occured.

I am unable to fix skype using the described method.

Skype Repo :

Download (curl) error for '
Error Code 60
Error Message: SSL certificate problem: unable to get local issuer certificate

Ignoring does not work. Removing the repo and trying via cmd line neither.

Since the repo has not changed – (may be the certificate), the new ceritificate should be found …
When importing via cmd line I receive no error. But the repo throws the same error.

meant “update”

the SSL error suggests an issue with microsoft’s site and it’s up to microsoft to fix it
worst case scenario just download the skype rpm with your browser and install it wit rpm or zypper
click the link below
after saving it with your browser in a terminal run

sudo zypper in ~/Downloads/skypeforlinux_8.16.0.4-1.x86_64.rpm


rpm -i ~/Downloads/skypeforlinux_8.16.0.4-1.x86_64.rpm

and ignore the missing key warning (if you get one)