I’ve installed 11.4 on the laptop. So far there hasn’t been a huge leap of difference between the 11.3 and 11.4. But now I can’t use Skype. It’s installed and all of that. But whenever I open it, nothing happens. Any help here, please.


Had same problem. If you run skype from a terminal, you will probably see that you are missing a library. In my case it was (the openSUSE package containing it is libpng12-0.rpm) Installing the rpm solved it for me.

HTH. Ralph

Did it and worked straight away. Cheers! :good:

On 03/30/2011 09:36 PM, Mississippi-Ralph wrote:

> missing a library …

that and other Skype problems mostly avoided by following the path

Tried LibreOffice? Do that and help at
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

This is not a direct supply to the skype-problem but an easy workaround: If you have a gmail account (anyway it is free of charge) click the green phone button and install goggles video/voice-telefone. Worked right away, except that the outgoing caller video is upside down with my setting. I have not looked into how to fix this yet.

The google option is part of chat. It worked great for me until an update. I had to re-install the google voice extension and video accelerator (which took nearly 30 seconds) and all was fine again. A friend on a Mac gets no video but the voice is clear as can be.

oldcpu wrote once a good link to install skype.

# adding repo for non free Skype

zypper addrepo -f Skype


# adding libs for Skype

zypper install libqt4-32bit libqt4-dbus-1-32bit libqt4-x11-32bit libsigc++2-32bit xorg-x11-libXv-32bit

and then

# installing some programs

zypper install skype

and this too

# adding scripts

mv /usr/bin/skype /usr/bin/skype.real
chmod 755 /usr/bin/skype.real

echo '#!/bin/bash'>>/usr/bin/skype
echo 'LD_PRELOAD=/usr/lib/libv4l/ skype.real'>>/usr/bin/skype

chmod 755 /usr/bin/skype

after that it should work bueno.