Skype with video on OpenSUSE 11.1 x86_64

So i finally got Skype working on my OpenSUSE 11.1 64-bits install on my laptop (smolts -> Show Box).

Here is a quick run-through how i got it to work.

First get Skype here: left-click and save …or…


Install the dependencies:

sudo zypper install libqt4-32bit libqt4-x11-32bit

Install Alien:

sudo zypper install alien

Convert the .deb file into .rpm:

alien -r -c skype_ubuntu-

Install the new converted .rpm package of Skype:

sudo rpm -ivh skype-

Start Skype: Run it from the menu → Applications > Internet > More Programs > Skype


Some screenshots of Skype in OpenSUSE 11.1 x86_64 with E17:](
Audio in and output devices using ALSA](
Skype on the DBUS session bus](
Webcam with Skype! Working receive and sending of images with the webcam in my system (08ff:2810 AuthenTec, Inc.):slight_smile:

Not working:
Putting the webcam picture window on “Fullscreen” cause Skype to crash on my machine.

On-going investigation on what’s not working …


Just curious, are you able to see yourself in the preview window at the same time? This is what I can’t get working in Skype with any version of SUSE I’ve tried…

Yes, the preview pictures are shown in the option screen and in the video window during a call (as a picture-in-picture thing).

Awesome. I’m definitely going to try your method.


For me it installed OK on my HP Pavillion notebook dv6736nr. Got vídeo but no sound. What sound system did you use?

Thanks for the tips… got it working now :slight_smile:
But just out of curiosity, why do we need to install 32bit libs since we’re using the 64bit deb file?


I prefer not to use PulseAudio due to latency issue with audio playback. That’s the gamer in me talking; He hates high latency.

Good question. I asked myself that one too.

But than i saw skype was working and stopped caring to investigate about it. My guess now is that it was most likely to resolve a dependency issue with the .deb.

Tho i’m not running openSuSE 64-bits atm on my laptop. The frustration of the crashing Intel graphics driver when composite is enabled was droving me to killing spree.

hey dude, great job, nice tutorial, but I get an error while trying to install the .rpm file, here’s what came up in terminal

error: Failed dependencies: is needed by skype- is needed by skype- is needed by skype- is needed by skype-

Does it mean it cannot read my network,or ???

Thanks a lot. I need Skype stay in touch with my relatives. Please help.

Use the command

zypper what-provides filename

to find out which dependencies you’re missing on your system and install them.

I don’t have access to a openSuSE desktop system atm. I’ll post packages name at later time when i’m behind an openSuSE machine.

As for reply on your pm: The bar & desktop widgets you see are E17 svn , builded with easy e17 installer. But i don’t recommend beginner openSuSE users, such as yourself, to endeavor into building svn software from source. Yes, the ‘easy’ means “easier”. Not necessary really easy from a beginner users point of view.

hah … thanks.

Download (curl) error for ‘’:
Error code: Connection failed
Error message: couldn’t connect to host

Is the server down? I tried Yast>Software Repos but got the same output. Any guess?

On my opensuse 11 64b desktop with logtech 9000 cam with usb mike[build in] works fine with skype rpm [downloaded from skype]. Why compile?

I have missing dependencies, and I’m currently unable to install them.

When I tried to install dependencies →

zypper what-provides skype-
Building repository 'openSUSE-11.1-Update' cache [done]
Error building the cache:
'' '-o' '/var/cache/zypp/solv/repo-update/solv' '/var/cache/zypp/raw/repo-update'
error, the repository specifies extra information about package with checksum 'b742c488e35a93824474c8ae763f17d0566e8d95', which does not exist in the repository.

Warning: Disabling repository 'openSUSE-11.1-Update' because of the above error.
Loading repository data...
Reading installed packages...
No providers of 'skype-' found.

works very neat, thanks so much for this post!

i installed twice, the first time as you suggested, and it seemed to work fine, but then i reinstalled using sudo for the alien command (to avoid a denied access to .gfvs) and then installed libasound2-32bit, just to avoid some annoying errors verbosed in the terminal. as i said, the first time worked, and these two additional steps might not make any difference, although it works flawlessly now.

thanks again,


brilliant work…
it’s solutions and problem solving of this nature that makes this such a great forum… !
works like a charm !
8 )

Why all the extra work? The provided suse rpm and the static version from the skype website work perfectly!

You have to install 1 other package through yast or zypper (can’t remember which one right now), but that’s it.

I’ve been using those for years, and my webcam works perfectly :sarcastic:.

but I get an error every time I try to install the rpm with YaST…

Is it really a 64 bit version?
According to Skype, they don’t have 64 bit versions for Linux yet.

I was not able to install without installing 32 bit Qt libs.