Skype will not start

Hello, first of all I’m not a native English speaker, and more importantly, I’m new to Linux. I have used it for some times but never went behind basic use to use Internet, save files, write documents with OpenOffice…

I just installed the 11.2 version in 64-bit. I previously used a 11.1 version which was probably 32-bits, and on which Skype worked fine.

Now I re-installed Skype on the new version (I totally reformatted my system) but when I try to stat it, the cursor will bounce for about 15 seconds, then nothing happens.

Could someone please help me?

did you install the dependences

zypper install xorg-x11-libXv-32bit libqt4-32bit libqt4-x11-32bit

Sorry for including earlier but these are required for openSUSE 11.2 64 bit.

Oh-so-ignorant question: Do I just open a terminal and copy-paste your instructions, or is there something else to do first? Do I need to do it as root?
(Yes, I’m that clueless.:shame:)


The real problem is not openSUSE or 64 Bits but the “specialists” from skype packaging their “openSUSE RPMs”.

Have a look at this:

A) Older RPM-package:

rpm -qp --requires skype- 
warning: skype- Header V3 DSA signature: NOKEY, key ID d66b746e
libqt4-x11 >= 4.2
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1  
rpmlib(PayloadIsBzip2) <= 3.0.5-1

B) Latest RPM-package:

rpm -qp --requires skype- 
config(skype) =
qt >= 4.2
rpmlib(CompressedFileNames) <= 3.0.4-1

With older versions, zypper/YaST would automatically install missing 32-bit libs of qt4 (due to correct Requires of the package), but not with the most recent versions (due to “castrated” requires).

Seems the packagers at skype never heard of the “Autoreqprov”-tag.

You can and you do need to be root. In order to get to root in the console type

su -
then your root password (note:that the password will not echo to the screen so it looks like you are not typing anything don’t be alarmed)

Then copy and paste both zypper lines from above. You need both the 64bit and the 32bit versions of the libraries. Since skype is still only 32bit

We all start somewhere, by the way forgot earlier welcome to openSUSE:)

Here is a link that may come in handing with your quest to learn linux: Learn the Linux command line. Write shell scripts.

Thank you, now it works fine. Except for the sound

As I’m starting to notice, I’d never learn if everything went well!

Now there’s this:

SDB:Skype installation - openSUSE