Skype problems - recording voice sounds like chipmunk and skype not in status bar

I’ve installed Skype on openSUSE-LEAP-42.1 (on my mother’s PC) and I’m having problem with Skype recording of any voice. She uses a logitech C270 webcam that has worked with openSUSE-12.x versions, 13.1 and 13.2 with Skype.

The first time Skype is run after a fresh boot, any voice sounds like a chipmunk. this can be reliably reproduced with Skype test call (or with a phone call to a 3rd party). I’ve tried unsucessfully the following:

  • removing /home/mother/.skype
  • removing /home/mother/.config/pulse and /home/mother/.pulse
  • editing /etc/pulse/daemon.conf, replacing “; default-sample-rate=44100” to “default-sample-rate=48000” followed by a reboot.
  • editing skype control of C270 webcam
  • changing skype setting “allow skype to automatically adjust my mixer levels”.

None of the above work in isolation nor all done at once. If after hearing the chipmunk, skype is closed and re-opened, often the chipmunk voice will disappear, and one will have their regular voice recorded.

4 to 5 years ago there was a kernel bug that was fixed to stop this. Any ideas as to what could be a fix ?

Further, Skype is not showing up in the status panel at the bottom. I have the option “start skype minimized in the system tray” selected and deselected (rebooting between changes) and it makes no difference.

She has the latest Leap updates installed.

I only have local access to this PC for another ~20 hours, after which I will need to access remotely (via ssh/vnc) > 7000km away.

Any help/suggestions for the two problems is appreciated. As noted - the problem did not exist with openSUSE-13.2 and earlier versions (on identical hardware).

I note the following which may explain the status bar absence:

System tray icons for applications such as Skype no longer show

Plasma 5 has dropped the support for the legacy system tray protocol, also known as XEmbed. KDE software is unaffected as it uses the new Status Notifier protocol, but other applications may not appear anymore.

Qt4 applications (includes Skype) - Install the sni-qt package and logout. Upon the next login Qt 4 applications will show up in the system tray. As Skype is a 32bit application, you will have to install sni-qt-32bit as well if you are on a 64bit system.

I’ll give that a try tomorrow when I visit my mother’s place.

However thats the minor problem. The major problem is the “chipmunk” sound. Although I cleared out the old ‘skype’ and ‘pulse’ configuration files, possibly there is something desktop related (as I kept her old /home from openSUSE-13.2. Time permitting tomorrow (as I fly back to Europe soon) I’ll create a new user on her PC and see if the new user has the same Skype chipmunk sound recording problem.

I applied the above recommendation to install “sni-qt-32bit” and it appears to work (sni-qt was already installed). I need to test it a few more times to confirm repeatability.

I also may have found a work around to the chipmunk sound problem. I discovered that a solution is to tell the system never to autosuspend USB device. This is done by adding to the kernel boot code the entry


I’ve performed a couple of tests and this appears to work.

I do not know, thou, of any negative side effects of this autosuspension boot code being nominally applied. I need to both test this some more, and also research this some more.

Because this is not my PC, and because it is a PC that is > 7000km away from where I live, I do not feel comfortable raising a bug report this as I am not able to support any developer/packager efforts to address this chipmunk audio (in skype) problem.

I am very interested in this since I use skype a lot to contact relatives and I am a bit worried after reports that Microsoft’s skype support was dropped with the latest update end of February. (see and in German What version are you using there - I am using skype- and it is still working.

This is on my 90-year old mother’s openSUSE-Leap-42.1. She now has skype-

I suspect I have the same version on my PCs.

I was very (pleasantly) surprised to find the “never to autosuspend USB device” approach fixed the chipmunk recording problem with Skype. I now have that boot code permanently applied in grub2.

I subsequently conducted over a dozen reboot / tests and this “sni-qt-32bit” installation appears to have worked wrt ensuring skype is in the Leap-42.1 KDE-5 panel.

I also conducted over a dozen reboot / tests and this kernel entry appears to have worked wrt solving the chipmunk sound in Skype.

I still need to research this.

I’m now over 7000 km away from my mother’s PC, so any further changes I do will need to be performed remotely.