Skype-playback system does not work.

I have OpenSUSE 11.0 and I installed Skype (not from Linux but from zip).
If you test you get a message that audio playback system not working.
Ekiga is also not working for pc-to-pc calls.
Ramachandran

Hi,

I’ve had a lot of trouble with skype too. I’ve managed to make it work under certain conditions. Try them to see if they work for you:

Go to skype and then go to options -> Audio Settings

There, You have to choose Sound input, Ring sound output and sound output. DO NOT leave them as default, or skype will never work.

The problem with skype in linux, is as follows. Linux has ALSA which has the drivers for your audio card. ALSA can access your card directly. Unfortunately it cannot manage several uses of the card at a time (for example if you play music and at the same time you are chatting using pidgin or gmail. Everytime you get an instant message beep you would get distorted playback of your music). To fix this, the linux developers came up with PulseAudio. This software is able to ‘mix’ sounds from different sources without interfering. Unfortunately, PulseAudio is not supported by skype nor by flash. Flash works ok, although it has its issues. But skype doesn’t work at all with pulse.

In order to make skype sound work, you have to select your sound output to be directly from ALSA (use the test sound button until you get something, you could try OSS too). I also recommend that you do not use any other application that may use sound at the same time. This will result in the same problem. Also, if you were playing your music and suddenly closed the application and decided to use skype, I suggest you wait a few seconds for ALSA to be fully ‘liberated’ and ready to use by skype.

This works well for me. Hopefully in the future flash and skype will add better support for pulse and we won’t have this problem.

Andres

Andres, I can hear myself in the headphones, so the microphone is working. But when I do a test call to Skype and I record a message as requested, when it plays back there is nothing. So I can hear myself “live” but apparently my voice is not getting out to Skype.

Per your advice not to use the default settings, which do you suggest I try? I have no idea what any of the selections mean.

Thx
socref

If you can hear the test call voice then your audio playback should be fine, but your audio input is messing up.

What are your options for sound input and output? So I can tell you which one to choose to see if it works.

OK, thanks. Here’s what I have.

Sound In:
default
HDA Intel (hw: Intel,0)
HDA Intel (plughw:Intel,0)
HDA Intel (hw:Intel,1)
HDA Intel (plughw:Intel,1)
HDA Intel (hw: Intel,2)
HDA Intel (plughw:Intel,2)
hdmi

Sound Out:
default
HDA Intel (hw: Intel,0)
HDA Intel (plughw:Intel,0)
HDA Intel (hw:Intel,1)
HDA Intel (plughw:Intel,1)
HDA Intel (hw: Intel,2)
HDA Intel (plughw:Intel,2)
hdmi

socref

ok great, now could you run this command on your terminal/console:

cat /proc/asound/cards

and please paste the output you get, in order to have a better idea of which device to choose.

Andres

Here you go…

gil@phred:~> cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfdff4000 irq 22
gil@phred:~>

Are you using KDE or GNOME?

Anyways choose either of these options for both input and output:
HDA Intel (hw: Intel,0)
HDA Intel (plughw:Intel,0)

Then click on “make a test sound” and also try the test call. If it doesn’t work and try other devices and run the tests again until you hear a sound and you can record your voice.

If nothing works, then set it to your device number zero. Then you have to do the following in your command line:

alsamixer

There, go to capture (move with tab and arrows, up and down increase volume). Increase the volume of your mic in case it’s been muted. Try using the ‘mic boost’ option if you have it. Then try skype again.

If that still doesn’t work, then do the following:

arecord --list-devices

And show me the output you get in your terminal

Andres

Andres,

Using HDA Intel (hw: Intel,0) I hear sound in my left ear only, and I hear the announcement asking me to record a message, but I don’t hear my own voice played back. It apparently is not being recorded.

Using HDA Intel (plughw:Intel,0) I hear the test sound in both ears, but I can’t make a test call. Skype won’t work with that setting and displays a message saying “Problem with audio playback.”

So I reset both to HDA Intel (hw: Intel,0) assuming that is what you meant by “device number 0.” I went to the alsamixer per your instructions and raised the mic levels wherever they appeared. I also raised the capture settings wherever they appeared.

Retried, but same results as before.

So here is the output of arecord --list-devices.

Note, I am using KDE 3.5 and SuSE 11.0.
Thx

gil@phred:~> arecord --list-devices
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: ALC883 Analog [ALC883 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
gil@phred:~>

ok,

So you have device 0, 1, and 2. Device 0, you tell me, doesn’t work. Thus try device 1 (plughw) as your output so you can hear it on both ears. An choose device 1 hw as your input device. Try that. If it doesn’t work then try device 2. If that still doesn’t work, try using device 1 plughw for output and 2 hw for input. Try as many combinations as you can think of. If it still doesn’t work then try this on your command line:

speaker-test -c2 -l5 -twav

and let me know if you hear a lady speaking front left and right.

if that works then your audio should be ok. I’m running out of ideas, hopefully any of these will work. What kind of microphone are you using? is it usb or regular?

Andres

Tried everything. No better. I did hear the voice “left front, right front.”

microphone is combined with headset. Regular plugs on front of the pooter (same plugs as on sound card on rear).

Thx
socref

Allright. Open up your terminal/konsole and do this:

> cat /proc/asound/pcm

and this:

> arecord --list-devices

Show me the output

Andres

Hey, Andres. I finally got it working!! lol!

I clicked through every microphone setting I could find in KMix and Alsamixer but nothing seemed to make a difference. Finally I found an answer on an Ubuntu forum at this URL:
Fixing the Errant Microphone « Ubuntu Blog

The instructions appear to be quite similar to those you suggested. But somewhere in the process this time I must have unmuted the microphone despite the fact that everything I had looked at each time previously seemed to indicate that the mic was not muted.

And, of course, as I stated in the beginning, throughout the process I could hear my voice in the headset – the mic absolutely was live. But for reasons unknown the signal was not getting out to Skype.

Anyway, the working audio settings in my Skype are:

in: hw:Intel,0
out: default

Many thanks for all your great suggestions and patience.:shake:
socref

Good evening,

I don’t know if I can go on with the same post, but I am the same problem with skype (in particular after update from 11.0 to 11.1).
My sound system now is working but not with skype.

I read your post and I tried to solve the problem according to the instruction in the link
Fixing the Errant Microphone « Ubuntu Blog

but now situation is worse than before.

Before following instruction as per the above said link I had the following situation:

Using HDAATI SB (hw: SB,0) I hear sound in my left ear only, and I hear the announcement asking me to record a message, but I don’t hear my own voice played back. It apparently is not being recorded.

Using HDAATI SB (plughw: SB,0) I hear the test sound in both ears, but I can’t make a test call. Skype won’t work with that setting and displays a message saying "Problem with audio playback.

Now after having made changes in alsamixer I don’t get any sound signal during sound skype test and skype test call as well.

I don’t understand… My setting in alsamixer it seems to be normal:
Master is on 95%
Capture is L R Capture 94% (typing space you get ------?), I don’t know what is the right option?

I try to post some information about my device:


linux-carla:/home/carla # cat /proc/asound/cards 
 0 [SB             ]: HDA-Intel - HDA ATI SB 
                      HDA ATI SB at 0xfe024000 irq 16 


linux-carla:/home/carla # arecord --list-devices 
**** List of CAPTURE Hardware Devices **** 
card 0: SB [HDA ATI SB], device 0: ALC888 Analog [ALC888 Analog] 
  Subdevices: 1/1 
  Subdevice #0: subdevice #0 
card 0: SB [HDA ATI SB], device 2: ALC888 Analog [ALC888 Analog] 
  Subdevices: 1/1 
  Subdevice #0: subdevice #0 


linux-carla:/home/carla # cat /proc/asound/pcm

00-02: ALC888 Analog : ALC888 Analog : capture 1

00-01: ALC888 Digital : ALC888 Digital : playback 1

00-00: ALC888 Analog : ALC888 Analog : playback 1 : capture 1


I hope I can have your help, because after several trials I don’t know what to do anymore.

Tnank you for your attention.

I understand your frustration. You’re experiencing exactly what I did using SuSE 11.0.

I suggest going back to the Alsamixer settings and rechecking everything, particularly to be absolutely certain that you don’t inadvertently have the mic muted.

I was 200% sure that the mic on my system was live (I could hear it in my headphones), yet for reasons I have never figured out it was muted going out to the Internet (to Skype). So I clicked EVERY setting in Alsamixer to be certain nothing was muted.

Suddenly I could send mic signal to Skype. I don’t know why and I don’t know where anything changed in Alsamixer. I only know that something I clicked in Alsamixer made all the difference.

Then it was a matter of finding the settings in Skype that let me hear the Skype message in both ears. The final “in” and “out” settings I described in my previous message.

Hope this helps.
socref

Hi there,

Ok, I’m going to ask you a few things to see if they help you:

First tell me if you’re using KDE or GNOME? if KDE which version?

Now, exit all running programs you have (especially firefox, banshee/amarok and all multimedia programs), except for your konsole/terminal. Wait a few seconds and run skype by typing: skype &

Tell me if you get any error messages or warnings.

Once in there go to Audio Settings and choose the device with (plughw: SB,0). And try playing the test sound and then making the call. Let me know if you get the error in playback again.

If this doesn’t work, quit skype and in your terminal/konsole type:

speaker-test -c2 -l5 -twav

You should hear a lady saying front left and front right 5 times.
If not, let me know

If it succeeds, then do the following

alsamixer -c 0 listing

Press TAB to move to the ‘Capture’ menu, then move with the arrows to increase the volume of your ‘mic’ and ‘capture’ parts (Use space to activate in case they are turned off).

Then do the following with your mic plugged in and record something for 20 seconds:

arecord -f cd -D hw:0,2 -d 20 test.wav

Here hw:0,2 means your are choosing your card 0 and device 2 (which is only capture).

If it succeeds, then you can play your recording as follows

aplay -f cd test.wav

If this works, then skype should work… If it doesn’t let me know. Oh, please tell me the list of devices you have available for selection in Skype’s Audio Settings (both input and output).

Andres