Skype no input from mic

openSUSE 13.2 64bit KDE

After six months of no use on my notebook I did a “zypper up”. Now I get no onboard microphone input using Skype. Now here is an odd test observation that may not be significant. When I run pavucontrol and adjust the microphone input level while talking the level increases as I raise the gain until it reaches 36% and then cuts off completely. Even if I set it lower than 36% Skype gets no input.

Any suggestions would be appreciated.

skype is 32 bit maybe some 32bit libraries got removed?
try reinstalling skype with zypper

zypper in -f /path/to/skype.rpm

zypper should pull all missing packages

Output from your suggestion…

 # ls
skype-4.3.0.37-suse.i586.rpm
# zypper in -f skype-4.3.0.37-suse.i586.rpm
Error building the cache:
|] Failed to cache repo (1).
Building repository 'Plain RPM files cache' cache ..................................................................[done]
Error building the cache:
|] Failed to cache repo (1).
Warning: Skipping repository 'Plain RPM files cache' because of the above error.
Some of the repositories have not been refreshed because of an error.
Loading repository data...
Reading installed packages...
Package '_tmpRPMcache_:skype=0:4.3.0.37-suse121' not found in specified repositories.
Resolving package dependencies...

Nothing to do.
# 

try using the full path to skype-4.3.0.37-suse.i586.rpm
something like

zypper in -f /home/<you>/Downloads/skype-4.3.0.37-suse.i586.rpm

replace /home/<you>/Downloads/skype-4.3.0.37-suse.i586.rpm with skype’s real path

I had already done that, but to make sure I repeated it…

# zypper in -f /home/ion/DATA/TEMP/skype-4.3.0.37-suse.i586.rpm
Error building the cache:
|] Failed to cache repo (1).
Building repository 'Plain RPM files cache' cache ..................................................................[done]
Error building the cache:
|] Failed to cache repo (1).
Warning: Skipping repository 'Plain RPM files cache' because of the above error.
Some of the repositories have not been refreshed because of an error.
Loading repository data...
Reading installed packages...
Package '_tmpRPMcache_:skype=0:4.3.0.37-suse121' not found in specified repositories.
Resolving package dependencies...

Nothing to do.
#

I’d recommend cleaning your rpm cache, and doing a manual refresh

zypper clean
zypper ref

then you can try again
if that doesn’t work your rpm database might be damaged you may need to rebuild it

         rpm --rebuilddb     


you might have turned off autorefresh on some repo’s and a bad cache might be causing this, what is the state of your repo’s

zypper lr -d

edit
are maybe using btrfs it wasn’t the default on 13.2 but it was an option, your root partition might be running out of space, if you have btrfs clean some snapshots, if you are running out of space do some cleaning.

Invoked all the above suggestions. Not using btrfs. All enabled repositories are autorefreshed. Nothing changed.

and where is the repo list?
post the output of

zypper lr -d

how much free space do you have in root?

it looks like more then skype is miss configured, imo you have some permission issues, did you maybe stop an update before it was finished?
try updating your system again, run

zypper up

the more info you can provide the better help you can recive just saying it doesn’t work gives us little information to help
#1 rerun zypper up
#2 tell us how much free space you have in root /
#3 tell us you repo’s

#1

# zypper up
Loading repository data...
Reading installed packages...


The following 40 items are locked and will not be changed by any action:
 Available:
  akregator amarok apparmor-docs apparmor-parser apparmor-parser-lang apparmor-profiles apparmor-utils
  apparmor-utils-lang apper digikam digikam-doc digikam-lang gstreamer-0_10-fluendo-mp3 hugin
  kaddressbook kontact korganizer libreoffice-base libreoffice-base-drivers-mysql
  libreoffice-base-drivers-postgresql libreoffice-branding-openSUSE libreoffice-calc
  libreoffice-calc-extensions libreoffice-draw libreoffice-filters-optional libreoffice-gnome
  libreoffice-impress marble marble-data marble-devel marble-doc midori-lang plymouth samba samba-32bit
  samba-client-32bit smplayer-lang snapper yast2-samba-client yast2-samba-server


The following package update will NOT be installed:
  libodfgen-0_1-1


Nothing to do.
#

#2

# df
Filesystem     1K-blocks     Used Available Use% Mounted on
/dev/sda2       20510716  9178704  10267056  48% /

#3

# zypper lr -d
# | Alias               | Name                         | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                          | Service
--+---------------------+------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------+--------
1 | ftp.gwdg.de-suse    | Packman Repository           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/     |        
2 | repo-non-oss        | openSUSE-13.2-Non-Oss        | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |        
3 | repo-oss            | openSUSE-13.2-Oss            | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/     |        
4 | repo-update         | openSUSE-13.2-Update         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                    |        
5 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/            |        
# 



Since everything was functional when I stopped using my notebook six months ago and 13.2 is close to the end of its lifetime I think it’s going to be simpler in the long run if I install 42.1 and start with a clean slate.

I appreciate all the thought you have put into it and thank you for your assistance.

you seam to be running out of space you are using 9178704 out of 10267056 that’s 90% of root
you should take note that the /var dir gets filled up with a lot of cache during regular use that gets deleted when you power off, so you might be using more then 90%

I don’t know how your system is setup so this is a guessing game, yast might have removed some of the 32bit libraries to free up space and you need those for skype to run.
maybe someone else has a better idea.

check and see if you have the 32bit pulse libraries

zypper se -si libpulse0-32bit

and

zypper se -si libpulse0

As I reported I am no longer trying to solve this problem but just to set the record straight, if you look at my post again, it shows some 10 gigabytes of available space. I believe that should be sufficient for the /var directory.

As for your suggestion “yast might have removed some of the 32bit libraries to free up space and you need those for skype to run”, I can report again that Skype IS running.

In any case, many thanks for your advice and suggestions.

you are using 90GB in your root and it’s not a btrfs file system how did you manage that?
I thought your root was 10G and you wore using 9G (I didn’t check the numbers too closely)
as I said you seamed to have a permission issue, the only reason I thought you might be running out of space is because some users have reported zypper issues when low on space.

Please note…



**Device     Boot    Start       End   Sectors   Size Id Type**
/dev/sda2  *     4208640  46153727  41945088    20G 83 Linux

…my root partition is only 20GB and I am only using approximately 9GB…

# df

Filesystem     1K-blocks     Used Available Use% Mounted on 
/dev/sda2       20510716  9178704  10267056  48% /

…and it is formatted as ext4.

Thank you for your assistance, but I am no longer trying to resolve the problem.