Skype installation issues


I am a new user with a new laptop which runs GNOME and I’m trying to download skype however the error message I get reads:

“dependancy resolution failed
Unresolved dependancies:
Installing skype- packages)
There are no installable providers of for skype- packages)”

I don’t understand what this means? I then went to resolve conflicts via yast but that just told me there were no available patches. I don’t know what to do next? must be a typo, should be

Running 64bit openSUSE? Install libqt4-32bit, and you have it. Did you try, in the Software Installer, to search for the missing package with the option ‘Filelist’ checked? Then it shows up, in libqt4, libqt4-32bit and libqt4-debiginfo.

But…you can also download the ubuntu amd64.deb file and use ‘alien -r xxxamd64.deb’. Software search at will show you a one-click install for alien. The command will generate a 64bit installable rpm-file. To install use
su -c ‘rpm -iUvh skype…rpm’
Works like a charm here.

Good luck, get back to us if needed

um whoa

a) how do I know I’m running 64bit openSUSE, I just assumed I was?
b) where do I find/how do I install libqt4-32bit?

Feeling a bit stupid here and way over my head! Thanks for the quick response

As root, just type:
zypper install libqt4-32bit

After that, try installing Skype again.

I’m having pretty much the same issue. When I try to run Skype off the desktop the “loading” icon for it appears, but Skype never starts up. After installing the libQt thing, I got this in the terminal…

linux-2v48:/usr/bin # ./skype
./skype: error while loading shared libraries: cannot open shared object file: No such fileor directory
linux-2v48:/usr/bin # zypper install libqt4-32bit
Loading repository data...
Reading installed packages...
'libqt4-32bit' is already installed.
Resolving package dependencies...
Nothing to do.
linux-2v48:/usr/bin #

First go to
Perform search for “alien”.
Install “alien” via One-click.

Now you have the program “alien” installed, which can convert debian install packages (like for Ubuntu) to rpm packages (for openSUSE).

Next, open a terminal window (konsole) and run command below:


This downloads the 64bit skype package for Ubuntu, skype-ubuntu-intrepid_2.1.0.47-1_amd64.deb
Now we need to convert it to an rpm-package and install it, still in the terminal window:

su -c ‘alien -r skype-ubuntu-intrepid_2.1.0.47-1_amd64.deb’
-Enter root password when asked for. Command will end with ouput: skype- generated. Now you can install the rpm with the next command, still in the terminal window:

su -c ‘rpm -iUvh skype-’
-Enter root password. You’ll see either an error message or a primitive progress bar. On error message, get back with the message, on success, please let us know as well.

It runs on both my systems and works after some fumbling around with the mixer settings. is provided by libqt4-x11-32bit
So, install that:

zypper install libqt4-x11-32bit

(Alternatively, you may follow instructions given by Knurpht).
Also, please note that there is no 64bit version of Skype and even the rpm file from debian is not actually 64bit.

You’re right. I missed the new missing dependency. Don’t know about the actual arch of the ubuntu file, but alien creates an x86_64-rpm, which installs and runs fine.

Okay, I tried the instructions from the last two posts and finally got the loading bar. When I enter ./skype from the desktop, I see the loading icon and a skype process on the taskbar, but it gives up on loading after 30 seconds.

This may be a stupid question but I can’t seem to answer it on my own and I think it’s the key to me solving this (yes, it’s still not working). I can’t install libqt4-32bit because “root privaledges are required for running zypper” (yup understood, fine) however I can’t then work out how to get root privaledges…

I know my root password and whenever I do anything else which needs it I get prompted and it works. This is not prompting me for my password though and typing it in has no effect whatsoever. Do I need to become the root? how?

I’m still so confused!!!

To become root type at the console prompt:

su <ENTER>

and then it will ask for the root password.

To restore the console to the normal user type:

exit <ENTER>

Here’s what I did to get Skype running on openSUSE 11.2 x86_64 (64-bit):

cd ~
mkdir skype-stuff
cd skype-stuff
sudo zypper install skype-*.rpm

** Now, unfortunately, it doesn’t handle dependencies on 64-bit Linux well, so after trying to launch Skype several times and tracking down the missing library dependencies, I also had to install the following packages:

sudo zypper install xorg-x11-libXv-32bit libqt4-32bit libqt4-x11-32bit

I hope this helps!

By chance I have also recently installed Skype, and while it runs initially, so that I can log in to my account, when I run the call back sound test I get a large number of command line errors:

ALSA lib pcm_dmix.c:867:(snd_pcm_dmix_open) unable to open slave

and I hear no playback of my voice. Is this perchance related to the "works after some fumbling around with the mixer settings. " in one of the posts?

Also, I do not get a video screen, as I have come to expect from my Windows side installation. Is this not the default in Linux, or does it only come up when you attempt a call?

> Also, I do not get a video screen, as I have come to expect from my
> Windows side installation. Is this not the default in Linux, or does it
> only come up when you attempt a call?

the screen comes up after connected to the other party if you have
set the skype video option to “Start my video automatically when i am
in a call”

and, well…it won’t work at all if your webcam is not recognized…go
to the skype options, select “Video Devices” and see if yours is
recognized…if not see and the forum
search function to find previous posts on webcam ops…


Which is not zypper’s “fault”, the problem is a very badly built rpm package.

rpm -qp --requires skype- 
config(skype) =
qt >= 4.2
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

While the last stable version shows you this:

rpm -qp --requires skype- 
warning: skype- Header V3 DSA signature: NOKEY, key ID d66b746e
libqt4-x11 >= 4.2
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1  
rpmlib(PayloadIsBzip2) <= 3.0.5-1

Installing version locally with “zypper in skype-version.rpm” would pull missing dependencies, the rpm for 2.1.0 ist just missing this information so zypper can not do its job, because he doesn’t “know” what dependencies will be needed.

Maybe the packagers from skype need to learn a lesson about RPM packaging, especially about the option “AutoReqprov”.

to use skype with opensuse go to :

Skype HOWTO - openSUSE

and enjoy!