Skype installation doesn't work, needs libQtGui.so.4

I’ve installed the OpenSuse version of Skype, downloaded from the Skype website. When I try to run it, I get this:

skype: error while loading shared libraries: libQtGui.so.4:
cannot open shared object file: No such file or directory

As far as I can tell, I have all the available qt packages installed, libqt4 and libqt4-x11 in particular.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

You’re on 64-bit, probably, and that file is 32-bit. Skype is TERRIBLE
about listing its dependencies and so you’ll get to fight a few of these
(sorry).

libqt4-x11-32bit

Good luck.

On 02/01/2011 06:06 PM, pwabrahams wrote:
>
> I’ve installed the OpenSuse version of Skype, downloaded from the Skype
> website. When I try to run it, I get this:
>
> Code:
> --------------------
> skype: error while loading shared libraries: libQtGui.so.4:
> cannot open shared object file: No such file or directory
>
> --------------------
>
> As far as I can tell, I have all the available qt packages installed,
> libqt4 and libqt4-x11 in particular.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJNSLMpAAoJEF+XTK08PnB5K1UQALOHNzjSizU41+gpMEASumEC
Q3GkU8Y5Io7bH/rsiCjm6bobCReEnlkUH0/ZO8D6mga1okLxUbfi//ioznxaO1XE
cmjHXPj5L7Ci4st6eoro3ZpZaXqxd2N6IsG1JQ+aayQNNS+AeNLFWl8KqyYYSAVt
fAaTnda9U6O7fDKSxFmfgGGv68WjHmu2iWAd/43sfShPTFjh2wo7Hix/iTANq4bn
E1Dr22JkOJN+RgTx1AHJ5+uuvFf4WaDcAOjCgtsyBGfMshZzzD1Xq7d5EF5SHaUx
FR/S3JojZeTSRSm96DjuNHsAP54iztL0fuROTt2t7blL18xuixV2mneZSdcbVStf
flsl/rXDCh6JL5DrR9DKA5/Cehyvo4cX6Xi8B4/zi2Lw1xkU9IRkxOYhMZrpeQys
YaOKbzudIKcF9XcM1ZMedoPBgRube1Fbz/rJloaeEIxMVDZZuh68GX4HnOq7gIlR
XUajQNYlH4BZTgXTuHNOYerA8whGh/wbRi9iVgswe9g3xvBIpAqZxnwCEV1SflsW
4ERAu9pgg6Y+VaCPTLPi/EDNz4RjHk1ehNFq/1VAGIRK13TtAvNPhJ5FXVh0MxOu
0DvtyAbtmfQN6h/1HdDUYGi4cNi0iwmdCynpAYsevXFZqdDwHr1CYIb8eJjPqozP
2U8y6CoOY7vp1Z82kFqw
=PCXr
-----END PGP SIGNATURE-----

You need to do that on a 64bit system:

zypper in libqt4-x11-32bit libsigc++2-32bit libpng12-0-32bit

On 02/02/2011 04:06 AM, please try again wrote:

> You need to do that on a 64bit system:

all of that is covered in the wiki: http://en.opensuse.org/SDB:Skype


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

That did it – sort of. I got past the error complaint and was able to log onto Skype. But there’s no sound – the Skype sound test produces nothing. Same for the sound test call. I’ve verified that my sound system is working in general, since I can use aplay on a wav file. I wonder if there might be a similar dependency problem with the sound. If so, how can I find it?

So you hear the Skype operators voice but can’t hear your voice? Hear ring tones and such?

If so go to the mixer. see if you have a Mic control and that it is not muted. Also a Mic boast and a capture control. If you don’t see them add them from the settings menu. Make sure they are not muted and the capture box is checked. You should hear any sounds from the Mic feed back though the speaker or earphones. You may need to play with these controls a bit.

Thank you, It work for me.