Skype: incoming video not displayed

Hey there!

I installed skype (yet without app armor) 4.3 under openSuse 13.2. The webcam works and pretty good pictures are transfered to the other side. But neither I can see the incoming video, nor does skype display the picture of the camera showing me.

Where can I start to search for the error?



Can you skype to another PC on your home lan ?

Any chance you are behind a router firewall or other firewall that has blocked the ports skype uses ?

Make sure your firewall is actually running. Certain conditions may it not to start at the install and you have to manually correct the problem.

Sound more like a video problem though what chips? and what drivers

  1. Skype as such works: it sends audio and video
  2. If both parties use skype inside the same lan the same error occurs: neither does skype show the incoming video, nor in Options / Video a picture from the camera.

So it’s a stupid software issue. With wxcam I can even make recordings from the input the camera supplies. And because the other party receives video and audio from skype without any error, the trouble is obviously, that skype does not work on openSuse 13.2 with kde: it can broadcast video, but not display received video pictures, neither from the local camera, nor from the remote camera the other party uses while skyping.

What can prevent skype from displaying video?

  1. The input from my camera obviously reaches skype, because it broadcasts the stream.
  2. the part of the software reliable for displaying a video is broken.

What a pity, but what should I say? That’s exactly the reason why I’m typing this on a linux computer: MS is a horrible company.

Unfortunately this does not work for you, and it is specific to your PC. I use openSUSE-13.2 with KDE and Skype all the time (to chat with my mother who is > 7700km away) and it works well.

With skype NOT running, try removing the directory and see if that makes a difference. Skype will recreate the directory 1st time it runs.

Note typically only one application can use the video device at a time.

The other possibility is you have a bad Skype install, and/or are missing some support applications for Skype.

Possible the guidance here for openSUSE-13.1 ( will work on 13.2.

Sigh. If I start with kernel 3.16.7, skype does not even recognise the camera (wxcam does). I changed to kernel 4.1.rc2 (!) and upgraded everything “v4l” to the tumbleweed version – no success. I tried the workarounds in SDB:Skype, nothing.

After some minutes a via console started skype drops this message:

 libv4l2: error dequeuing buf: Das Argument ist ungültig

(in English: »argument invalid«)

I googled this error, but to no end.

On 2015-05-06 17:56, cookie170 wrote:

> I googled this error, but to no end.

You’d have to create a new Linux user, set its language to English, and
reproduce the error. This time it would be in English, and then you can
google it with a better chance.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))