Skype errors with 11.3

Anyone else having problems installing Skype beta (direct from Skype) on 11.3 x86_64?
Error is:

  skype: symbol lookup error: /usr/lib/ undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

I’ve been through the forums and Google and made sure I have all the 32-bit libs required by skype. For example:

6930p:~ # rpm -qa | grep -i libqt4

Others on the net had issues with references to nessus libs in the ld.conf file. I don’t have nessus installed here.

6930p:~ # cat /etc/
  include /etc/*.conf

Can anyone offer any suggestions or hints? Please.
And thank you.


What does

ldd which skype

return? Any missing libraries? I suspect not. I suspect Skype was built against an older release of libQt. Until they release an updated version of Skype that will work with 11.3, you may have to use the static version from Skype.

ldd says:

6930p:~ # ldd `which skype` =>  (0xffffe000) => /usr/lib/ (0xf75ea000) => /usr/lib/ (0xf75e4000) => /usr/lib/ (0xf75e0000) => /usr/lib/ (0xf7568000) => /lib/ (0xf7521000) => /usr/lib/ (0xf74de000) => /usr/local/lib/ (0xf6bfb000) => /usr/lib/ (0xf6bd0000) => /usr/lib/ (0xf6bc7000) => /usr/lib/ (0xf6bac000) => /usr/lib/ (0xf6b9b000) => /usr/lib/ (0xf6b90000) => /usr/lib/ (0xf6b87000) => /usr/lib/ (0xf6b81000) => /usr/lib/ (0xf6b75000) => /usr/lib/ (0xf6b70000) => /usr/lib/ (0xf6ae9000) => /usr/lib/ (0xf6ab3000) => /usr/lib/ (0xf6aa1000) => /usr/lib/ (0xf6966000) => /usr/lib/ (0xf6846000) => /usr/local/lib/ (0xf6620000) => /lib/ (0xf660c000) => /usr/lib/ (0xf6606000) => /lib/ (0xf65fc000) => /usr/lib/ (0xf6516000) => /lib/ (0xf6511000) => /lib/ (0xf64f5000) => /usr/lib/ (0xf6405000) => /lib/ (0xf63db000) => /lib/ (0xf63bd000) => /lib/ (0xf6252000) => /lib/ (0xf624b000) => /lib/ (0xf6221000) => /usr/lib/ (0xf6201000)
  /lib/ (0xf76e6000) => /lib/ (0xf61d2000) => /usr/lib/ (0xf61cd000)

Report the problem to so that they can start building a new version suitable for 11.3.

I have problem on 11.3 x86_64 with Skype untill I installed libpng12-0-32bit

Thanks for the post. Skype was not working for me, either, until I installed that same file.

The problem is you need qt4 32bit.

Whoops, I noticed something. You have your own versions of some Qt libraries in /usr/local/lib. How did this happen? Did you compile Qt yourself? They are causing the mismatch.

Where can I download the latest skype for 64bit?

AFAIK there is no 64-bit version, you have to use Skype’s 32-bit version.

Some of the libqt-32bit libraries wasn’t upgraded when I upgrade the system from opensuse 11.2 into 11.3. Just update all libraries and it will works!

Also had the problem with Skype. Installed all the 32 bit libraries. But it didn’t help. Skype couldn’t find the file. So, I installed the xorg-x11-libXv 32-bit library and now it works;)

Thank you. This did it for me.

" zypper in libpng12-0-32bit"


Install libpng12-0
For me it solved the problem.

more Info: Skype for Linux 2.1 beta2 does not work on Suse 11.3 - Skype Community