Skype - Distorted Microphone Input

Hi guys,

Skype has not worked completely yet for me since installing OpenSUSE 12.2. It worked with 12.1.

While I can hear perfectly what others are saying, the audio records my voice heavily distorted which is how I
hear it when using the Skype Testing Service. My voice more or less sounds like some demonic being in the
movies :slight_smile: …heavy and low.

Now if I record from arecord instead, my voice sounds completely normal. Here is the command that works:

arecord -vv -f S16_LE -c 2 -D hw:0,0 new.wav

Skype is set to use the same audio input explicitly. If I set it to default, then there is sound being recorded at all.

Any idea why would Skype not record correctly and how to fix it?

Thanks in advance,

PS: Let me know if there is any other information required to diagnose the problem.

On 2013-01-22 16:36, idanan wrote:

> Any idea why would Skype not record correctly and how to fix it?

I don’t know, I haven’t used skype in a long time, just installed it
again yesterday. One suggestion, though: try installing the static
package instead of the rpm: it is downloaded from the option named
“dynamic”, a bz2 archive.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Skype worked for me on openSUSE-12.2 on my laptop, when I was in Thailand (with my laptop) and my mother in North America (she is using openSUSE 12.1).

If you have the record level too high you will get distortion. You can tune the levels using pavucontrol - and I blogged about Skype and pulse audio here: https://forums.opensuse.org/blogs/oldcpu/pulseaudio-basics-opensuse-pavucontrol-96/

Note there is a newer version of skype available: skype-4.1.0.20-suse121.i586

Also note your arecord test proves your mike is working, but it bypasses pulse audio so if the problem is in your pulse audio setting it will not show the problem.

Sorry but that version makes NO sound at all.

Thanks for trying though!

  • Itai

No, the volume is not high at all and the distortion is so severe that it is not understandable. Actually with arecord, I come out on the low side but perfectly clear.

Pavucontrol does not work for me because that requires PulseAudio which causes my system to have no audio at ALL… no record or playback and in no application.
Once I uninstalled it, everything worked except for Skype input. I use AlsaMixer instead and played with the controls extensively without success.

Thanks anyway!

  • Itai

On 2013-01-22 23:06, idanan wrote:
> Once I uninstalled it, everything worked except for Skype input. I use
> AlsaMixer instead and played with the controls extensively without
> success.

In my case, skype says that it notices that PA is running, and offers a
button to run the appropriate audio control dialog. Don’t you get an
equivalent text and button for your audio?


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Its unfortunate your hardware does not work with pulse audio. Practically all testing now adays is done with pulse audio, and when one removes pulse audio (or does not install it) then one is in mostly untested territory.

We can only take your word for your mixer settings being appropriate, unless you provide more information, such as output of diagnostic script (ie web address to where your PC’s hardware/software audio config information is uploaded by the script):


/usr/sbin/alsa-info.sh

No problem. Here it is:
http://www.alsa-project.org/db/?f=2d7851aded67a133ecaeb81c61976829d4066f25

Honestly when it comes to audio in Linux, I am quite lost. Everything except Skype just worked once I removed Pulse Audio
which is something I wouldn’t have known to try until I read it has worked for many people in this forum.

Maybe one day I’ll put some new questions to get Pulse Audio working :slight_smile:

Well, thanks for your help. Please let me know if there something you see wrong in the ALSA info uploaded.
There has to be something Skype does differently than arecord.

  • Itai

Hmmm … looking at your mixer configuration I am surprised arecord works at all.

This is what I can see … your motherboard has an ALC889 hardware codec, which provides a significant amount of configuration options with the alsa sound driver.

According to arecord you have two capture devices with both analogue:


ARECORD

**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 2: ALC889 Analog [ALC889 Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

Your mixer indicates “Input Source-1” set to Line and "Input Source-2 set to “Rear Mic”. Your front Mic is not selected, which is likely good as your Front Mic playback is ‘OFF’ which if not ‘OFF’ would give you feedback indicating that the Front Mic works.

If I look at the Rear Mic settings I see there is a ‘capture-0’, ‘capture-1’, ‘capture-2’ and also a digital-0’. Every one of these has 0% capture, meaning you can not possible record any audio.

Plus when I look at the ‘Rear Mic’ playback settings, it is ‘OFF’ which means you will get no feedback even if it was working.

I think your mixer needs tuning.

Here are your misconfigured (?) settings:


**Simple mixer control 'Front Mic',0
**  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] **[off]**
  Front Right: Playback 31 [100%] [12.00dB] **[off]**

**Simple mixer control 'Front Mic Boost',0**
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [30.00dB]
  Front Right: 3 [100%] [30.00dB]

**Simple mixer control 'Capture',0**
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 0 **[0%]** -16.00dB] [on]
  Front Right: Capture 0 **[0%]** -16.00dB] [on]

**Simple mixer control 'Capture',1**
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 0 **[0%]** -16.00dB] **[off]**
  Front Right: Capture 0 **[0%]** -16.00dB] **[off]**

**Simple mixer control 'Capture',2**
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 0 **[0%]** -16.00dB] **[off]**
  Front Right: Capture 0 **[0%]** -16.00dB] **[off]**

**Simple mixer control 'Digital',0**
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 0 **[0%]** -30.00dB]
  Front Right: Capture 0 **[0%]** -30.00dB]

**Simple mixer control 'Input Source',1**
  Capabilities: cenum
  Items: 'Rear Mic' 'Front Mic' 'Line'
  Item0: **'Line'**
**
Simple mixer control 'Input Source',2**
  Capabilities: cenum
  Items: 'Rear Mic' 'Front Mic' 'Line'
  Item0: **'Rear Mic'**
**
Simple mixer control 'Rear Mic',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] **[off]**
  Front Right: Playback 31 [100%] [12.00dB] **[off]**
**
Simple mixer control 'Rear Mic Boost',0**
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [30.00dB]
  Front Right: 3 [100%] [30.00dB]

Now I am even more baffled then before. Just in case I broke something between reporting my problem and generating the ALSA output,
I ran arecord again and it worked. My voice sounds perfect. Even more strange, I am using the Front Mic which you said is not used by
the config!

Then, I spend a good amount of time fiddling with the mixer to correct the problem and it seems I can only make it worse! At best, I get
my voice played back at a reasonable volume but completely distorted. At worst, I got no playback at all. What controls Skype hearing
me is the setting called ‘Capture’ (it has to be ON but any gain is fine), plus Front Mic Boost (It has to be at least 1/3 from the bottom to
record myself). When Skype is allowed to ‘Change Mixer Settings’, I can see the Front Mic Boost going to the maximum.

Since the behavior is so weird, I suspect there is an either deeper cause than mixer config but I’m guessing of course. The only odd thing
I just noticed is that in Yast -> Sound there are 3 cards listed and one says ‘Not Configured’ and it has the same name as the first one.
The Delete button refuses to do anything while trying to configure is results in an error saying there is no kernel driver for it! Specifically,
the cards are list as follows:


0                      SBx00 Azalia (Intel HDA)
1                      R700 Audio Device [Radean HD 4000 Series]
Not Configured  SBx00 Azalia (Intel HDA)

If I try to configure it, either automatic or manually, it says:

The kernel module snd-hda-intel for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.

Any ideas why there would be this extra sound card and how to remove it? That may cause some confusion in the system with
multiple parameters and then maybe ALSA gets confused. Could it this also be what causes PulseAudio to make my system
silent?

Thanks again,

Please, can you run the same diagnostic script again, and post here the web address of the output provided, so we can review the settings which you believe to be the optimum.

Note your capture varied from 0% (no capture) to 100% (serious distortion possible in capture) in your mixer. It was not configured properly IMHO, so I am curious as to what you now believe to be the optimum.

YaST typically picks up those settings from the file /etc/modprobe.d/50-sound.conf. If you delete that file and go into YaST and reconfigure, that device may be gone (assuming it is not a real hardware device). However doing so may give you a bunch of extra KDE dialog box warnigns (if you are using KDE desktop) which may be confusing to you and you will then need to sort.

In any event, what ever final optimal configuration you end with, it is THAT configuration that I am interested in viewing from the diagnostic script. There is very little point in showing me a diagnostic script output that has no resemblance to your current settings.

Good luck.

Hi again,

Thank you for taking the time to look at this! I really appreciate it. Here is the output of the script again:
http://www.alsa-project.org/db/?f=ef4c0c823436f02cbd5527eb29f629857fe3faa0

At this point arecord work perfectly and Skype records something but it is not inteligible.

Now because you said my previous settings made no sense and should have made it impossible to record,
I mentioned the sound card issue, in case alsainfo is not showing the right settings! It is only a guess, but I
imagine it would be possible for the system to be confused and show the configuration for a card that is not
there!

Here is the sound file you mentioned:

[/home/itai] cat /etc/modprobe.d/50-sound.conf


options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.j_qSqBy1Xx9:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.txz_sgxDiRE:R700 Audio Device [Radeon HD 4000 Series]
alias snd-card-1 snd-hda-intel  

Seams like there are only two and YaST is confused. Yes, I am using KDE, maybe I’ll rename the file and
see what happens when I have time for a reboot.

Please let me know if you see any that can be tried and how to do it.

Thanks again!

Your front mic is switched OFF in your mixer. You need to switch it on IMHO for Skype to work. Note this setting from that script output:


Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] **[off]**
  Front Right: Playback 31 [100%] [12.00dB] **[off]**

wrt the Skype application … what are you choices in the ‘options’ > ‘sound devices’ tab for the mic ?

Hi again,

Actually, that setting makes only one difference on my system: With it ON, I hear myself in the headset too. With it OFF, I do
not hear myself. In either case, the audio that Skype records is heavily distorted. From my experiments yesterday, the setting
that toggles whether Skype hears me or not is actually this one:


Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 34 [74%] [18.00dB] [on]
  Front Right: Capture 34 [74%] [18.00dB] [on]

In Skype sound options, the default resulted in no audio being recorded so I set it to:

Microphone -> HDA ATI SB, ALC889 Analog (hw:0,0)
Speaker -> Default device (default)
Ringing -> Default device (default)

Also, I tried with ‘Allow Skype to automatically adjust my mixer levels’ on (the initial setting) and off (what I left it as since
it made it easier to play with mixer settings).

The microphone option that worked at least coincides with the settings that work for arecord.
Any more ideas?

Thanks in advance,

No ideas. I use pulse audio with Skype. You don’t.

Why does pulse audio not work for you ?

There are users who claim their PC works better without pulse audio, but unfortunately they rarely step in to help. One of these users who do not use pulse audio needs to step in and give suggestions.

Did you try surfing google on " distorted audio in skype " or " distorted sound in skype " , and then try out some of the suggestions from that ?

Hi,

The PulseAudio story:

  1. Installed OpenSUSE 11.1 and had NO sound from any application, not even the web brower, flash, audio player, nothing.
  2. Looked up my problem and found an answer in the 11.1 forum saying to try uninstalling PulseAudio. I did and it worked. Audio was working perfectly even in Skype.
  3. Installed OpenSUSE 12.1 (yes, I skipped some) and well there was no audio at all. Familiar with this problem, I uninstalled PulseAudio and it worked perfectly, Skype too.
  4. Installed OpenSUSE 12.2 and well there was no audio at all. Familiar with this problem, I uninstalled PulseAudio and everything got its audio back except Skype Recording.
    (Skype plays back, arecord records, aplay plays, audio players, VLC, web-browsers, etc ALL play and record audio).

Now whenever I mention that PulseAudio is not installed, someone says that must be my problem. The truth is I DO NOT KNOW. There is a reason why PulseAudio
does not work but my original problem was not ‘PulseAudio not working’, it was ‘No audio in OpenSUSE’. If it works, I couldn’t care less which audio library is there or
not there.

So, unfortunately, that is all I know. It would take time to figure out why PulseAudio does not work and I don’t even know what I have instead of PulseAudio because
I guess that I would have to uninstall whatever is giving me audio now. Seems like I have packages called ALSA
-something
and ASOUND-something. It does not look
like they can be removed easily because other applications I regularly on my system depend on them. Maybe PulseAudio does not work because some applications
create conflicting requirements? Or maybe it did not like my motherboard (no sound-card in my system, so onboard sound is what I use).

In the meantime, I tried some other things to patch Skype but did not find much applicable. None of the tried ones worked.

As for PulseAudio, where could I start to figure out how to install and configure it without hosing all my other audio applications? I may try but I’d have
to wait until I have more free time.

Thanks again!

  • Itai