Skype claims speakers are muted, but mic input is not working

On Nov 5th I installed LEAP 42.3, and immediately checked Skype, as Skype sound problems are the main reason I’m changing distros. I called the testing service and the sound worked.
On Nov 7th Skype was updated.
On Nov 12th I tried to use Skype but the other end could not hear me. The display claims that speakers are muted, which they are not, as I could hear the other end perfectly. Checking with pavucontrol the webcam mic is active.
There is any amount of advice around, mostly rather scary, and applying to older versions of both Skype and openSUSE.
Before I do anything drastic, does anyone have any ideas as to what has gone wrong since Nov 5th, or how I can find out?

As an experiment I installed Mageia 6 on a spare partition. Mageia does not supply Skype, instead suggests installing from the MS rpm. This showed identical symptoms - “speakers muted”, no mic input, but sound output working. Pavucontrol allowed me to select the webcam mic as the default, connecting the webcam mic to Skype. The “speakers muted” display persisted, thought evIdently untrue.

Back on openSUSE, pavucontrol does not have a default-setting function. Looking through Yast I found that the sound card was not configured, so I ran a “normal” configuration, and Skype now works, though it still says “speakers muted”. I assume that something installed or updated since the initial OS install has un-configured the sound card.

No need for drastic steps.

Works fully here (42.2) but I still see the muted speaker prompt though all works

On that note I do indeed have troubles with current Skype and Leap 42.3. Somehow the application is not rendering correctly and the menu entries are cut off. Very strange

However, the next day it was back to silence. I noticed a mention of possible problems with Logitech webcams, which mine is, so I replaced it with a Microsoft one I had lying about and this appears to have done the job.