skype and apparmor

I have installed skype by using the advice here:

Skype HOWTO - openSUSE

and it suggests this:


A lot of people don’t want to run Skype cause tries to collect data from your system which it shouldn’t do. It tries to read your Mozilla profile for whatever reason.

To avoid such things you can use Apparmor to protect your system.

Copy this apparmor profile to your /etc/apparmor.d/ directory to jail skype.

Skype has to be installed as RPM that it works. "

I tried to start skype before making the above mentioned change and then it worked.

After this modification I get this error:
process 3302: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open “/var/lib/dbus/machine-id”: Adgang nægtet
See the manual page for dbus-uuidgen to correct this issue.
D-Bus not built with -rdynamic so unable to print a backtrace
Afbrudt (SIGABRT)

Any ideas?

It looks like skype can not work properly if ‘in jail’.
After the modification in Skype HOWTO - openSUSE I couldn’t sign in, so I removed the Then I signed in successfully.

Any ideas why :confused:

I run openSUSE 11.0 - Gnome

delete the profile and make a new one or change the profilling mode from enforce -> complain, play with skype for a while and start update profile wizard. all that from yast -> apparmor