Skype-4.0/4.2 on openSUSE-13.1

Skype may have no sound or corrupted sound for some users on openSUSE-13.1 and this blog re-iterates what has been posted elsewhere in different places.

The method I use for installing skype is per the openSUSE wiki (where at the time of writing this blog entry it had advice labeled for openSUSE-12.3 that nominally should work for openSUSE-13.1).

I had no sound from skype- on my Toshiba Satellite Z930 Ultrabook after my openSUSE-13.1 GM installation. :frowning:

After some surfing (and also reading of a user with a similar problem in the openSUSE forum on the 13.1 RC2 thread) I made note of the following on this subject:

Where I quote from the news announcement:

PulseAudio 4.0 and Skype

                        *By [Arun](       |       Published: **August 2, 2013*
                                                                                     This is a public service announcement for packagers and users of Skype and PulseAudio 4.0.

In PulseAudio 4.0, we added some code to allow us to deal with automatic latency adjustment more gracefully, particularly for latency requests under ~80 ms. This exposed a bug in Skype that breaks audio in interesting ways (no sound, choppy sound, playback happens faster than it should).

We’ve spoken to the Skype developers about this problem and they have been investigating the problem. In the mean time, we suggest that users and packagers work around this problem in the mean time.

If you are packaging Skype for your distribution, you need to change the Exec line in your Skype .desktop file as follows:

Exec=env PULSE_LATENCY_MSEC=60 skype %U

If you are a user, and your distribution doesn’t already carry this fix (as of about a week ago, Ubuntu does, and as of ~1 hour from now, Gentoo will), you need to launch Skype from the command line as follows:


If you’re not sure if you’re hit but this bug, you’re probably not. :slight_smile:

I applied the fix noted above and Skype worked for me. :slight_smile:

I note that the latest 13.1 release notes also covers this:

5.12. Skype

PulseAudio 4.0 exposes a bug in the current version of Skype for Linux
(v4.2). Until Skype is fixed and updated, run skype from the command line:


For more information about this bug, see

My thanks to user wolfi323 for pointing this out to me.


The only way I can get Skype to work properly was to run it as root and disable Pulseaudio (did the latency thing too).

After my upgrade from openSUSE 12.3 to 13.1 I lost line-in sound, and start-up sound. I disabled Pulseaudio and have line-in now, but still have no start-up sound?

With previous 12.3 openSUSE, boot up sometimes hanged for bit with pulseaudio activated.

Asus P5P43TD with on board Intel Audio ALC887

p.s. this is my first blog so apology’s if it’s in the wrong place.

This sounds like a permissions issue then. Is your user’s session listed by “loginctl”?
See here f.e.:

After my upgrade from openSUSE 12.3 to 13.1 I lost line-in sound, and start-up sound. I disabled Pulseaudio and have line-in now, but still have no start-up sound?

Startup sound is disabled by default in recent KDE versions.
You can configure one in “Configure Desktop”->“Application and System Notifications” though.

Thank you very much for that, I’ll look in to it. Thanks again. Bob Jankowski

The only correct decision to avoid being deaf and mute skype is:
Until Skype is fixed and updated, run skype from the command line:



Please, colleagues, limit obsession to write redundant. Asking others to read extra things they do not need the least useful.

Forum is only for specific solutions and is a social network for common themes.

Put in /home/your_user_ home_name/.local/share/applications/skype.destop

Exec=env PULSE_LATENCY_MSEC=60 skype %U

and remove old

exec=skype %U

save it

And enjoy!

Quicklaunch command : “PULSE_LATENCY_MSEC=60 skype” worked in all cases.
Horrible buzzing noise when launching Skype on a laptop : problem solved.
No sound on a first desktop : problem solved
Bad sound on another one : problem solved.
Thank you.
Opensuse development team didn’t have to change Pulseaudio latency for this piece of ****, Microsoft owned, NSA approved, we install because friends/family/children with no computer ethics use it. :shame: :shame: :shame:

I disabled pulseaudio in Yast and Skype works fine… In fact all audio apps are working fine for me under 13.1 - Rosegarden, VLC, Mplayer, web browsers with plugins, I even use 2 soundcards… and ALSA directly
I think pulseaudio is the problem. Who needs it when everything works fine without it? :expressionless: - The shop cheap wholesale and retail Nike Air Jordan shoes,Air Max Shoes,Designer Handbags,Jewelry,Belts,hats,Jeans,sunglasses,Sports Jerseys online,high quality goods and Low price outlet from china,free shipping,Welcome to order.
Air Jordan shoes $56
Jordan hats $10
Brand Belts $27
Jewelry $15
AAA Jeans $52
Sunglasses $16
NBA Jerseys $25
(DG MK LV) Handbags $46
Jordans Shoes
Cheap Handbags
Fashion Jewelry
Cheap Jordans
Cheap Jewelry
Jordans for sale
Cheap NBA Jerseys
Cheap Jordan shoes
JoRdaN REleasE DAtES
Cheap Designer Handbags