Skype on openSUSE10x

I am linux noobie, I dont know about RPM’s or anything. I only know the term RPM from trying to figure out how to get my SKYPE working. Im desperate its 3 am and need to try and get this working so my Son can have his Grandma watch him open christmas presents.

I have tried this

zypper install  libqt4-32bit libqt4-dbus-1-32bit libqt4-x11-32bit libsigc++2-32bit
Restoring system sources...
Parsing metadata for SUSE Linux Enterprise Desktop 10 SP2 10.2-0...
Parsing RPM database...
skipping package 'libqt4-32bit' (already installed)
package 'libqt4-dbus-1-32bit' not found
package 'libqt4-x11-32bit' not found
skipping package 'libsigc++2-32bit' (already installed)
Nothing to do.

I found this code from here Skype HOWTO - openSUSE

I searched and searched for the libqt files etc. but since i have no clue what im looking for i dont know where to look. Is there anyone that can help me?

QT main location here
Index of /repositories/KDE:/Qt

add the correct repo for your 10.? sys

eg; if you are 10.3
Index of /repositories/KDE:/Qt/openSUSE_10.3

I cant even find anything more specific than SUSE10(86_64)

So its SUSE Linux Enterprise Desktop 10 Service Pack 2 (SP2) 10.2-0

Index of /repositories/KDE:/Qt/SLE_10

I tried to download all the things it says i need, but it doesnt let some of installs work. Do i need to get certain ones first? Like pre requisits?

Also I cant seem to find a file named this anywhere in there

package ‘libqt4-dbus-1-32bit’ not found