Skype, 11.2 and Creative X-Fi

Hey guys,

I have 11.2 (32bit) and a Creative X-fi as a sound card. Thanks to the kernel driver all sound works fine except for Skype. I’m running the latest beta and it’s not working right at all.

If I start it from a terminal I get the following errors:

ALSA lib conf.c:4600:(snd_config_expand) Unknown parameters CARD=XFi,DEV=0       
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM rear:CARD=XFi,DEV=0      
ALSA lib pcm_asym.c:106:(_snd_pcm_asym_open) capture slave is not defined        
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave                
ALSA lib pcm_asym.c:106_snd_pcm_asym_open) capture slave is not defined
ALSA lib pcm_dmix.c:1010snd_pcm_dmix_open) unable to open slave

I am assuming it’s an ALSA issue. Running alsaconf and it can’t find my x-fi. I do not have pulse audio installed since I don’t know how to work it

Any ideas?

alsaconf is depreciated for openSUSE-11.2. alsaconf will create an /etc/modprobe.d/sound file, and 11.2 will ignore such a file. Instead 11.2 looks for an /etc/modprobe.d/50-sound.conf file.

jan-bart@Dexter:/etc/modprobe.d> dir
total 44
-rw-r--r-- 1 root root 3201 2009-10-24 01:32 00-system.conf
-rw-r--r-- 1 root root  532 2009-10-24 01:32 10-unsupported-modules.conf
-rw-r--r-- 1 root root 5906 2009-11-23 19:49 50-blacklist.conf
-rw-r--r-- 1 root root  128 2009-10-21 22:45 50-bluetooth.conf
-rw-r--r-- 1 root root   22 2009-11-23 20:06 50-ipv6.conf
-rw-r--r-- 1 root root   33 2009-10-19 16:38 50-ipw2200.conf
-rw-r--r-- 1 root root   86 2009-11-02 12:11 50-nvidia.conf
-rw-r--r-- 1 root root   18 2009-10-19 16:38 50-prism54.conf
-rw-r--r-- 1 root root  398 2009-10-24 01:33 50-thinkpad_acpi.conf
-rw-r--r-- 1 root root    0 2009-11-21 23:26 50-tv.conf
-rw-r--r-- 1 root root    0 2009-11-23 20:06 50-yast.conf
-rw-r--r-- 1 root root   47 2009-10-24 01:32 99-local.conf

I don’t seem to have that… anyone else with a x-fi not have a 50-sound.conf file?
Any ideas on how to get one? I find it a bit strange that I finally have a working x-fi alsa driver but it’s still not working properly :frowning:

From what I have read (on another thread) that for X-Fi to work, it should not have a 50-sound.conf file. It appears both alsaconf and YaST will misconfigure the sound card. Hence it is best not to have that file, but rather rely on the version of alsa one has installed to autoprobe and correctly configure the card.

Edit: I don’t use Skype. I never have used Skype. So I can not help you with Skype.

If you run alsaconf you will cripple your card and it will not work AT ALL.

Remedy; remove the files alsa created and reboot.

Fair enough lol!

This is true but a reboot sorts it since alsconf actually finds nothing. Nor does YAST. The card just works but I have no idea how.

What does it create and how do I remove this?


Are the files they mentioned. If the driver auto-configures correctly config files are uncessary and have advantage it “just works” when you change your card.

Rob robbed™ me. Anyway if you have either of those two files, the autoprobing won’t work and it won’t detect the X-Fi properly.

Thanks for all the help so far guys. I will have a look into this this evening when I am back home. It might just be a ‘it won’t work for you thanks to your silly soundcard’ scenario and I will just have to accept this. :slight_smile:

I have an X-Fi (11.2+2.6.31) so let me test it, I don’t have Skype installed tho and I have no idea where my mic is - I’ll try to find it :slight_smile:

Thank you!

It starts fine for me but sound quality is bad and if I start it from the konsole I get the errors mentioned in the first post.

I also tried it with Pulseaudio which sort of worked in 11.1 but can’t get it to work in 11.2 so I gave up. :slight_smile:

Just to let people know it’s not a must have but it’s a would be nice to have! I use it under windows XP without a problem since I have that installed as well for my games.

Well, I got it installed nicely and ran it - unfortunately I still haven’t found my mic. I vaguely remember sitting on one but I thought a bought a new one :stuck_out_tongue:

I’ll keep looking.

And are you getting the same errors when you start it from konsole?

Capture slave undefined yes but not about the parameters, let me examine it some more.

I have the same problem. Skype + openSUSE 11.2 64 bit. Music I play is ok. Knickst the sound in Skype. Alsconf find them sound card in Yast and it is not listed.

30: PCI 102.0: 0401 Multimedia audio controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1102_5
  Unique ID: fQ_y.D6BVe4HUNs7
  Parent ID: 6NW+.rH3rArjV8aF
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:01:02.0
  SysFS BusID: 0000:01:02.0
  Hardware Class: sound
  Model: "Creative SB X-Fi"
  Vendor: pci 0x1102 "Creative Labs"
  Device: pci 0x0005 "SB X-Fi"
  SubVendor: pci 0x1102 "Creative Labs"
  SubDevice: pci 0x0029
  Driver: "SB-XFi"
  Driver Modules: "snd_ctxfi"
  I/O Ports: 0xbc00-0xbc1f (rw)
  Memory Range: 0xf9a00000-0xf9bfffff (rw,non-prefetchable)
  Memory Range: 0xf4000000-0xf7ffffff (rw,non-prefetchable)
  IRQ: 21 (390 events)
  Module Alias: "pci:v00001102d00000005sv00001102sd00000029bc04sc01i00"
  Driver Info #0:
    Driver Status: snd_ctxfi is active
    Driver Activation Cmd: "modprobe snd_ctxfi"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #20 (PCI bridge)

Skype says…:

ALSA lib pcm_asym.c:106:(_snd_pcm_asym_open) capture slave is not defined
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM null
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM null
ALSA lib pcm_asym.c:106:(_snd_pcm_asym_open) capture slave is not defined

I would be grateful for help

Pick a number and join the back of the line please :stuck_out_tongue:
We will have to wait until Chrysantine is done with her testing… Or until someone else has an idea…
sits down patiently

I might raise a bug report on the handling of the x-fi by OpenSUSE…

Chrysantine, any clue to what is happening with Skype and any potential cure?

Sorry I’ve been overly busy in the past few days with work stuff and others, I’ll promise to give it a poke tonight after cleaning and cooking :slight_smile:

I’m giving up on this subject… anyone who can solve it please post the solution here… I’m sticking with twinkle for my voip and I’ll use Windows for Skype to Skype calls…

Dexter1979 wrote:
> I’m giving up on this subject…

but, did you do the right thing at:

freedom: you are free to participate in making Linux/openSUSE better
by logging your bug…otherwise that Creative card may never be