Skating Penguins: A December 1 Install Goodie?

I did a reinstall of 13.1 today from the DVD image and it booted up to a chilly-looking display of ice, snow, and skating penguins.

Cute, that. :slight_smile:

It is December.

(Now, does it show a warm beach scene with surfing penguins in the southern hemisphere?)

joncr wrote:
>
> I did a reinstall of 13.1 today from the DVD image and it booted up to
> a chilly-looking display of ice, snow, and skating penguins.
>
> Cute, that. :slight_smile:
>
> It is December.
>
> (Now, does it show a warm beach scene with surfing penguins in the
> southern hemisphere?)
>
>
It seems that the penguin theme has been removed in grub2 :frowning: So no more
penguins while booting.


GNOME 3.10.1
openSUSE 13.1 (Bottle) (x86_64) 64-bit
Kernel Linux 3.11.6-4-desktop

I miss those penguins. But grub2 doesn’t show them.

Well, it has not really been removed, as it never was part of grub.

It was part of openSUSE’s theme for grub1 and has not been implemented in the grub2 theme (I don’t know if it would even be possible with grub2 though).

Anyway, the result is the same of course.

Are you sure? the OP said he saw them on a 13.1 install. But then maybe he still uses grub1. Is that still an option? It was always random but only triggered in Dec

On 2013-12-01 20:26, gogalthorp wrote:
>
> Are you sure? the OP said he saw them on a 13.1 install. But then maybe
> he still uses grub1. Is that still an option? It was always random but
> only triggered in Dec

I understand he saw them on the DVD boot. That’s not grub2, right? It
could even be EFI.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

It’s a feature, upgrade, and one reason why I switched to Grub2. :smiley:

Yes, AFAIK the installation medium uses grub1 (there’s a line where you can add kernel options).

As far as I know, the DVD media uses “syslinux” for booting, except in UEFI mode where it uses grub2-efi.

That’s true.

But syslinux and grub1 both use “gfxboot” to display the graphical boot menu. (open)SUSE’s grub package contains a patch for that.
That’s why they look the same.
And the Penguins theme is contained in gfxboot’s openSUSE branding (“gfxboot-branding-openSUSE”).

Grub2 OTOH has its own implementation for showing a graphical boot menu.

It was the DVD boot. I assumed it was keyed to Dec 1 because I’d booted the same DVD earlier with no penguins.

Well in the past that screen is random this time of the year. ie not every boot will show it.

I want to start a petition to bring the penguins back :frowning:

Switch to Grub1 in YaST->System->Boot Loader, and you will have them back… :wink:

Yep, switch it for the month of December and revert to Grub2 after the holiday season is over.lol!

I will sigh it :slight_smile:

Neat. Thanks!

https://www.change.org/en-CA/petitions/grub-development-team-bring-back-the-penguins-special-themes-during-holiday-seasons

rotfl!

wolfi323 wrote:
>
> alanbortu;2604858 Wrote:
>> I want to start a petition to bring the penguins back :frowning:
> Switch to Grub1 in YaST->System->Boot Loader, and you will have them
> back… :wink:
>
>
How safe is this procedure ?
Is it possible to end up with a broken system when switching back and
forth ?


GNOME 3.10.1
openSUSE 13.1 (Bottle) (x86_64) 64-bit
Kernel Linux 3.11.6-4-desktop

I have signed it. :slight_smile:

No, there shouldn’t be any problems.
It’s just as safe as updating the boot menu after a kernel update or similar.

And you can of course verify the menu in YaST->Boot Loader or even edit it there.