size display

linux set size display auto 1024x768, i need to change size 1152x864 and then
i restarted, size was the last 1024x768
how turn off “auto”

Here are some questions:

  • What version of openSUSE?
  • What make and model graphics card do you have?
  • What desktop environment (e.g. KDE or GNOME)
  • How did you change to 1152x864 before you restarted and it went back to 1024x768?

open suse 11.3
ati radeon x1600
the first i changed the size to 1152x864 and the restarted
the size didn’t change (why linux sets 1024x768 )

Can you please post output of


in Konsole?

Screen 0: minimum 320 x 200, current 1152 x 864, maximum 8192 x 8192
DVI-0 connected 1152x864+0+0 (normal left inverted right x axis y axis) 306mm x 230mm
1024x768 85.0 + 85.0 75.1 70.1 60.0
1280x1024 60.0
1152x864 75.0*
832x624 74.6
800x600 85.1 72.2 75.0 60.3 56.2
640x480 85.0 72.8 75.0 66.7 60.0
720x400 87.8 70.1
S-video disconnected (normal left inverted right x axis y axis)
DVI-1 disconnected (normal left inverted right x axis y axis)

You appear to be using 1152x864 at the moment. Did you change the resolution in KDE System Settings -> Display and Monitor?

yes i did the resolution but if i’m restarting the resolution will be 1024x768

This should work by switching to 1152x864 at KDE login. Run this in Konsole:

echo "xrandr -s 1152x864" >> ~/.kde4/Autostart/
chmod +x ~/.kde4/Autostart/

Then restart and log in. Does that work?

linux-wmiq:/home/titkov # echo “xrandr -s 1152x864” >> ~/.kde4/Autostart/
bash: /root/.kde4/Autostart/ No such file or directory

You are in root mode at the moment. Run is as your normal user by pressing Control+D or typing:


To get back to your normal user. Then try it again

it works!!!:):slight_smile:
thank you, thank you

No problem :wink:

Have fun :slight_smile: