SiS video card 640x480

First if all, I have two xorg config.xorg.0.log:
http://pastebin.com/qGYUvT0Y
**xorg.1.log:
**http://pastie.org/9241079
my hardware:
http://pastebin.mozilla.org/5297382

I can’t use xrandr:

dab@linux-7cs4:~> cvt 800 600# 800x600 59.86 Hz (CVT 0.48M3) hsync: 37.35 kHz; pclk: 38.25 MHz
Modeline “800x600_60.00” 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync
dab@linux-7cs4:~> xrandr --newmode “800x600_60.00” 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync
xrandr: Failed to get size of gamma for output default
dab@linux-7cs4:~>

and gparted too:
dab@linux-7cs4:~> pkexec /usr/sbin/gparted %f
No protocol specified

(gpartedbin:4014): Gtk-WARNING **: cannot open display: :0.0
dab@linux-7cs4:~>

The Xorg log reports that the sis driver is the preferred driver and it is loaded (as expected)

    17.094] (==) Matched sis as autoconfigured driver 0
    17.094] (==) Matched modesetting as autoconfigured driver 1
    17.094] (==) Matched fbdev as autoconfigured driver 2
    17.094] (==) Matched vesa as autoconfigured driver 3
    17.094] (==) Assigned the driver to the xf86ConfigLayout
    17.094] (II) LoadModule: "sis"
    17.094] (II) Loading /usr/lib64/xorg/modules/drivers/sis_drv.so
    17.094] (II) Module sis: vendor="X.Org Foundation"

However, later on it is unloaded with the basic framebuffer driver used at 640x480

    17.109] (II) UnloadModule: "modesetting"
    17.109] (II) FBDEV(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
    17.109] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
    17.109] (==) FBDEV(0): RGB weight 888
    17.109] (==) FBDEV(0): Default visual is TrueColor
    17.109] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
    17.109] (II) FBDEV(0): hardware: VESA VGA (video memory: 1216kB)
    17.109] (II) FBDEV(0): checking modes against framebuffer device...
    17.109] (II) FBDEV(0): checking modes against monitor...
    17.109] (--) FBDEV(0): Virtual size is 640x480 (pitch 640)
    17.109] (**) FBDEV(0):  Built-in mode "current": 30.7 MHz, 36.9 kHz, 73.3 Hz
    17.109] (II) FBDEV(0): Modeline "current"x0.0   30.72  640 672 752 832  480 484 488 504 -hsync
-vsync -csync (36.9 kHz b)
    17.109] (==) FBDEV(0): DPI set to (96, 96)
    17.109] (II) Loading sub module "fb"
    17.109] (II) LoadModule: "fb"
    17.110] (II) Loading /usr/lib64/xorg/modules/libfb.so
    17.110] (II) Module fb: vendor="X.Org Foundation"
    17.110]    compiled for 1.14.3.901, module version = 1.0.0
    17.110]    ABI class: X.Org ANSI C Emulation, version 0.4
    17.110] (**) FBDEV(0): using shadow framebuffer
    17.110] (II) Loading sub module "shadow"
    17.110] (II) LoadModule: "shadow"
    17.110] (II) Loading /usr/lib64/xorg/modules/libshadow.so
    17.110] (II) Module shadow: vendor="X.Org Foundation"
    17.110]    compiled for 1.14.3.901, module version = 1.1.0
    17.110]    ABI class: X.Org ANSI C Emulation, version 0.4
    17.110] (II) UnloadModule: "sis"
    17.110] (II) Unloading sis
    17.110] (II) UnloadModule: "vesa"
    17.111] (II) Unloading vesa
    17.111] (==) Depth 24 pixmap format is 32 bpp
    17.111] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    17.111] (==) FBDEV(0): Backing store disabled
    17.112] (==) FBDEV(0): DPMS enabled

This issue is discussed in this old thread

https://forums.opensuse.org/showthread.php/478096-SIS-771-671-PCIE-Display-Adapter-Driver-openSUSE-12-2

Basically
SiS suck

With the fbdev driver, you should be able to change the X resolution by changing the graphics console resolution in YaST->System->Boot Loader->Boot Loader Options. Just select any particular resolution instead of “Autodetected by Grub2”. fbdev should take that over to the graphical session.

and gparted too:
dab@linux-7cs4:~> pkexec /usr/sbin/gparted %f
No protocol specified

(gpartedbin:4014): Gtk-WARNING **: cannot open display: :0.0
dab@linux-7cs4:~>

That’s completely unrelated.

Use “kdesu”, “gnomesu”, or “xdg-su -c” to run gparted or other graphical applications, not pkexec or sudo. Otherwise they won’t find/can’t connect to the user’s X session.

And omit that “%f”, that doesn’t make sense.