Since recent update: no samba share reachable - XFCE thunar

Hi!

Have here two installs of Leap 15.3 XFCE that since a zypper up some days ago can’t reach samba shares:

“Failed to mount Windows share: invalid argument”.

In journalctl I see

org.gtk.vfs.Daemon[21677]: Kerberos auth with 'username@WORKGROUP' (WORKGROUP\username) to access '10.10.10.119' not possible

…and found this here:

https://bbs.archlinux.org/viewtopic.php?id=275179

Version for smbclient is 4.15.7.something…

Any ideas how to make that work again?

So nobody knows what you do to get this error and you cannot even say what version you have (is it that difficult to paste rpm -q output?) but you want to know how to fix it?

Anyway, you obviously need to open bug report. 4.15.7 includes offending commit and so it is likely the same issue:

commit 9b6e8ae65e24788c82022e761bfb2c78b59260d9
Author: Elia Geretto <elia.f.geretto@gmail.com>
Date:   Fri Mar 11 19:32:30 2022 +0100


    s3:libsmb: Fix errno for failed authentication in SMBC_server_internal()
    
    In SMBC_server_internal(), when authentication fails, the errno value is
    currently hard-coded to EPERM, while it should be EACCES instead. Use the
    NT_STATUS map to set the appropriate value.

I have no idea what XFCE is using to access SMB shares so I do not know whether Invalid Argument with samba 4.16.0 (#611) · Issues · GNOME / gvfs · GitLab applies.

https://bugzilla.opensuse.org/show_bug.cgi?id=1199973

Mount it in /etc/fstab with vers=2.0

This is about Nautilus and here it is clear how to fix. But we still do not know what OP does to trigger this problem so it is not clear if fixing gvfs will also fix problem reported in this thread.

Hmmm, you enter into the command line of thunar

smb://IP_of_share

or from a bookmark in the sidetab you try to open the link to the samba share.

What else can you do to access a samba share from a file manager?

The sever has set

client min protocol=SMB2

for a long time and it worked in the past.

Hi
You need to set the protocol on the client as well in /etc/samba/smb.conf

…yepp, already tried that, no improvement.

Related bug reports…
https://bugzilla.redhat.com/show_bug.cgi?id=2068976
https://gitlab.gnome.org/GNOME/gvfs/-/issues/611

I have the same issue here, I use openSUSE leap 15.4 with XFCE, thunar can access samba sharing,whatever i use Ip address or domain name is still error with error message the with TS.
https://i.postimg.cc/7Lzv6k7n/Cuplikan-Layar-2022-07-09-16-00-40.png

https://i.postimg.cc/mrkN4Ycv/Cuplikan-Layar-2022-07-09-15-53-35.png

How to solved this problem?

Thank You in Advance

I can access from terminal
https://i.postimg.cc/tRWc8bGh/Cuplikan-Layar-2022-07-09-16-14-42.png

I upgraded to 15.4 in the meantime (all updates done right now), doesn’t work now with Thunar (“invalid argument”, if I click on a bookmark; fails silently if I try to reach with smb://10.10.10.124 in the navigation bar), I think it worked some days ago

I am also using 15.3 and experiencing the invalid argument error. I have 2 Raspberry Pis, fully updated, Bullseye on a Pi3 and Stretch on a Pi2. Each of the Pis can connect to each other, and each can connect to my 15.3 machine. The 15.3 machine cannot connect to either of the Pis.
I do have NT1 as the minimum protocol on all 3 machines.

How about if try

smb://yourusername@192.168.1.4

For me

smb://yourusername@192.168.1.4

Brings up shares, but when I click on the share I get the invalid argument error. (I do have a 192.168.0.4 machine)

I downgraded to 4.13.13 … I can connect now.

I am experiencing the same “invalid argument” error in Nautilus on a fresh LEAP 15.4 installation. Samba version is 4.15.7. Does a Samba downgrade really solve this?