simple question about email forwarding in KMail

when I click “forward” in KMail, I get a new email-window, but it is completely empty.
the subject is “Fwd: …” like it should be, and any forwarded attachments are also there, but the body of the email is just empty, which makes the whole thing useless…

I can forward emails as an attachment, but thats sometimes very impractical…

does anyone have the same problem or a solution? :confused:

(using latest KMail and KDE4 on opensuse 11.1 64 bit)

You can right click on the message and choose >Forward>Inline, or you can click and hold on the forward button to get a drop down menu then choose Inline. Or you can use the top line menu >Message>Forward>Inline. Or with the message selected type Shift+F to forward inline. If you want you can edit the toolbar to add a button for Inline forward, or replace the default button with the “Inline” button. Only the default “Forward” button has the drop down menu. But you could still forward as attachment with the menu or right clicking or typing F.

I tried all that, and it does not work.
all I get is an empty message body.
the subject line is there, but thats it… the rest is missing.

that happens with any email that I try to forward inline.


I have the same problem on my desktop. Whenever I try to reply or forward an email, the body of the message is blank. I also have a recent version of kontact. On my laptop, I have kontact version 4.2.1 and that works fine. I wouldn’t mind downgrading to version 4.2.1 if that would work but am not sure how to accomplish this.

This is surely an annoying problem and I am even thinking of switching to evolution eventhough I like kontact.


This is a bug emanated from the latest KDE. The tool button does not allow you to select from its drop-down options.
Also, in the main menu, KMail is not showing the other “forward” options.
However, you can still choose other forwarding options such as “inline” etc. by right-clicking on the message.
Otherwise, press Shift+F on the message to forward inline.