I just post this to help many user ask in irc…

First download nvidia driver Drivers - Download NVIDIA Drivers

be sure Repo opensuse 12.1 source is enabled

open terminal type su
put password

then type
zypper install gcc make automake autoconf kernel-source kernel-syms

when that finish type
echo “blacklist nouveau” > /etc/modprobe.d/nvidia.conf

then close window

open yast>bootloader

edit opensuse 12.1

you will see
splash=silent quiet showopts

then add nomodeset like this
splash=silent quiet nomodeset showopts

click accept and close

reboot machine choose failsafe

when come to command enter user name and pass
then cd /Downloads

type dir to see the nvidia you just download “optional”

now type su and password

then type sh NVIDIA"filename"
easy to type sh NVIDI then hit tab key then click enter

this will start the NVIDIA install

when finish reboot and have lots of fun!!! :slight_smile:

if anyone wants clean up this howto feel free i just put for many user i see in irc have trouble this method works for both kde and gnome 3 :slight_smile:

Many thanks. A few missing details though. I use autologin at the moment myself. I needed to log out and select correct session without X. What failsafe is is kind of blurry. Perhaps it depends on how experienced you are with Linux. Failsafe should really be “without X”? Failsafe selection during bootup still loads X.
I’ll take notes next time I will compile (should be soon after release of 12.1)

The suggested blacklisting method now is to do the following:

echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf 

You can read it directly from nVIDIA here: SDB:NVIDIA the hard way - openSUSE

I have a blog on the subject here: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums


A script file to help install the driver the heard way here: LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.10 - Blogs - openSUSE Forums

Thank You,

Thanks for replies, however point out 2 thing, first if you blacklist and add nomodeset like i tell, when you boot failsafe will notstartx because cannot start x :slight_smile:

2nd, that nvidia howto is for 11.4 while it is similar to this method, seems to be drawn out a bit much :slight_smile:

thanks again and have lots of fun!

if you have autologon reboot and add a 3 at grub when selecting boot entry.
This will lead your system to level 3 with no X server, install nvidia driver and reboot


good useful post I guess ,
I remeber having problems sending blacklist nouveau so going throw daniel3 posts was helpfull as well as switching to runlevel 3 with init 3 command and installingfrom there. . . .

You can use fastboot, add the 3 as a local kernel load option abd quickly boot into run level 3:

FastBoot for Grub Legacy Menu using Kexec - Version 1.28 - Blogs - openSUSE Forums

Just run fastboot, select the kernel in which to install the nVIDIA driver, Add the option 3 and enter a Y to restart. When the restart completes, install the nVIDIA drive. You can use the lnvhw script to run that install as well.

LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.10 - Blogs - openSUSE Forums

Then, once loaded, just run fastboot again, to restart your kernel with the newly installed nVIDIA driver.

Than You,

Great Job! Everyone helping each other out :slight_smile: LONG LIVE OPENSUSE!

I did something wrong the second time I was about to play with the driver. The computer autologged in to a dysfunctional mode without any GUI, nor visible text mode. Only blackish/purple blank screen. Autologin is advised not to use :wink:
That and Shell was the only accessible modes. With my rather low knowledge in this area I was incapable of restoring the computer without reinstall… I’m currently using the repo version. You need to create the xorg.conf (if you wish to keep your multiscreen config) though with this driver…

Followed instructions, now all I get is command prompt, no x…

You need to tell us more about your computer, video hardware, openSUSE version and desktop version and just exactly which instructions did you follow?

Thank You,

Asus N55S with GeForce GT55M. Total nightmare just to get installation running 12.1, finally got it with no acpi (setnomode didn’t work). However, of course, video would tear and distort such that an editor would not be view-able even. I downloaded the latest driver for 64 bit Linux from Nvidia, switched to run level 3, then ran commands in your instructions. Not sure why needed gcc, etc, but ran that anyway. Installation seemed fine, but reboot makes it to command line only. Tried setnomode, acpi=off/on, nothing works. Now also can no longer dual boot Windows, in process of recovery restore from backup disk image, unfortunately.

Did you try or add in the kernel load option:** nomodeset**? This is entered at the Grub OS selection menu before you press enter and can be added to the file /etc/grub/menu.lst file as root. At the nVIDIA site, I find no reference to a video card called GT55M and so I wonder just what this really is or if you have the wrong name? When you go to the nVIDIA site, you MUST enter the correct video card in order to confirm the correct driver to use. Since it failed for you, perhaps it was not the right one?

Thank You,

Yes I tried nomodeset every day for the last week, too. GT555M, 2G top end Nvidia card.

I might check out the read me here in case there is some detail on this laptop you have missed: NVIDIA Accelerated Linux Graphics Driver README and Installation Guide

I would read through it as using a Laptop can be more troublesome to setup than is a desktop.

Thank You,

I’m surprised that no one mentions installation from the nvidia repo anymore in these fora. AFAIK it is the easiest way, specially for a newbie - no need to install development libs/aps/sources/etc or to recompile the driver whenever there’s a kernel update.

Since 11.2 (or 11.1 IIRC) I only had to add the repo and Yast’s update would automagically select and install the driver, which I could then forget about, no need for recompilations ever. It was always something I really admired in oS.

Perhaps nouveau is good enough that there’s no more need for this, or is it still working in 12.1?

You can find the repository method for installing the nVIDIA driver here: SDB:NVIDIA drivers - openSUSE, For me, I like to load the very latest nVIDIA driver version and often its required when I use the very latest kernel. But of course, we are all free to recommend any method we know how to use and support.

Thank You,

Nouveau is so bad Xemacs editor distorts and is unreadable when used.

I was unable to use Yast to get updates, just freezes up requiring reboot during file download.

The last thing I see before it goes to command line is “nvidiafb: cannot ioremap FB base”.
Researched that, just more endless circles, wow this is too much.
Never in 12 years of installing Linux, or even in developing hardware, have I seen quite this many problems on a new install.

So laptops can be crazy particularly if they actually have two video chipsets with say nVIDIA and Intel. Do you know if you might have such a setup?

Thank You,