simple-ccsm doesn't start

Hi.
I installed compiz via 1-Click installer.
After installation I tried to run simple-ccsm,but it doesn’t start and shows me this reports :

[FONT=“Lucida Sans Unicode”]/usr/bin/simple-ccsm:40: DeprecationWarning: Use the new widget gtk.Tooltip
Tooltips = gtk.Tooltips()
/usr/bin/simple-ccsm:182: DeprecationWarning: Use the new widget gtk.Tooltip
Tooltips = gtk.Tooltips()
libccs: dlopen: /usr/lib/compizconfig/backends/libkconfig4.so: cannot open shared object file: No such file or directory
/usr/bin/simple-ccsm:426: DeprecationWarning: Use the new widget gtk.Tooltip
Tooltips.set_tip(self, _(“Disabled”))
Traceback (most recent call last):
File “/usr/bin/simple-ccsm”, line 1385, in <module>
mainWin = MainWin(context, page)
File “/usr/bin/simple-ccsm”, line 1181, in init
self.Update()
File “/usr/bin/simple-ccsm”, line 1210, in Update
self.ZoomPage.Update()
File “/usr/bin/simple-ccsm”, line 1102, in Update
self.SetZoom()
File “/usr/bin/simple-ccsm”, line 1063, in SetZoom
setting = plugin.Display[settingName]
KeyError: ‘zoom_in’[/FONT]

How I can fix this problem?

Hi,

Are you using KDE or GNOME? Also which version of openSUSE are you using? And finally, have you tried following my guide here Installing and Configuring Compiz - openSUSE Forums?

Take Care,

Ian

I’m using KDE on openSuSE 11.2.

I checked your link and when I try to install compiz,it finds conflict problems.

*#### YaST2 conflicts list - generated 2010-05-21 23:00:27 ####

compiz-kde4-0.8.4-167.1.i586 requires compiz = 0.8.4, but this requirement cannot be provided
uninstallable providers: compiz-0.8.4-167.1.i586[X11:XGL]
] break compiz-kde4 by ignoring some of its dependencies

 ] do not install compiz-0.7.8-43.44.1.i586

 ] do not install compiz-kde4-0.8.4-167.1.i586

YaST2 conflicts list END

Choose

compiz-kde4-0.8.4-167.1.i586 requires compiz = 0.8.4, but this requirement cannot be provided
uninstallable providers: compiz-0.8.4-167.1.i586[X11GL]
] break compiz-kde4 by ignoring some of its dependencies

[X] do not install compiz-0.7.8-43.44.1.i586

] do not install compiz-kde4-0.8.4-167.1.i586

Take Care,

Ian

when I choose Compiz as my default window manager,there is no window decoration. :frowning:

The installation guide I gave there covers everything.

*Note: Currently (as of 12/04/2009) the one-click installer excludes the compiz-emerald and compiz-emerald-themes packages. You will have to manually install these or else you will not have window decorations when you set compiz as your window manager (remember to choose version 0.8.x and not 0.7.x).

12.)If you want to use emerald as the decoration manager when compiz starts up, open the CompizConfig Settings Manager (CCSM), go to the Effects Category
and make sure Window Decoration plugin is checked. Click into the plugin and find “Command”.
If it’s not in there already replace whatever’s in there with

Code:
emerald --replace
13.) For KDE4 users, To set compiz as the default window manager open Configure Desktop (Personal Settings). Then click Default Applications. Click Window Manager and choose Use a different window manager. Use the drop down menu to choose Compiz (not Compiz custom).

You have to install the emerald packages manually. Just open up Yast’s Software Installation and search for emerald. You need compiz-emerald and compiz-emerald-themes.

Then follow my instructions above and you’ll be using compiz as your default window manager.

Take Care,

Ian

I did it,but again simple-ccsm doesn’t start as I said earlier.
what should I do now?

Downloading and trying this out again now.

Is there any particular reason you need to use the simple-ccsm and not the regular ccsm?

Take care,

Ian

Works for me. The output on my computer:

simple-ccsm
/usr/bin/simple-ccsm:40: DeprecationWarning: Use the new widget gtk.Tooltip
  Tooltips = gtk.Tooltips()
/usr/bin/simple-ccsm:182: DeprecationWarning: Use the new widget gtk.Tooltip
  Tooltips = gtk.Tooltips()
/usr/bin/simple-ccsm:426: DeprecationWarning: Use the new widget gtk.Tooltip
  Tooltips.set_tip(self, _("Disabled"))

But it launches.

It looks like you’re having trouble here:

libccs: dlopen: /usr/lib/compizconfig/backends/libkconfig4.so: cannot open shared object file: No such file or directory

I also do not have this file, but I’m running 64 bit.

Which version of KDE are you using?

Take Care,

Ian

I’m using 32bit version.
If I wanna use ccsm ,how I can enable or disable compiz?I used ccsm but when I enable or disable plugins,they dont take effect and I can only manage plugins using Desktop Effect within systemsettings.
Also there are such a abnormal things happend.Run Program changed in its diplay mode,I dont know why some changes happed each time system gone shutdown or reboot without my interaction.It seems 11.2 has a huge amount of unknown bugs.11.1 was pretty much stable than 11.2

I meant which version of KDE as in KDE 4.3, KDE 4.4, etc.?

Really that guide tells you everything you need to know to use compiz without the simple-ccsm since I never used it.

13.) For KDE4 users, To set compiz as the default window manager open Configure Desktop (Personal Settings). Then click Default Applications. Click Window Manager and choose Use a different window manager. Use the drop down menu to choose Compiz (not Compiz custom).

Also, what features does compiz have that KDE4’s native implementation does not?

Take Care,

Ian

I’m using KDE 4.3.
I really don’t know what is the problem.This is annoying.

Sorry to say, but neither do I. I just know that compiz is shaky in KDE4. I’m using Factory KDE4 but do no recommend upgrading just to get some desktop effects. KDE4’s native Desktop Effects work just fine for me. What in particular does compiz have taht isn’t supplied by Kwin?

Take Care,

Ian

Hi,

I downloaded compiz via 1 click Installer, and I am using Gnome. I installed compiz. But CCSM doesn’t start. Also, I can start Desktop Effects program, but when I choose enable desktop effects and try to add animations or effects I want, it does nothing! Besides, when I restart the Desktop Effects program, it starts again but it looks like as if I didn’t choose any effects or animations. How can i solve this problem? Any help would be great.:\