Silver searcher borked my btrfs

I’m running the latest Tumbleweed in a VMWare VM. Yesterday I ran a search using ag (aka the Silver Searcher) on the whole disk. This didn’t end well, and mid process the box crashed. The file-system is btrfs and it set the disk in read-only mode.

Now some googling let me to a VMware page informing me that this was indeed an issue, but one solved a long time ago:
Further, the solution suggestion did not work in this case. So I downloaded the OpenSUSE Tumbleweed Rescue CD. This allowed me to run

btrfs check --repair /dev/sda2

but this does not seem to work. The repair process seems to loop indefinitely because it can’t write the repairs to the disk(?) Here is a screenshot of the process running. After pausing at this display for a moment, the process seems to restart…

Trying to

mount -o remount,rw /dev/sda2


mount -o rw /dev/sda2

) from the rescue CD yields this error-message in the log:

BTRFS error (device sda2): Remounting read-write after error is not allowed

So the question is what I can do now?