SigmaTel STAC9205 Dell 1520 Mic very quiet


I’m running 11.0, and I just can’t get the internal microphone to work correctly. It works fine in Windows, but not with Fedora 8, or what I have now installed, openSUSE 11.0

The internal microphone is so quiet. It “works”, but I just can’t turn it up. I’ve googled a lot about this, and it seems some people have solved the issue, and others not, but playing with volume and capture settings. I’ve moved and clicked everything I can reach using Kmix, but no luck. I do not have a “mic boost” switch. It badly needs a mic boost switch !

I’ve also tried setting

options snd-hda-intel to various options, but no luck.

Any ideas ? The internal mic itself, does “work”, its just too quiet when using Skype and KRecord. I have to get very close to the mic for it to sound normal. As this Dell model has a webcam, I can’t really put my face up to the mic when using Skype, as the webcam just picks my nose out !


have you tried upping the pcm volume with kmix? not sure if this will fix it but it might help!

By various “options” I presume you mean you tried the options here from the ALSA-Configuration.txt file:
(Reference: Linux Kernel Documentation :: sound : alsa : ALSA-Configuration.txt )

983		STAC9205/9254
984		  ref		Reference board
985		  dell-m42	Dell (unknown)
986		  dell-m43	Dell Precision
987		  dell-m44	Dell Inspiron 

How did you enter these options? Via YaST, or by editing your /etc/modprobe.d/sound file?

Can you provide the EXACT syntax as to what your /etc/modprobe.d/sound file looks like after such an edit. ie provide the output of:
cat /etc/modprobe.d/sound

Please also provide output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a

When connected to the internet, can you also run the two diagnostic scripts from the opensuse audio troubleshooting guide, and post the URLs here on this thread, that they provide:

wget -O && bash

In the next script, when prompted for a password, enter your root password, and type “NO” for every question that you do not understand.

su -c 'wget -O tsalsa wget && bash tsalsa' 

Thanks for the detailed reply. I’ve not tried the dell-m44 option, and as my Dell is an inspiron, that would be a good option to pick. I’m at work now, and can’t play with the laptop. But I’ll execute all your suggests this evening and post the results here.

I can turn the volume down using the capture slider, but at its highest position, its just very quiet.

I already have the PCM slider at full, and moving this didn’t make a difference.

I tried options dell-m44, dell, and dell-3stack by directly editing the sound file. Nothing changed. At first I used Yast, but this didn’t seem to save the setting when I changed module. Only if I edited the file directly, did Yast pick out the change, when I checked what the setting was.

Each time after changing the sound file, I performed a new start. But still the mic was very quiet. I played around with kmix too, but no difference. Basically it didn’t seem to matter what I set module to.

I then ran out of time. I’ll post all the other test info later, and try running the diagnostic scripts.

There are still other dell specified settings I could try too. If only there was a magic mic boost option switch !


Can you show me the EXACT syntax you used? ie paste the contents of the /etc/modprobe.d/sound file here.

suse-11:/etc/modprobe.d # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

I have then added a line at the end to specify model. Like below.

options snd slots=snd-hda-intel

u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=dell

I have tried dell-m44, dell, and dell-3stack as models by editing the sound file. Trying one change at a time. When using Yast to change the model, it isn’t saved. Well at least it isn’t saved in the sound file if it is saved. When I edit the file directly, reboot, then check with Yast, it does read the model correctly.

Here is some more info:

suse-11:/etc/modprobe.d # rpm -qa | grep alsa
suse-11:/etc/modprobe.d # rpm -qa | grep pulse
suse-11:/etc/modprobe.d # rpm -q libasound2
suse-11:/etc/modprobe.d # uname -a
Linux suse-11 #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux

The first script

Your ALSA information is located at general pastebin - J_Moore - post number 1065633

Second script

uploading /tmp/tsalsa.txt to
tsalsa completed in 191 seconds
paste this url in #alsa: tsalsa.txt - (beta)

Thank you for taking the time to look at all this.

dell and dell-3stack are not proper options for your hardware audio codec, as far as I know. Why those?

The options are as I already posted here:

985		  dell-m42	Dell (unknown)
986		  dell-m43	Dell Precision
987		  dell-m44	Dell Inspiron 

ie a file like:

options snd slots=snd-hda-intel
# u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=dell-m44

then restart with rcalsasound restart and test your sound.

PLEASE do NOT run alsaconf and do NOT go to yast > hardware > sound after making that edit as it will remove the edit, completely defeating the purpose of your making the edit.

Frankly, I have no idea if you did the above properly (apologies, my wife says I am very grumpy tonight - and I think she is right - a rough day at work).

I’ll look at the rest of your post later, … right now I’m just very tired …

I’m looking at your mixer settings …

Amixer contents for card 0 [Intel] _____________________________________        
amixer set 'Master',0 79% on        
amixer set 'PCM',0 100% 100%        
amixer set 'Front',0 100%,100% on        
amixer set 'IEC958',0 off        
amixer set 'IEC958 Default PCM',0 on        
amixer set 'Capture',0 Capture 0 0%,Capture 0 0% on        
amixer set 'Capture',1 Capture 0 0%,Capture 0 0% on        
amixer set 'Analog Loopback',0 off        
amixer set 'Digital Input Source',0 Items: 'Analog Inputs' 'Digital Mic 1' Item0: 'Digital Mic 1'        
amixer set 'Input Source',0 Items: 'Mic' Item0: 'Mic'        
amixer set 'Input Source',1 Items: 'Mic' Item0: 'Mic'        
amixer set 'Mux',0 Capture 4 100% Capture 4 100%        
amixer set 'Mux',1 Capture 4 100% Capture 4 100%  

Try the following /etc/modprobe.d/sound file:

options snd slots=snd-hda-intel
# u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=dell-m44

I recommend you take a hard look at your mixer settings. Any chance your laptop uses digital audio? In which case, you need to switch it on. Test that. (ie IEC958=ON, and its IEC958-PCM switched ON/up). If it doesn’t work, switch it back off.

also, when testing your audio, try the following audio test (copy and paste it into an xterm/konsole):
speaker-test -Dplug:front -c2 -l5 -twav


Thanks for the further advice. Editing the sound file, and restarting did change things (and much faster than a reboot too), but still too quiet. So … I basically went through dell-m42, dell-m43, dell-m44, and also ref. m43 just gave the option of analogue input, and my mic didn’t work at all. the other model settings, I couldn’t tell any difference, except the ref gave a few extra settings (like 3D sound).
I turned on and off the extra switches you mentioned, but no difference. The only real difference I can make is the capture main switch, under the slider. I did originally think that the capture slider volume did something, but it doesn’t. Only its switch does something, at the bottom of the slider. The capture switch is basically off or on (very quiet of course). Out of frustration, I just tried model values with the word “dell” in them from the Also doc ! Of course this made no difference.
It seems that the capture volume slider is not really doing anything … could this be the real problem ?
The sound test worked fine. I put all sliders I can access to max when trying audio tests. Then I attempt to “sing” to the microphone, recording using KRecord.
Its our first wedding aniversary this weekend, and my wife too is “concerned” I’m spending too much time fiddling with Suse 11.0 !
Maybe its a real bug with Alsa ? Capture slide volume just doesn’t work ? Is there a way to use the windows driver in linux ? ndiswrapper ? Or any other ideas ?

I recommend you leave the dell-m44 in your /etc/modprobe.d/sound

A couple of nights ago, I played with my mic. I first had to setup my mixer to record sound, … and for a good 10 minute I was stumped because my kmix was mis-configured, specifically under the “switches tab” which had “surround jack mode” set to “shared” instead of “independent”. I don’t even know what that means, but it was enough to stop my capability to record audio, until I changed to “independent”.

Yes, I’ll leave the module on this setting. Though after Googling around a bit more, I’m tempted to try Ubuntu. Dell offers this as an option, hence I’d be surprised if the mic didn’t work correctly with Ubuntu out of the box. Though I would of also thought that if they have solved the mic problem, the solution would work its way to Alsa ? Or even be better posted on the web ?

I just use my laptop for email, web surfing, and skype. I just don’t like windows due to Microsoft’s business ethics. One day everything will work on my laptop using Linux, and that will be great !

Make certain as well, that you are not doing something silly, such as trying to use your mic with an application that is not properly setup. I recommend using a basic alsa record command … ie play around with command lines like:
arecord -d 10 myrecording.wav
arecord -d 15 -f cd secondrecording.wav
if a KDE user, also played with krec and krecord

I spent more time playing with settings, and using Krecord, but no luck. The mic was still too quiet.

So I thought I’d go for a radical change, and try Ubuntu. Dell offers this as an alternative OS, so I thought it should at least work with my Dell laptop.

Well I installed the latest 8.04 version, and took a look at the audio settings, and played around with basic recording. But it was still quiet ! Anyway, I installed a bunch of updates, and also skype from Ubuntu’s repository, and … wait for it … it worked !

So why did it now work ? Well I took a closer look at the audio settings, and new slider called digital had appeared. I guess when I installed skype, perhaps a dependency was also installed which “added” this digital slider ? Anyway, the mic now works just as good in Ubuntu as in Windows. I’m not sure if the digital slider will make it into Suse or Fedora, but I’ll stick with Ubuntu for the time being, as the three things I need (email, web browser, and skype) all work. I was surprised how easy it was to configure Ubuntu, although the install wasn’t simple, and the auto installed didn’t really work for me. I had to manually tell it to use my ext3 partitions. But apart from that, everything was pretty straight forward, even installing nvidia and b43xx wireless drivers.

I’ll take a look at Suse again in the future though. I’m starting to understand now why Ubuntu is popular, it doesn’t take much effort to get basic things working with it, which is a good thing for non-techie people.

Thanks very much for your time and effort with my mic problem though. Whatever is in Ubuntu code, hopefully will cross over into Suse at some point.

Glad to read it is working for you under Ubuntu.

I have a couple of friends, with whom I correspond with via email, who are big Ubuntu users. We try to help each other with our Linux experience.

Having typed that, I received an email within the past week from one of them, noting Skype did NOT work for them under Ubuntu. … There have been other cases like this (with different applications), where things “just worked” for me under openSUSE, did not “just work for them” under Ubuntu. So while I am happy it “just works” for you under Ubuntu, I know for a fact not every one shares this experience.

My experience has sometimes some apps “just work” on one distribution, do not “just work” on another distribution. And often this is NOT because one distribution makes more effort to have it “just work” but rather it is a quirk of the configuration setup of individual distributions, and how they interact with applications. For example, often developers will develop on one distribution, but are not able to test their application on different distributions.

Anyway, my points are all mute, because this does work for you under Ubuntu Linux, and I am glad to read it works under Ubuntu. Far from me to disparage any Linux distribution.

If you ever do figure out what Ubuntu specific difference caused this to work for you, it would be nice if you could post that information here. Enjoy your Skype under Linux !!

I came to this thread from Google, and I’m not really quite understood of the details you guys discussed, but my mic doens’t work either. I tried pulseaudio settings, it didn’t help.

I googled many times, but they said pulseaudio doesn’t work on suse11. and that’s the difference between suse11 and suse10.3 on audio. my mic works in suse 10.3.

I’m now considering to remove all pulse rpms, but not sure whewher it works. afraid of making too bigs changes as I’m a new user and a business man who knows little about technology and no time on this as well.

wanna got some information from experts like you. thanks.

I’ve read of users who removed pulse audio applications, and say audio worked better for them afterward. I have not had to do this myself, so other than repeat that, I can not add much there.

In truth, I can not provide any recommendation without wild speculation, unless I know more on your PC’s hardware and software configuration. Can you provide more information, for example as noted in this thread (from an above post):
SigmaTel STAC9205 Dell 1520 Mic very quiet - openSUSE Forums