Shutting Down openSUSE 12.3

I am using openSUSE 12.3, 64-bit. Not much of an expert with Linux.

When I want to turn off the computer, the shutdown icon shows a
countdown clock that starts at 30 seconds.

How do I get that clock to start the counting down from 5 seconds instead?

Thanks.

tb

Welcome to the forums.

> I am using openSUSE 12.3, 64-bit. Not much of an expert with Linux.

None of us were before we were. It’s great that you’re willing to learn
and ask questions.

> When I want to turn off the computer, the shutdown icon shows a countdown
> clock that starts at 30 seconds.
>
> How do I get that clock to start the counting down from 5 seconds instead?

I don’t know how to change this; just to be sure (this isn’t meant to be
insulting if it’s insanely obvious… just covering all of my bases), is
there a reason you do not just click ‘Shutdown’ and go all the way down
instead of waiting for the clock? I will bet that there is a reason and
that sharing it may lead more to the reason for desiring to change the
count, but without knowing for sure I’ll share the easy tips (click the
button to shutdown right away) and let somebody else figure out the hard
stuff. :wink:

Good luck.

Maybe tell us how you are shutting down. Which desktop, for example?

I don’t pay enough attention, but I think from KDE I might sometimes see a choice between “sleep, hibernate, shutdown” with a 30 second countdown. If I click “shutdown” a second time, it shuts down in a few seconds.

On 2013-03-15 21:46, nrickert wrote:
> I don’t pay enough attention, but I think from KDE I might sometimes
> see a choice between “sleep, hibernate, shutdown” with a 30 second
> countdown. If I click “shutdown” a second time, it shuts down in a few
> seconds.

Gnome 2 in this 11.4 does the same.

I click shutdown, I get a dialog for suspend, hibernate, shutdown,
reboot. If I do nothing more, in 60 seconds it does shutdown.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

On 03/15/2013 03:46 PM, nrickert wrote:
>

> Maybe tell us how you are shutting down. Which desktop, for example?
>
> I don’t pay enough attention, but I think from KDE I might sometimes
> see a choice between “sleep, hibernate, shutdown” with a 30 second
> countdown. If I click “shutdown” a second time, it shuts down in a few
> seconds.
>
>

I think I have the same setup as yours.

My desktop environment is KDE 4.10.00 “release 1” and openSUSE 12.3 is
installed on a desktop.

In the taskbar (or whatever it is called in the KDE DE) I have a
shortcut that when clicked presents three choices: Logout; Turn Off
Computer; Restart Computer.

When I was using openSUSE 12.2, selecting the Turn Off Computer option
would cause the computer to shut down immediately. Now it shows a
countdown clock stating that the computer will shut down in 30 seconds.

I did not realize that clicking a second time on the Turn Off Computer
icon would cause a faster shutdown. That’s good information.

Nevertheless, just out of curiosity, how does one modify the 30-second
countdown option for the Turn Off Computer option?

tb

I don’t know the answer for that. I have not come across a configuration setting for it.

I usually shutdown with right-click on the desktop, then select leave. That probably brings up the same menu that you see. If I click “shutdown” it sometimes shuts down, and it sometimes asks me whether I want to hibernate or sleep - in which case a second click on shutdown does the trick.

On 03/16/2013 03:25 AM, tb wrote:
>
> Nevertheless, just out of curiosity, how does one modify the
> 30-second countdown option for the Turn Off Computer option?

i don’t know either…but, if i wanted to know i would do something
like this

https://www.google.com/search?q=KDE+shutdown+countdown+timer+30+change

which led me to (second hit)
https://forums.gentoo.org/viewtopic-t-834221-view-next.html?sid=2fe228f60042402e664f4954c2e63764

where i found that in KDE i could avoid all of the delay (and the
second click) by going Personal Settings - Configure Desktop > System
Administration > Startup and Shutdown > Session Management and there
uncheck “Confirm logout”

or if i wanted to change the 30 to 15 seconds, i might join the KDE
forums and ask the experts there…


dd
http://tinyurl.com/DD-Caveat