Не запускается shutter

Ошибка сегментации](http://ru.wikipedia.org/wiki/Ошибка_сегментации) может произойти из-за чего угодно, это просто некорректное обращение к памяти, она сама по себе ничего сказать не может. Поэтому ничего конкретного посоветовать нельзя, и такие ошибки у разных людей совершенно не говорят о том что проблема в одном и том же. Сложный способ разобраться, это ставить дебаг патеты, запускать программу через дебагер и пытаться понять в чем проблема, но надо иметь большое желание разобрать.

В вашей ситуации, самое вероятное предположение, что все падающие программы используют при работе используют какую-то библиотеку или библиотеки не тех версий на которых они собирались. То есть если например firefox собирался с GTK из офф репозитория, а у вас в системе GTK установлен из другого репозитория, то с некоторой долей вероятности Firefox может некорректно обращаться к этой библиотеки что будет приводить к таким ошибкам. Самый простой способ проверить это перевести все пакеты только на офф репозиторий(то есть заведомо убрать все потенциальные конфликты) и посмотреть исправится ли ошибка.

Такое может происходить если вы например смешивали репозитории 13.1 и Tumbleweed. Но могут быть и другие ситуации. Что-то более конкретное посоветовать скорей всего нельзя пробуйте разные варианты, отпишитесь о результате.

Неа, gtk из офрепа. Но при чем здесь gtk если у меня проблемы с некоторыми kde-прогами.

Все библиотеки и так из офрепа. Гонкой за свежими версиями пакетов я не занимаюсь, поэтому из допрепов стоят только конкретные программы которых нет в офрепе.

Делать мне больше нечего

Это просто пример, вместо Firefox можно поставить A, все место gtk - B.

Не надо воспринимать объяснение конкретно, что у вас в системе я не знаю, а разбираться долго. Вам лучше это известно. И не надо воспринимать примеры на свой счет, это не способ сказать про кривые руки, просто пример как может быть, у меня так было много раз. Еще раз, данная ошибка ничего не значит, может быть все что угодно. Но если это происходит с популярными программами про которые известно что они у большинства работают, можно предположить что дело в окружении этих программ, то есть в конкретной системе. Предположения на основе своего опыта я высказал.

Все библиотеки и так из офрепа.

Риторический вопрос: Вы это проверили или просто так думаете?

Проверил. Во первых в yast, которым я пользуюсь запрещена смена поставщика. Во вторых все проги из допрепов устанавливал я, а не какой-то дядя. В третьих репов хоть и много, но это не мешает мне просмотреть их по отдельности (в yast это удобно) и все проверить.

Попробуйте , этот способ](https://forums.opensuse.org/showthread.php/494724-Ошибка-сегментации-при-запуске-программ?p=2618968#post2618968) помогает в 97%.

Так это тоже самое что и переустановка. Знаете, не хочется и нет времени, я уже заканчиваю настраивать kubuntu…

Это вы зря. Поясню: нынешнее мейстримное ПО глючно по определению: протестировали на 10-20 конфигурациях, работает, Ок пойдет! В данном случае актуальны грамотные багрепорты, но их писать долго и сложно. Никто и не пишет)) На всяком убогом мейнстриме работает- каменты выше… Тогда не ныть!

Не ною. Kubuntu настраиваю…

**Так писал бы в KDE?
**это не тот раздел.

О чем? О kubuntu? lol!

Это не переустановка, все ваши программы останутся, просто файлы дистрибутива приведутся в соотведствие с базовым аналогом. Все потому что 100% у вас какие-то библиотеки конфликтуют может вы установили случайно не ту версию чего-нибудь.

Здравствуйте!Вы часом не пользуетесь qtcurve?Если да,то попробуйте зайти в параметры системы - оформление приложений - настройка GTK+ и заменить qtcurve обратно на оксиген.У меня была похожая ситуация и мне такой способ помог.Если вам поможет,то переустановите пакет qtcurve-KDE

Да я использую qtcurve. Попробую конечно. Только как это поможет в случае с kde программами?

В принципе терять уже нечего, так что попробую.

Вы попробовали выполнить,что я описал выше? Честно говоря,я сам в linux новичок , но у меня тоже не запускались программы и это помогло

В ближайшее время попробую. Ибо сейчас я не в openSUSE