Shutdown isn't working

Hi,

openSUSE 12.3 on my new Laptop wont shutdown, but reboot works fine.
I have reinstalled SUSE and not updated it from a previous version.

Are there any possibillities to fix this?

Thanks

SG-O

There are many ways to start a shutdown. We can not guess which one you use. Please explain.

Hi,

Im using the command “/sbin/shutdown -h -P now” for shutting down and “/sbin/shutdown -r now” for rebooting.

The Laptop is a Clevo P150EM with i7 Prozessor and NVidia Geforce 775M Graphics.

Thanks
SG-O

Sorry, I thought by triggering you to tell more info, you would start to describe the problem in a little bit more then “won’t shutdown”. That does not seem to be the case.

When you do

/sbin/shutdown -h -P now

does anything happen? Nothing,do just get a new prompt and that is all? Please we can not look over your shoulder while you are typing a command. We need every bit of information from you.

Hi,

the system halts, but it is stuck at this point.
The Laptop only shows the loggoff Image and when shutting down from console it shows that that it has halted, but it won’t switch off.

Thanks

SG-O

If I understand you correctly, it does all the shutdown actions (stopping services, killing processes, unmounting disks), but fails to power off (notwithstanding the fact that you use the -P option).

Thats exactly whats happening.

On 2013-03-17 20:16, hcvv wrote:
>
> If I understand you correctly, it does all the shutdown actions
> (stopping services, killing processes, unmounting disks), but fails to
> power off (notwithstanding the fact that you use the -P option).

I have a similar problem with my 12.1: it stops at “powering off system”
or equivalent message. Ii have to hit the power button hard.

Interestingly, when I hit “hibernate” it does power off at the end.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

@Carlos,

You could check what is in /etc/suspend.conf.

I had a similar, but different experience on one system. On hibernating it did somehing that looked/heard like poweroff and the immedialtly power on and booted again.
I had to change

#shutdown method = platform

into

#shutdown method = shutdown

I do not know if trying the different possibilities there might hlp in your case.

But all this does not help the OP. I am a bit disappointed that nobody (except Carlos :wink: ) has any comment now we have formulated the problem.

I reread the command you gave:

/sbin/shutdown -h -P now

IMHO -h and -P are mutualy exclusive. According to the man page both are the same as --poweroff. Could you try using only the -h? (I only use -h myself).

Second thing, would you mind me chaning the title of this thread into:

shutdown -P does not power off

Would be a better caption IMHO.

On 2013-03-18 10:16, hcvv wrote:
>
> @Carlos,
>
> You could check what is in /etc/suspend.conf.

That’s the one that works. I have:


shutdown method = shutdown

> But all this does not help the OP. I am a bit disappointed that nobody
> (except Carlos :wink: ) has any comment now we have formulated the problem.

I have no clue of the cause of the problem. I halt the system rarely, I
always hibernate instead which works. So when I do use halt or reboot it
is because I applied a software update (which could affect that
functionality) or I’m going out for some days and have no time to
investigate.

What I know is that halting worked when I installed this system, and
that it doesn’t since a month or two ago. And I’m using systemv.

Several people are experiencing the same problem, I have seen several
reports of this problem since a few months.

One item from today:

Newsgroups: opensuse.org.help.install-boot-login
Re: ctrl alt del option in inittab - has it stopped working in 12.1?

aungOWUmJv3Hpfig;2478176 Wrote:
> Just in case anyone else comes down this road, I found a solution which
> works: 208 2012-08-03 21:50:20 cd /lib/systemd/system 211
> 2012-08-03 21:50:49 rm ctrl-alt-del.target 212 2012-08-03 21:51:05
> ln -s poweroff.target ctrl-alt-del.target

This stopped working on the 13th of March. The ctrl-alt-del.target was
reset to point to reboot. Was that supposed to happen? It was probably
as a result of an update.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)