Shutdown doesn't turn off computer in openSUSE 13.2

When I shutdown the computer it goes to the normal black screen showing the login but instead of turning off the computer it prints out:

Reboot: Power Down

and then just hangs until I hold the power button for 10 seconds.

My setup:
Computer: Acer AX1470-UR30P
openSUSE 13.2 (64bit)
Linux 3.16.7-21-desktop
KDE 4.14.6
AMD A4-3400 APU with Radeon™ HD Graphics

How do i fix this?

often cause by the graphics. Maybe try the proprietary AMD dirver.

On 2015-05-01 19:16, gogalthorp wrote:
>
> often cause by the graphics. Maybe try the proprietary AMD dirver.

Years ago I would say ACPI. If acpi gets disabled, many features related
to power handling are lost.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

How would I test this (or check for it)? This computer worked correctly with openSUSE 12.1. (I just installed 13.2)

I also found this: https://forums.opensuse.org/showthread.php/495716-Unable-to-shutdown-in-13-1-(x86_64) but he claims it was fixed by Linux kernel 3.13. But I’m on 3.16.x, so not sure how I’d check if it’s the same issue.

On 2015-05-01 20:56, 6tr6tr wrote:
> robin_listas;2707779 Wrote:

>> Years ago I would say ACPI. If acpi gets disabled, many features related
>> to power handling are lost.
>>
> How would I test this (or check for it)? This computer worked correctly
> with openSUSE 12.1. (I just installed 13.2)

Well… you should see something like this, depending on your hardware:


cer@minas-tirith:~> tree /proc/acpi/
/proc/acpi/
|-- ac_adapter
|   `-- ACAD
|       `-- state
|-- battery
|   `-- BAT0
|       |-- alarm
|       |-- info
|       `-- state
|-- button
|   `-- lid
|       `-- LID0
|           `-- state
|-- event
`-- wakeup

7 directories, 7 files
cer@minas-tirith:~>

Ah, I forgot, another candidate is APIC. Or maybe not…

https://en.wikipedia.org/wiki/Advanced_Configuration_and_Power_Interface
https://en.wikipedia.org/wiki/Advanced_Programmable_Interrupt_Controller


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

I get this:

/proc/acpi/
- wakeup

0 directories, 1 file  

Is that what’s causing my issue? What should I do?

On 2015-05-04 18:06, 6tr6tr wrote:

> I get this:
>
>
> Code:
> --------------------
> /proc/acpi/
> - wakeup
>
> 0 directories, 1 file
>
> --------------------
>
>
> Is that what’s causing my issue? What should I do?

I don’t know. Maybe.

I would have a look at the log, the boot section, and see what errors it
reports. Search for words such as error, warning, oops, acpi…


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Which log? When I look in “boot.log”, there’s no error, warning or oops.

Could this fix it?

http://blog.christosoft.de/2013/03/linux-acpi-disabled-wakealarm-poweroff/

Are there any risks in enabling acpi?

First of, are you sure that your problem is related to fglrx?

lsmod | grep drm

then try to unload this:

modprobe -r -v <module>

or something similar. Once the driver is turned off, then try to reboot:

systemctl poweroff

If this doesn’t work, then the problem is not in your driver. Try with journalctl to debug the issue.

Maybe, should not hurt though I suggest you try it by editing the boot code at the boot menu as a test. If it works you can then added it permanent to grub.

At the boot scree press “e” to enter edit mode Find the line starting linux go to the true end, it wraps, add the proposed kernel parameters press F10 to continue boot. This only temporally changes the boot

If it works edit the grub files as suggested to make the change permanent

+1 to that idea. I would try with

nomodeset

also.

On 2015-05-05 20:06, 6tr6tr wrote:

>> I would have a look at the log, the boot section, and see what errors it
>> reports. Search for words such as error, warning, oops, acpi…

> Which log? When I look in “boot.log”, there’s no error, warning or oops.

Ok. It would be “/var/log/messages”; but in the default 13.2 it is
activated. In that case you access the systemd journal via command; for
instance:


journalctl | grep -i acpi

On 2015-05-05 22:36, 6tr6tr wrote:

> Could this fix it?
>
> http://tinyurl.com/pev8g6a

If the logs show that acpi was disabled (and the reason), yes.

> Are there any risks in enabling acpi?

You can try it temporarily, as explained by gogalthorp.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

unfortunately, i tried this and it didn’t work. I added “acpi=force” (without quotes) but it still froze at shutdown.

On 2015-05-08 01:26, 6tr6tr wrote:
> unfortunately, i tried this and it didn’t work. I added “acpi=force”
> (without quotes) but it still froze at shutdown.

But was there any change in “/proc/acpi/”?

Did you check the log as I explained?


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

with “tree”? i checked and no, there was no change.

I checked using “journalctl -i acpi” and it returned pages of output! what should i be looking for?

On 2015-05-08 18:46, 6tr6tr wrote:
>
> robin_listas;2709033 Wrote:

>> But was there any change in “/proc/acpi/”?

> with “tree”? i checked and no, there was no change.

/proc/acpi


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

On 2015-05-08 21:36, 6tr6tr wrote:

> I checked using “journalctl -i acpi” and it returned pages of output!
> what should i be looking for?

I might know after seeing it :slight_smile:

(Huh. I did not say “journalctl -i acpi”)

Look for errors in the last session. The man page you can limit output
to the current session with “–boot”.

If you still can not see anything, upload the complete log (no grep) of
the current boot to susepaste.org (say, for a month), and post a link here.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))