Shutdown button doesn't work, why?

When I clicked the shutdown button through the menu, the computer seem to do not respond. And the command line works well.

#halt now

How can I fix it?:slight_smile:

What Desktop Environment are you using? (e.g. KDE or GNOME) and what version are you using? (e.g. KDE 4.5 or GNOME 2.30)

If you are using KDE does this work to shutdown? -

qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout 0 2 2

I use KDE 4.4, the command you give me close some application: amarok, but other application is still working (e.g. chrome, kconsole).

What happens with reboot?

Try booting the Failsafe option, does it behave differently?

Thats strange. That command is a KDE command which is meant to shut down the computer. It is the same as clicking on the shutdown button in KDE menu. Try caf’s suggestion - try rebooting and try failsafe mode in the boot menu

I have tried booting the Failsafe option, no miracle happened. The button in menu leave away, including logout, switchuser, sleep…, all of them did not work.

Once I have configure the screen saver program, and the screen splashed so that I cannot click the window I want. Is there some relations to this?

My advice. Don’t use screensavers.

caf4926 wrote:
> My advice. Don’t use screensavers.

+1
(screen savers are unnecessary CPU ticks which just add unneeded
carbon to the planet’s atmosphere…“save” your screen by turning it
off when you are not gonna need it for a while…otherwise, just leave
it on unmoving/static and therefore not exercising CPU, RAM, power
supply, hard drives etc etc etc )


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

And then, how to close the screensaver, and how to fix the original problem?

Try a different/new user. It may be a configuration problem in the local config files. Was this an upgrade from a previous version? Do you play in the factory or other experimental repos?

partner1985 wrote:

>
> When I clicked the shutdown button through the menu, the computer seem
> to do not respond. And the command line works well.
>
> Code:
> --------------------
> #halt now
> --------------------
>
>
> How can I fix it?:slight_smile:
>
I have had this problem on my 11.3 system since July. See Novel Bugzilla
#619754. It is also occurring on my 11.4 MS1 system (same computer different
disks). Something I noticed recently is after a kernel update, the first
time I try to shutdown it works but after that its back to the shutdown
problem. I also have an 11.2 installation on this system (separate disk) and
it work fine for shutdown.

Sorry I can not help more. If you find fix please post it.


Russ
openSUSE 11.3 (2.6.34.7-0.5-default)|KDE 4.5.2 Release 10|
Intel core2duo 2.5 MHZ,|4GB DDR3|GeForce 8400GS

Hi,

I ran into this problem too, so I trawled the web for folk with the same issue (as one does, I guess); and did lots of messing around with kde4 config files and updated phonon backends (whatever they might be), and ended up staying up too late trying to fix it, and was tired and teasy the next day, and probably yelled at the kids unnecessarily…

Anyway - whilst probing the issue (after the kids had gone bed), I noticed that when I switched user to a second copy of my primary account, the button in the second account worked!

Somehow, I got from this to figuring that, since the NetworkManager icon doesn’t appear in the panel of the second account (and I’d recently gone through the fairly straightforward process presented by Martin Schandler on his blog to replace knetworkmanager with nm-applet and in a GUI method by ‘susestarter’ - as an aside: do this - it works better and provides more useful info about your connection) that if I removed the startup call to nm-applet, then I might be on to something… hey presto, the red button is back in action!
I ditched the ‘system tray bit’ in susestarter’s step 17 initially - after the Shut-down button was working again, I replaced the startup call to nm-applet, but completely skipped 16 & 17: its still seems to work, regardless… as does the Shut-down button!

Now, you’re probably wondering: ‘I’m using knetworkmanager, so how does this help me?’ - well, it might offer a workaround, namely: log-in, then ‘switch-user’ to a second instance of your account, do your computery stuff, and then Shut-down from there, closing both accounts.

It might work and, admit it, you’re desperate, or you wouldn’t have read this far! nighty-night… JS

OpenSuse11.4/KDE4.6.5rel7/IntelCeleronDualCore1.2MHz/3.8GbRAM/HP_PavilionDM3