Showing JAVA error in firefox

Hi, whenever i go to this website

Morse Code Translator

I get the error message as follows:

icedteanp plugin error: Failed to run /usr/lib64/jvm/jre//bin/java.  For more detail rerun "firefox -g" in a terminal window

The website is for translating the given words into a morse code and give it as a audio file.
When i close the error and try in the website to click translate, the same error reappears.
I also tried to run as firefox -g in terminal window… but I get the same error while opening the website

Please help
Thankyou

On 02/03/2012 05:56 PM, thinkanish wrote:
> For more detail rerun “firefox -g” in a terminal window

show us what you get when you follow those instructions…please
copy/paste the in/output back to this thread using the instructions
here: http://goo.gl/i3wnr

as well, please tell us what operating system and version you are
using…as well as desktop environment…

and, if you go to this site http://www.javatester.org/version.html do
you see a pink rectangle…what is written in it?

and, place this in the nav bar of your firefox and press enter:


about:plugins

when the new page comes up press Ctrl+F and type


java

in the search box… do you find a no instances of java there…or
many…please copy/paste the headline of the longer list, mine looks like


Java(TM) Plug-in 1.6.0_29

and it is followed by a long list of java stuff…but, i have only
one list…do you have none, one or more? if more, give us the headline
of all lists…

by the way, the morse code site works fine with my FF 10 in KDE4.6.0
with SUN Java…


DD http://tinyurl.com/DD-Caveat
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Hi DenverD, thanks for your reply
Here are the responses for your questions.

  1. When I type firefox -g in terminal, i get the following and firefox opens up normally.

anish@linux-jmbg:~> firefox -g
anish@linux-jmbg:~> 


  1. I am using Opensuse 12.1 with gnome 3

  2. No pink rectangle appears when i go the java tester website. Instead, i get the same popup error

icedteanp plugin error: Failed to run /usr/lib64/jvm/jre//bin/java.  For more detail rerun "firefox -g" in a terminal window.

and in a blue colored box titled “The version and vendor from the JRE”

If Java is working, you will see a pink rectangle above with one line of text that says something like:
            Java Version 1.6.0_22 from Sun Microsystems Inc.   *or*
       Java Version: 1.3.1 from Apple Computer, Inc.    *or*
       Java Version: 1.1.4 from Microsoft Corp.


But in firefox addon, i have IcedTea-web plugin and Java as enabled.

  1. In the firefox about: plugin page, two headings had “java” in them:
**IcedTea-Web Plugin (using IcedTea-Web 1.1.3 (suse-1.2-x86_64))

Java(TM) Plug-in 1.6.0_29**


What must I do now?

On 02/04/2012 07:26 AM, thinkanish wrote:

> What must I do now?

very strange!!

it seems you have the Java plugin installed, but it is not working…i
wonder if it was incorrectly installed maybe…

did you install it, if so how?
or is it the java which was default installed? has it ever worked (to
you knowledge)?

in your first post you wrote “Failed to run
/usr/lib64/jvm/jre//bin/java.” and i need to know if you typed that into
the forum compose window, or did you copy/paste it in, directly from the
error message? (i ask because it has a troubling extra slash /)

please shutdown firefox, open a terminal and input each of these
commands, giving an enter at the end of each line:


zypper lr -d
uname -a
cat /etc/SuSE-release
which java
ls -hal /usr/lib/browser-plugins/libflash*
ls -hal /usr/lib64/browser-plugins/libflash*
ls -hal /usr/lib64/jvm/jre//bin/jav?
ls -hal /usr/lib64/jvm/jre/bin/jav?
firefox --version
firefox --g

leave the terminal open when finished, then copy and paste the input and
output back to this thread using the instructions here: http://goo.gl/i3wnr


DD http://tinyurl.com/DD-Caveat
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

thinkanish wrote:
>
> Hi, whenever i go to this website
>
> ‘Morse Code Translator’
> (http://morsecode.scphillips.com/jtranslator.html)
>
> I get the error message as follows:
>
> Code:
> --------------------
> icedteanp plugin error: Failed to run /usr/lib64/jvm/jre//bin/java. For more detail rerun “firefox -g” in a terminal window
> --------------------
>
>
> The website is for translating the given words into a morse code and
> give it as a audio file.
> When i close the error and try in the website to click translate, the
> same error reappears.
> I also tried to run as firefox -g in terminal window… but I get the
> same error while opening the website
>
> Please help
> Thankyou
>
>

I went to the test site DenverD provided the link for, and Java didn’t work in
SeaMonkey (version 2.6.1). about:plugins revealed the iced-tea plugin was not
installed.

In Yast > Software Management Java was installed. Installing iced-tea and
restarting SeaMonkey didn’t enable Java. Forcing an update of both iced-tea and
Java (right-click each and selecting Update) and then restarting SeaMonkey fixed
the problem.

Try this and see if your issue is resolved.


Thomas

On 02/04/2012 05:55 PM, Thomas wrote:
> iced-tea plugin was not installed. . . . In Yast > Software Management Java was installed

thanks for your input Thomas!

it might be interesting to hear enough about both of your situations to
learn if (maybe) there is a situation where the java plugin is not being
correctly installed by YaST, or zypper, or if installed manually…

that is, not putting libflashplayer.so in the correct place while
‘claiming’ to install it, is as good as not even unpacking the RPM…

so, there may be a bug here which needs to get reported…but, so far
i’ve not seen enough info to make that decision…

and, if you are using your real email address that is ok with me, but
you might want to cloak it or use the suggested method in
http://forums.opensuse.org/faq.php?faq=novfor#faq_nntp, your call…


DD
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Hi DenverD,

did you install it, if so how?

Yes i installed it after browsing this forum. (found a thread in search )

has it ever worked (to
you knowledge)?

No,I am sorry, May be i didnt care to notice.

in your first post you wrote “Failed to run
/usr/lib64/jvm/jre//bin/java.” and i need to know if you typed that into
the forum compose window, or did you copy/paste it in, directly from the
error message? (i ask because it has a troubling extra slash /)

I copy pasted the content… and i double checked and there are two slashes before bin.
here is the exact copy of what appears:

ImageShack - Best place for all of your image hosting and image sharing needs](ImageShack - screenshotat20120204232.png)

please shutdown firefox, open a terminal and input each of these
commands, giving an enter at the end of each line:

Here is the exact copy of the terminal:


anish@linux-jmbg:~> zypper lr -d
#  | Alias                                        | Name                                           | Enabled | Refresh | Priority | Type   | URI                                                                               | Service
---+----------------------------------------------+------------------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
 1 | VLC                                          | VLC                                            | Yes     | Yes     |   99     | rpm-md | http://download.videolan.org/pub/vlc/SuSE/12.1                                    |        
 2 | cross-avr                                    | cross-avr                                      | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/CrossToolchain:/avr/openSUSE_12.1       |        
 3 | download.opensuse.org-Education              | openSUSE BuildService - Education              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_12.1/                |        
 4 | download.opensuse.org-games                  | openSUSE BuildService - Games                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_12.1/                    |        
 5 | download.opensuse.org-non-oss                | Main Repository (NON-OSS)                      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/non-oss/                      |        
 6 | download.opensuse.org-oss                    | Main Repository (OSS)                          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/oss/                          |        
 7 | download.opensuse.org-packages               | openSUSE BuildService - Java:packages          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Java:/packages/openSUSE_12.1/           |        
 8 | download.opensuse.org-python                 | openSUSE BuildService - devel:languages:python | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_12.1/ |        
 9 | download.opensuse.org-update                 | Update Repository (DEBUG)                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/12.1/                                   |        
10 | libdvdcss repository                         | libdvdcss repository                           | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/12.1/                                              |        
11 | openSUSE BuildService - CrossToolchain (avr) | openSUSE BuildService - CrossToolchain (avr)   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/CrossToolchain:/avr/openSUSE_12.1/      |        
12 | packman.inode.at-suse                        | Packman Repository                             | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/12.1/                                                |        
13 | repo-debug                                   | openSUSE-12.1-Debug                            | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.1/repo/oss/                    |        
14 | repo-debug-update                            | openSUSE-12.1-Update-Debug                     | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.1/                                   |        
15 | repo-non-oss                                 | openSUSE-12.1-Non-Oss                          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/non-oss/                      |        
16 | repo-oss                                     | openSUSE-12.1-Oss                              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/oss/                          |        
17 | repo-source                                  | openSUSE-12.1-Source                           | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/12.1/repo/oss/                   |        
18 | repo-update                                  | openSUSE-12.1-Update                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.1/                                         |        
anish@linux-jmbg:~> uname-a
If 'uname-a' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf uname-a
anish@linux-jmbg:~> cat /etc/SuSE-release
openSUSE 12.1 (x86_64)
VERSION = 12.1
CODENAME = Asparagus
anish@linux-jmbg:~> which java
/usr/bin/java
anish@linux-jmbg:~> ls -hal /usr/lib/browser-plugins/libflash*
ls: cannot access /usr/lib/browser-plugins/libflash*: No such file or directory
anish@linux-jmbg:~> ls -hal /usr/lib/browser-plugins/libflash
ls: cannot access /usr/lib/browser-plugins/libflash: No such file or directory
anish@linux-jmbg:~> ls -hal /usr/lib64/browser-plugins/libflash*
-rwxr-xr-x 1 root root 18M Nov 15 23:06 /usr/lib64/browser-plugins/libflashplayer.so
anish@linux-jmbg:~> ls -hal /usr/lib64/jvm/jre//bin/jav?
ls: cannot access /usr/lib64/jvm/jre//bin/jav?: No such file or directory
anish@linux-jmbg:~> ls -hal /usr/lib64/jvm/jre/bin/jav?
ls: cannot access /usr/lib64/jvm/jre/bin/jav?: No such file or directory
anish@linux-jmbg:~> firefox --version
Mozilla Firefox 7.0.1
anish@linux-jmbg:~> firefox --g
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).

after the last command, firefox opens. And i sincerely admit that I don’t understand a single word from the above code :frowning:

@Thomas: Thanks for your help. When i right click on them, it show only three options: show more info, disable and about. It didnt show any “update” option.

On 02/04/2012 07:06 PM, thinkanish wrote:
>
>> did you install it, if so how?
> Yes i installed it after browsing this forum. (found a thread in search
> )

then, that is probably the problem…see, java is installed in 12.1 by
default…that is, you should not have had to install it…or, if it was
not installed by default then that is a good indication you have a
broken install…

>> in your first post you wrote “Failed to run
>> /usr/lib64/jvm/jre//bin/java.” and i need to know if you typed that
>> into
>> the forum compose window, or did you copy/paste it in, directly from
>> the
>> error message? (i ask because it has a troubling extra slash /)
> I copy pasted the content… and i double checked and there are two
> slashes before bin.
> HERE IS THE EXACT COPY OF WHAT APPEARS:
> ‘[image:
> http://img36.imageshack.us/img36/2492/screenshotat20120204232.png]’
> (http://imageshack.us/photo/my-images/36/screenshotat20120204232.png/)

yep, there is something wrong there…for sure…

>>
>> please shutdown firefox, open a terminal and input each of these
>> commands, giving an enter at the end of each line:
>>
>
> Here is the exact copy of the terminal:
>
> Code:
> --------------------
>
> anish@linux-jmbg:~> zypper lr -d
> # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
> —±---------------------------------------------±-----------------------------------------------±--------±--------±---------±-------±----------------------------------------------------------------------------------±-------
> 1 | VLC | VLC | Yes | Yes | 99 | rpm-md | http://download.videolan.org/pub/vlc/SuSE/12.1 |
> 2 | cross-avr | cross-avr | Yes | No | 99 | rpm-md | http://download.opensuse.org/repositories/CrossToolchain:/avr/openSUSE_12.1 |
> 3 | download.opensuse.org-Education | openSUSE BuildService - Education | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_12.1/ |
> 4 | download.opensuse.org-games | openSUSE BuildService - Games | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_12.1/ |
> 5 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/non-oss/ |
> 6 | download.opensuse.org-oss | Main Repository (OSS) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/oss/ |
> 7 | download.opensuse.org-packages | openSUSE BuildService - Java:packages | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/Java:/packages/openSUSE_12.1/ |
> 8 | download.opensuse.org-python | openSUSE BuildService - devel:languages:python | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_12.1/ |
> 9 | download.opensuse.org-update | Update Repository (DEBUG) | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/update/12.1/ |
> 10 | libdvdcss repository | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/12.1/ |
> 11 | openSUSE BuildService - CrossToolchain (avr) | openSUSE BuildService - CrossToolchain (avr) | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/CrossToolchain:/avr/openSUSE_12.1/ |
> 12 | packman.inode.at-suse | Packman Repository | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/12.1/ |
> 13 | repo-debug | openSUSE-12.1-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/distribution/12.1/repo/oss/ |
> 14 | repo-debug-update | openSUSE-12.1-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/12.1/ |
> 15 | repo-non-oss | openSUSE-12.1-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/non-oss/ |
> 16 | repo-oss | openSUSE-12.1-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/12.1/repo/oss/ |
> 17 | repo-source | openSUSE-12.1-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/distribution/12.1/repo/oss/ |
> 18 | repo-update | openSUSE-12.1-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/12.1/ |

well, there is another problem or three

first: stop now and read the paragraph beginning with “IMPORTANT” in the
thread written for folks new to openSUSE: http://tinyurl.com/33qc9vu,
among other things it says something like until you know how to fix the
problems you cause when downloading from the prime four repos, don’t.
and, i’m still a new guy, so i follow the advice and here is how my
repos look: http://paste.opensuse.org/81397698

second: for sure you need to
disable these: 1, 10
stop refresh on these: 1, 10
these are duplicates, delete these: 15, 16

what you do with 2, 3, 4, 7, 8, 9, 11, 14, 17 i do not know! i’ve never
used them [heck, i don’t even know what a crossToolChain is!] but i’m
just a user, you seem to be a programmer–is that right? when you
program using tools is it ok with you that maybe have different tool
tomorrow than you are using today? see, when you have all of those
development repos open up to your system then stuff can flow if you use
the wrong zypper command, or set up YaST wrong…

that is one reason why that IMPORTANT paragraph warns against having
more than the main four repos…

i know what i would do with those eleven! repos (hint: disable and
stop the refreshing) and end up with four enabled repos (5, 6, 12, 18)
with only two refreshing (12 & 18–oss and non-oss never change, so
there is no need to refresh them, ever)

third: that repo #7 is some kind of a java repo…did you enable that
repo because you were sure you wanted the java in that repo, rather
than from the standard repo where java should come from (oss, or #6)??

> anish@linux-jmbg:~> uname-a
> If ‘uname-a’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
> cnf uname-a

that just above was supposed to be “uname -a” and not “uname-a”

> anish@linux-jmbg:~> cat /etc/SuSE-release
> openSUSE 12.1 (x86_64)
> VERSION = 12.1
> CODENAME = Asparagus

ok, i see now you are using openSUSE 12.1 and i see that you don’t
have any (for example) 11.4 or 11.3 repos enabled—that is good!

> anish@linux-jmbg:~> which java
> /usr/bin/java

and, that is good because that is where it is supposed to be…

> anish@linux-jmbg:~> ls -hal /usr/lib/browser-plugins/libflash*
> ls: cannot access /usr/lib/browser-plugins/libflash*: No such file or directory

that means there is no libflashplayer.so (the Flash program) in that
directory, which is GOOD because it is for 32 bit players, and you have
a 64 bit system…

> anish@linux-jmbg:~> ls -hal /usr/lib/browser-plugins/libflash
> ls: cannot access /usr/lib/browser-plugins/libflash: No such file or directory

i didn’t ask for that command…you need to be more careful…don’t
type, instead copy paste

> anish@linux-jmbg:~> ls -hal /usr/lib64/browser-plugins/libflash*
> -rwxr-xr-x 1 root root 18M Nov 15 23:06 /usr/lib64/browser-plugins/libflashplayer.so

ah, and you DO have the 64 bit browser plug in in the correct place!

> anish@linux-jmbg:~> ls -hal /usr/lib64/jvm/jre//bin/jav?
> ls: cannot access /usr/lib64/jvm/jre//bin/jav?: No such file or directory

hmmmmm–there is a problem! it should have returned like:

-rwxr-xr-x 1 root root 46K Oct 3 16:51 /usr/lib64/jvm/jre//bin/java*

> anish@linux-jmbg:~> ls -hal /usr/lib64/jvm/jre/bin/jav?
> ls: cannot access /usr/lib64/jvm/jre/bin/jav?: No such file or directory

hmmmmmmmmmmmmmmmmmm–there is another problem, it shoul have returned:

-rwxr-xr-x 1 root root 46K Oct 3 16:51 /usr/lib64/jvm/jre/bin/java*

> anish@linux-jmbg:~> firefox --version
> Mozilla Firefox 7.0.1

WOW! version 7, you should be on version 10…have you been running YaST
Online Update regularly ? you sure need to do that!!

and, if you have not read yet, let me be the first to tell you to
disable or uninstall Apper (the thing that sits in the panel and tells
you that it is gonna run updates–or maybe it asks, if it asks say NO),
it is broken!

> anish@linux-jmbg:~> firefox --g
> *** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).

so, here is what i suggest:

-clean up your repos, for now at least delete the redundant two, and
disable all but the main four, and stop the refreshing on all but
packman and update…do all of that in YaST > Software (on left)
Software Repositories (on right), when your repos are set as suggested,
then close YaST Software Repositories

-and then, open YaST > Software (on left) Software Management (on
right), search on java, and there should be (like Thomas said) two java
packages like JAVA™ PLUG-IN 1.6.0_29 and ICEDTEA something marked as
installed (white check mark)…right click on those two and mark them to
“Update” (green up arrow and green check mark), then press the “Accept”
button…and, when it is finished removing and replacing those java
components, close YaST Software Management (what i am hoping for here is
that it correctly build the links to allow java to be found in
/usr/lib64/jvm/jre/bin/)

-then, open YaST Online Update and when it is set itself up there will
probably be a long list of updates waiting…click the “Accept” button
and go for a walk…it is gonna take a while…maybe an hour, maybe
more…depends on how fast your net connection is and how fast your
machine is…

do NOT try to abort it, or interrupt it…if you do not have the
patience, or time, to wait for it…do not run it now, run it tomorrow…

but, you machine will not be up to date until it has run…

now, i am basing my time estimate on seeing you have firefox 7
installed, which to me means you have done no updates in three months!

> @Thomas: Thanks for your help. When i right click on them, it show only
> three options: show more info, disable and about. It didnt show any
> “update” option.

you have to right click on the package or the box to the left of the
package name, when you do you will see a menu of : Keep, Delete,
Update, Protected and others…

FOLLOWING my list above in order, THEN update the java…

are you really a programmer??


DD http://tinyurl.com/DD-Caveat
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Hi DenverD, thankyou for your time and reply. :slight_smile:

-clean up your repos, for now at least delete the redundant two, and
disable all but the main four, and stop the refreshing on all but
packman and update…do all of that in YaST > Software (on left)
Software Repositories (on right), when your repos are set as suggested,
then close YaST Software Repositories

I read the article pointed by you (written by the admin) and setup the repositories exactly as you told and here is the “zypper lr -d” after setting up

anish@linux-jmbg:~> zypper lr -d
#  | Alias                                        | Name                                           | Enabled | Refresh | Priority | Type   | URI                                                                               | Service
---+----------------------------------------------+------------------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
 1 | VLC                                          | VLC                                            | No      | No      |   99     | rpm-md | http://download.videolan.org/pub/vlc/SuSE/12.1                                    |        
 2 | cross-avr                                    | cross-avr                                      | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/CrossToolchain:/avr/openSUSE_12.1       |        
 3 | download.opensuse.org-Education              | openSUSE BuildService - Education              | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_12.1/                |        
 4 | download.opensuse.org-games                  | openSUSE BuildService - Games                  | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_12.1/                    |        
 5 | download.opensuse.org-packages               | openSUSE BuildService - Java:packages          | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/Java:/packages/openSUSE_12.1/           |        
 6 | download.opensuse.org-python                 | openSUSE BuildService - devel:languages:python | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_12.1/ |        
 7 | download.opensuse.org-update                 | Update Repository (DEBUG)                      | No      | No      |   99     | rpm-md | http://download.opensuse.org/debug/update/12.1/                                   |        
 8 | libdvdcss repository                         | libdvdcss repository                           | No      | No      |   99     | rpm-md | http://opensuse-guide.org/repo/12.1/                                              |        
 9 | openSUSE BuildService - CrossToolchain (avr) | openSUSE BuildService - CrossToolchain (avr)   | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/CrossToolchain:/avr/openSUSE_12.1/      |        
10 | packman.inode.at-suse                        | Packman Repository                             | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/12.1/                                                |        
11 | repo-debug                                   | openSUSE-12.1-Debug                            | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.1/repo/oss/                    |        
12 | repo-debug-update                            | openSUSE-12.1-Update-Debug                     | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/update/12.1/                                   |        
13 | repo-non-oss                                 | openSUSE-12.1-Non-Oss                          | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/non-oss/                      |        
14 | repo-oss                                     | openSUSE-12.1-Oss                              | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/oss/                          |        
15 | repo-source                                  | openSUSE-12.1-Source                           | No      | No      |   99     | NONE   | http://download.opensuse.org/source/distribution/12.1/repo/oss/                   |        
16 | repo-update                                  | openSUSE-12.1-Update                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.1/                                         |        
anish@linux-jmbg:~> 


that just above was supposed to be “uname -a” and not “uname-a”

I am sorry, i typed it wrongly (noobiness!!!) here is the correct output(i guess so)

anish@linux-jmbg:~> uname -a
Linux linux-jmbg.site 3.1.0-1.2-desktop #1 SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64 x86_64 x86_64 GNU/Linux
anish@linux-jmbg:~> 


and then, open YaST > Software (on left) Software Management (on
right), search on java, and there should be (like Thomas said) two java
packages like JAVA™ PLUG-IN 1.6.0_29 and ICEDTEA something marked as
installed (white check mark)…right click on those two and mark them to
“Update”

I didnt see any update option as i saw for firefox (When i right click on mozilla firefox, it shows an update option but on java and icedtea, no update option and i think that they are up-to-date if i am not worng)

WOW! version 7, you should be on version 10…

Now, i updated firefox!
For your info…

anish@linux-jmbg:~> firefox --version
Mozilla Firefox 9.0.1
anish@linux-jmbg:~> 


and, if you have not read yet, let me be the first to tell you to
disable or uninstall Apper (the thing that sits in the panel and tells
you that it is gonna run updates–or maybe it asks, if it asks say NO),
it is broken!

And I dont understand what you say here and what apper means…and where to catch and kill it.

[heck, i don’t even know what a crossToolChain is!] but i’m
just a user, you seem to be a programmer–is that right?
are you really a programmer??

crossToolChain installed along with the arduino IDE
Yes i am a bit of programmer (not a hardcore programmer… Just need to program the microcontroller stuff - that kind of hardware programmer :slight_smile: )

I didnt do yast online update as i was on a slow internet connection. I will do online update on 9th feb when i return home where i have a faster connection (I am away from home)

**But the problem still persists.
**
Is there anything else that i must do to resolve the problem? Maybe if the online update of the OS could fix it, then i will post after updating my OS.
Among all distros, I like opensuse verymuch and its not liking me !!! :‘(:’(

On 02/05/2012 08:46 AM, thinkanish wrote:
>
> I read the article pointed by you (written by the admin) and setup the
> repositories exactly as you told and here is the “zypper lr -d” after
> setting up

looks good…

>> that just above was supposed to be “uname -a” and not “uname-a”
> I am sorry, i typed it wrongly (noobiness!!!) here is the correct
> output(i guess so)

its ok…i made a mistake…once… :slight_smile:
copy/paste helps…

> anish@linux-jmbg:~> uname -a
> Linux linux-jmbg.site 3.1.0-1.2-desktop #1 SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64 x86_64 x86_64 GNU/Linux

looks good…

>> and then, open YaST> Software (on left) Software Management (on
>> right), search on java, and there should be (like Thomas said) two java
>> packages like JAVA™ PLUG-IN 1.6.0_29 and ICEDTEA something marked as
>> installed (white check mark)…right click on those two and mark them
>> to “Update”
>
> I didnt see any update option as i saw for firefox (When i right click
> on mozilla firefox, it shows an update option but on java and icedtea,
> no update option and i think that they are up-to-date if i am not worng)

ok, i guess that means the the box next to the Java Runtime and Java
Browser Plugin does not have a checkmark in it (like the image at
http://paste.opensuse.org/70664548), and then when you right click you
see these possible selections: Install, Do Not Install, Taboo–Never
Install, All in This List and more…

is that what you see? if so, it means that those packages are not
installed…or, at least according to YaST they are not
installed…remember earlier i asked you “did you install it, if so
how?” you answered you had installed it, but you didn’t say how…

i now guess you either used Apper (i tell more on that later) or you
downloaded an rpm and then i don’t know what…maybe you read a how-to
somewhere and used the rpm command, in a terminal ?? if so: CAUTION the
internet has a LONG memory, you may have found a how-to written for
Mandrake Linux (now closed down) in late last century…which worked for
that distro, then…but doesn’t work now for any distro…so, when
looking for how-to when running openSUSE, avoid old info…hey, even a
how to for openSUSE 10.1 is probably not gonna work with openSUSE 12.1 !!

or maybe you decided you didn’t want the already installed openJDK
and you uninstalled that and downloaded and installed the SUN Java using
the info at the SUN/Oracle Java site…is that what you did??

well…i think if the openJDK runtime and plug-in boxes are empty in
YaST, and you single left click the box there will appear a green
checkmark, meaning “Install”…so, click those two boxes to place a
green check mark and then press the “Accept” button…

maybe that will install over whatever you installed and do it
correctly…and, if so then you might see a pink rectangle at that java
test page…

>> WOW! version 7, you should be on version 10…
> Now, i updated firefox!
> For your info…
>
> anish@linux-jmbg:~> firefox --version
> Mozilla Firefox 9.0.1
> anish@linux-jmbg:~>

yes, but if you were to run YaST Online Update you would have v 10, and
when you run it on or after Feb 9, it will update to v 10…

>> and, if you have not read yet, let me be the first to tell you to
>> disable or uninstall Apper (the thing that sits in the panel and
>> tells
>> you that it is gonna run updates–or maybe it asks, if it asks say NO),
>> it is broken!
> And I dont understand what you say here and what apper means…and
> where to catch and kill it.

see, i asked you what Desktop Environment you are using, and i didn’t
get an answer…so, i assume you are using KDE4 (like me) and at the
bottom of your screen (unless you customized it) is a panel with icons
that do different things…and one of those near the bottom right pops
up a message every once in a while saying you have updates…that is an
application named Apper…i have no idea where it is or what it looks
like on your desktop…but, if you can find it, right click on it and
select something like:
-never install updates, or
-never check for updates, or
-disable checking for updates, or
-disallow updates, or

or something like that…now, if you have not updated since FF 7 was
new, then it is possible that you have already murdered Apper, and if so
GOOD for you…it is broken…use only YaST Software Management and
YaST Online Update (or, zypper if you know how to use it correctly…)

have you used zypper? do you know that “zypper dup”, “zypper up” and
“zypper patch” do three very different things and are not
interchangeable and if used as if they are interchangeable then you will
very likely have problems.

>> [heck, i don’t even know what a crossToolChain is!] but i’m
>> just a user, you seem to be a programmer–is that right?
>> are you really a programmer??
> crossToolChain installed along with the arduino IDE
> Yes i am a bit of programmer (not a hardcore programmer… Just need to
> program the microcontroller stuff - that kind of hardware programmer :slight_smile:
> )

ok, i see…if you use a “1-Click Install” button on a web page then you
must always pay attention because during the install you will be
presented with the choice to either:

  1. allow the repo to remain connected to your system (enabled and
    refreshing) or

  2. not keep the repo.

and you must do one of two things, either select to not allow the repo
to remain, or after the install go to YaST Software Repositories and
disable and cease refreshing of the newly added repo…keeping it so if
you later decided you need something from that repo you can just enable
and refresh it…or you can delete the repo…

the rule to keep you stable is four repos (until you have enough
experience to fix the mess you cause by more)

> I didnt do yast online update as i was on a slow internet connection. I
> will do online update on 9th feb when i return home where i have a
> faster connection (I am away from home)

ok…but, i think you might be able to get a working java just by
installing it as described above…

> But the problem still persists.

not suprising, given the status of the current java install…

oh, if you need SUN java, then that is a different thing…do you?
if you do then it is best to uninstall the openJDK first and then
install the SUN…there are instructions on exactly how to do that for
12.1 in these forums…NOTE: instructions for 11.4 and earlier are NOT
correct for 12.1…ask for help before proceeding if you know you need
SUN Java…

> Is there anything else that i must do to resolve the problem? Maybe if
> the online update of the OS could fix it, then i will post after
> updating my OS.

recommendation: try to install openJDK as outlined above, maybe it works
maybe not…if not, then maybe after running the Online Update it will…

if not, post again…

> Among all distros, I like opensuse verymuch and its not liking me !!!

a mistake some folks make is they start with (say) Ubuntu and then maybe
go to (say) Fedora and keep their home, and then maybe come here and
keep thier hom, and then they have a /home directory with configure
files written by and for Ubuntu, Fedora and openSUSE all jumbled up in
their home…

or, they (say) learned how to “sudo apt get” or “yum something” in one
distro and think (when they get here) that “sudo zypper up” looks close
enough that it ought to work…and, i might do something…but that
something might not result in a correct install…

so, what i’m saying is: if you have experience in Windows then most of
what you learned there will kill your openSUSE, and if you have
experience in Ubuntu/Mint/Kbuntu/Debian a lot of stuff you learned there
will murder your openSUSE…

do not use how-tos from just where ever you find them…now, i used a
ubuntu how-to last week and it worked…but, i have a recent system
backup and i made a BACKUP of the affected files prior just prior to
editing a config, and i was ready in case it hosed my system…doing
anything else is a gamble…


DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Hi DenverD,
I have open jdk installed i think. Please refer to this screen shot
SUSE Paste
(yeah copied your method)lol!

and you must do one of two things, either select to not allow the repo
to remain, or after the install go to YaST Software Repositories and
disable and cease refreshing of the newly added repo…keeping it so if
you later decided you need something from that repo you can just enable
and refresh it.

I got it and i wont forget it thanks.

have you used zypper?

yes, but only used “zypper in” or “zypper install” for installing vlc and arduino

a mistake some folks make is they start with (say) Ubuntu and then maybe
go to (say) Fedora and keep their home, and then maybe come here and
keep thier hom, and then they have a /home directory with configure
files written by and for Ubuntu, Fedora and openSUSE all jumbled up in
their home…

or, they (say) learned how to “sudo apt get” or “yum something” in one
distro and think (when they get here) that “sudo zypper up” looks close
enough that it ought to work…and, i might do something…but that
something might not result in a correct install…

so, what i’m saying is: if you have experience in Windows then most of
what you learned there will kill your openSUSE, and if you have
experience in Ubuntu/Mint/Kbuntu/Debian a lot of stuff you learned there
will murder your openSUSE…

I am not that kind of guy… from the beginning, i am using openSUSE (for a specific reason - i like the interface, name everything) - but tried live CD of mint, ubuntu, sabayon, centos, pclinuxos, opensolaris and many.
I was using windows xp and then windows 7 before. I would rather choose to murder windows than Opensuserotfl!

On 02/05/2012 02:56 PM, thinkanish wrote:
> I have open jdk installed i think. Please refer to this screen shot
> ‘SUSE Paste’ (http://paste.opensuse.org/49814362)
> (yeah copied your method)lol!

and, does it work on the morse code site now? how about the test site?

hope it works for you, if not check back after the Online Update…


DD
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

No, I had this openJDK installed before creating this thread. May be only online update must save me.

Okay, and one thing about the apper, I already mentioned that i use Gnome 3 as my desktop environment (I think you would have not noticed it its in my second post when you asked for it.) So, were to find the apper in gnome 3?

On 02/05/2012 03:16 PM, thinkanish wrote:
> No, I had this openJDK installed before creating this thread. May be
> only online update must save me.
>
> Okay, and one thing about the apper, I already mentioned that i use
> Gnome 3 as my desktop environment (I think you would have not noticed
> it its in my second post when you asked for it.) So, were to find the
> apper in gnome 3?

ah, NOW i see gnome 3…sorrry!

i don’t think apper is in gnome 3, so relax on that…but, what i want
you to do is go to http://paste.opensuse.org/89112048 and see that i
placed a red dot over the blue check mark next to “java-1_6_0-openJDK”…

and i want you to go to YaST and that spin select in the upper left
which now is set to “Groups” see if you can’t spin that to “Search” if
you can, leave it there…

and then search and find the -openjdk and place your mouse pointer
directly over the box with the check mark in it and single RIGHT click
that box/check…you should see a popup menu with “Update” or
replace, or refresh, or something like that…select that with a single
left click and the blue check shoul change to something else (maybe a
green something)…

DO NOT click the Accept Button yet" (where IS your accept button??)

anyway i do not see listed in that image the the
“java-1_6_0-openjdk-plugin” but you should find it…(careful, don’t
pick the wrong one) and right click on it and select update…

then press the “Accept” button…that should work…

NOW if you absolutely do not see an Update on the menu after you have
right clicked, then, if there is a Delete item, pick it for both of
those two items…and, click accept…AND then go back and find them and
right click and Install them again…

then try them at the test site…


DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Dear DenverD,

  1. First, I cannot spin the upper left option to Search… The options listed are: Groups, RPM Groups, Repositories, Patterns, languages.

  2. And I typed “openjdk” in search and got the following results:


java-1_6_0-openjdk
java-1_6_0-openjdk-demo
java-1_6_0-openjdk-devel
java-1_6_0-openjdk-javadoc
java-1_6_0-openjdk-src

Among these, I have the openjdk(first one) and devel(third one) installed.(a tick mark) I cant find anything as “java-1_6_0-openjdk-plugin”

Btw, what is your name?

Am 05.02.2012 17:46, schrieb thinkanish:
>

> Among these, I have the openjdk(first one) and devel(third one)
> installed.(a tick mark) I cant find anything as
> “java-1_6_0-openjdk-plugin”
The name of the plugin is icedtea-web


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
nVidia ION | 3GB Ram

On 05.02.2012 08:52, Martin Helm wrote:
> Am 05.02.2012 17:46, schrieb thinkanish:
>>
>
>> Among these, I have the openjdk(first one) and devel(third one)
>> installed.(a tick mark) I cant find anything as
>> “java-1_6_0-openjdk-plugin”
> The name of the plugin is icedtea-web
>

Isn’t that installed by default? I wonder i never get any of these problems.

Windows, supports nearly all software, hardware, and viruses.
Linux Counter: 548299 https://linuxcounter.net/

Hi martin, have a look at this
SUSE Paste

That is already installed and still the problem persists.

On 02/06/2012 04:46 AM, thinkanish wrote:
> That is already installed and still the problem persists.

so, what happens (exactly) when you single right click on the box with
the check mark next to “java-1_6_0-openjdk” and “icedtea-web” ??

@thinkanish, you asked: my first name is Denver…is yours Think?

@Martin, thanks for helping (i don’t have 12.1 handy)

DD
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Hi Denver

so, what happens (exactly) when you single right click on the box with
the check mark next to “java-1_6_0-openjdk” and “icedtea-web” ??

When I right click on these two, I get 5 options - Here is the menu:


Reinstall
Remove
Lock
Select all
Show column >Name
                      >Version
                      >Size
                      >Repository
                      >Supportability

@thinkanish, you asked: my first name is Denver…is yours Think?

No, my name is anish (I dont have a last name only anish)
I have a IBM thinkpad (My laptop) so, thinkpad + anish = thinkanish :slight_smile: