Show all Samba shares in a anetwork in Dolphin (or any other GUI)

Hello guys,

I want to share files between my Linux PC and Windows 10 PC’s and other Linux PC’s.
All Linux PC’s are running latest KDE Plasma.

I’ve managed to make Windows 10 show the Linux PC’s and that’s working fine.

BUT, I’m neither able to show my Windows PC on Linux, nor my Linux PC on Linux.

I’ve tried multiple things, they just do not show up; though, I’m able to connect to Windows and Linux PC manually using the IP-Address (not possible with NETBIOS name).

I’ve already tried SMB4K, which doesn’t work since it doesn’t seem to find any network (even with disabled firewall) Dolphin, which doesn’t show them as well, SMBNetFS and FuseSMB do not show any PC in the selected folder and Dolphin doesn’t show anything under network -> smb as well.
Nautilus doesn’t seem to work as well.

Is there like ANY way to make samba shares visible in OpenSUSE??

Or is there another protocol that I can use to at least connect two Linux PC’s with each other, but shown in Dolphin (btzw. what does the network option do in Dolphin? O.o)

I just don’t know what I should try next…

Maybe someone here got Samba shares visible in Dolphin?

Thank you. :slight_smile:

What did you do to share the Windows 10 PC’s content on the network?

This reads like samba connectivity is working as expected, but just that NetBIOS discovery/browsing doesn’t. If so, that’s because SMBv1 has been disabled (for well-known security reasons). Read my posts in these threads…

…and as I’ve written previously…

FWIW, you can still use the following command to list available workgroups and clients if desired…


It works by making use of NetBIOS-based discovery (on a temporary basis).

I tend to enter the required '“smb://<ip address or hostname of windows box>/<share name>” path into Dolphin’s location bar, and then save the required network shares in the ‘Places’ panel for future navigation. This might be sufficient for you.

Well, I selected a folder, properties -> share (don’t know the exact names since I don’t use Windows in English.
Then I had to change some system properties to make the PC visible for other PC’s in the network and deactivated the password authentication.

This PC is visible and accessible using another Windows PC.

BUT it’s not visible using Dolphin.

Btw. I just found out that Nautilus is able to show my samba shares, but, it can’t connect, since it says that it couldn’t be mounted or, when I type in the IP-address manually, it asks me for a password that I don’t have, since I deactivated it.
And since I don’t like GTK applications, it’s not very helpful probably, though, interesting to know.

Consider using fish:// or sftp:// for Linux file sharing perhaps. That’s what I often use.

When hosts are on the same LAN and Avahi discovery is in use, it may be as simple as this: From the Dolphin ‘Netwok’ places…
Network > Network Services > …

Sometimes it does take a couple of attempts for the discovery to work (pressing ‘F5’ to redisplay).

No, it won’t be. See that answer I’ve already provided about that.

OK, thanks; I’ve already searched for avahi-discovery for Opensuse, but haven’t found a package O.o (probably am I just stupid)

When that would work and could show me my other Opensuse machine, that would be great. :slight_smile:

Oh sorry, haven’t seen your first answer, my fault, sorry.

It should be installed and active by default.

sudo systemctl status avahi-daemon

However, you do need to make sure that any firewalls on the respective hosts are allowing the mDNS broadcasts through.

All good. I just wanted you to be aware of why it doesn’t work like it used to. :slight_smile:

OK, thanks; I’ve enabled mDNS via YaST firewall.

Now I can actually see my Linux PC’s. :slight_smile:
Thank you. :slight_smile:
But still, the Windows PC is not visible;
also, when I want to access the shares of my Linux PC’s, there are two entries.
One time for the samba shares (accessible) and one time with the user name.
That one is not accessible, it tells me that I don’t have the permissions to do so;
Is there a way how I can fix that?

Still, thank you so much, I just had my firewall to allow mDNS. :slight_smile:

That’s good.

But still, the Windows PC is not visible;

No, the samba shares relied on NetBIOS discovery, and that is no longer enabled, and Windows 10 doesn’t use it either. Instead, it is better to just save the desired network path(s) in Dolphin’s places menu as already mentioned.

also, when I want to access the shares of my Linux PC’s, there are two entries.
One time for the samba shares (accessible) and one time with the user name.
That one is not accessible, it tells me that I don’t have the permissions to do so;
Is there a way how I can fix that?

I’m not quite sure about what you’re describing here, but I assume one pertains to samba guest access, and one pertains to credentials for a samba user. If the first is working for you, I would just stay with using that.

This “how to” is one of many that explains how to add a samba user…

Oh my goodness, I’m sorry.
I don’t mean user name, I mean PC-name. I already have a Smaba user, that’s not the problem and it doesn’t seem to be a samba share, since there is not the NETBIOS name written, but the PC-name; I’ve uploaded a pricture showing what I mean.
There’s the PC-name itself and the NETBIOS name.
Just have a look at the picture, maybe you then know what I mean. :smiley:

Those are the Avahi hostnames (without the .local domain showing). The folder icon should spawn a new dolphin window showing something like this for example: ‘sftp://@linux-4k1z.local:22/home/dean/’. Depending on what services you have running, other icons might also be showing. For example, I have an SSH server running on one host, so get a ‘computer’ icon showing. Clicking on that causes konsole to open with a password prompt. That then provides me with an SSH terminal session.

Running the following will show services advertised by hosts on the LAN…

avahi-browse -art

Hope that helps with your understanding. :slight_smile:

BTW, susepaste is a good place to host text and images, then one can just post the link to it via the image icon in the forum editor. For hosting images on susepaste one needs to select ‘Image’ top-right of the page on that site.

Looking at the image you’ve linked to, I see that one of the icons pertains to the samba shares you have configured, and the other folder icon represents sftp connectivity. The ‘avahi-browse’ command that I gave you will reflect these services as well.

Oh OK, thank you so much for your assistance again. :slight_smile:

btw. Since I can see my Windows PC using Nautilus, I guess they haven’t deactivated SMB1, right?

AFAIR, they temporarily enable it just for share discovery.

Glad to have been of help. :slight_smile: