shotwell problem

# file /usr/local/lib/libgee.so.2
/usr/local/lib/libgee.so.2: symbolic link to `libgee.so.2.0.0'

So I did step 7

Now it works for Root again, mortal little me gets:

~> shotwell
shotwell: symbol lookup error: shotwell: undefined symbol: g_malloc0_n

again.

Oh well, at least Holland is in the semi final. :slight_smile:

Hello Ricochet,

The question is why doesn’t it work for your user but works for root?
I think it must be some setting or permission problem.

You could try a test user.
Start YaST->Security and Users->User and Group Management.
Select the tab Users and click on the button add at the bottom of the window.
Fill in the details and press Ok.
Now log out and log in as your new user and start shotwell.
If it works then your normal user has most likely a wrong setting.

If it doesn’t then I think your normal and new user don’t have the rights to the libgee files.
Did you compile as root or as normal user?
And could you post the output of these commands:

dir /usr/lib/libgee*
dir /usr/local/lib/libgee*

Good luck!:wink:

Omg I feel silly now…

The test user worked. So I deleted .shotwell from my homedir and now it works.

Thank you for all your help and patience :slight_smile: