short essay re getting openSUSE computer to sleep and wake up properly

I have not seen a lot of discussion on computer sleep issues so I will proffer the following.

After doing a fresh install (not an upgrade) of Leap 15.3 on my desktop workstation suddenly (after a happy time on 15.2) my workstation was mysteriously unable to sleep.

The computer would appear to try to sleep but at about the 75 second mark something would wake it back up.

Around the internet you can see discussions of the conflict between Nouveau graphics card drivers and the proprietary Nvidia drivers.

This was not that. I will leave that discussion for elsewhere, only noting many solutions involve the same command line as below.

(I ditched Nvidia proprietary drivers some years ago when they screwed me over with a proprietary driver update that totally did not work.

The former Nvidia driver would not run on the then-current openSUSE Leap version. The new Nvidia driver had no idea how to drive 4K screen resolution.

Thanks Nvidia. It is Nouveau for me.)

Cut to the chase:

Use a text editor (as superuser) to edit the root file /etc/default/grub

(It is a good idea to make a backup of the original “grub” e.g. to grub00, just because.)

Look for the line ==
This line is for boot configuration for “normal” conditions not recovery mode.

The default fresh install openSUSE Leap 15.3 version of this line is very simple with only 3 parameters (where parameters are separated by a space):

[LEFT] GRUB_CMDLINE_LINUX_DEFAULT=“splash=silent mitigations=auto quiet”

I added three additional configuration statements:

  1. apci_osi=Linux

Just because. This is supposed to turn on defaults for Linux equal to the full power of Windows. Or so the story goes.

  1. resume=/dev/sda3

This helpfully tells the sleep function where to go to find the swap space on your system drive
so the system can wake up and fully resume state and offer you a chance to log back in.

You would think sleep would automatically know this, but sleep may have missed the memo.
So you have to tell it.

/dev/sda3 is the default Leap 15.3 system drive swap partition.
If your swap partition is different then change the statement accordingly.
You can check your partitions and see who is who with $ lsblk -f

Another version is

The UUID story is out of scope here.

  1. pci=nomsi,noaer

A computer has lots of devices which are part of it. Some of them get cranky and complain.
Some devices complain unfairly over trivial things.
If devices are complaining when your computer is trying to sleep then it cannot stay asleep or go to sleep.
Also device complaints can fill up system log files and silently eat away your root application space.
This statement shuts them up.
The result is your computer gets restful sleep.

So the full statement that saved my system is:

[LEFT] GRUB_CMDLINE_LINUX_DEFAULT=“splash=silent mitigations=auto quiet resume=/dev/sda3 apci_osi=Linux pci=nomsi,noaer”[/LEFT]

Having saved the /etc/default/grub you have to do an additional command to make the grub text file take effect.
That is because the grub text file is really a text configuration file that is just a source for making the real grub configuration file.
But you don’t have to worry about that. Just execute:

$ grub2-mkconfig -o /boot/grub2/grub.cfg

That mercifully worked for me. May it solve your problems as well.

You may try both apci_osi=Linux and apci_osi=Windows to find out what works best with your machine:

Moving to our ‘General Chit-Chat’ sub-forum as not a request for technical help.

Professional resume services melbourne are a great way to get your resume noticed by potential employers. In a competitive job market, resumes that are poorly formatted or poorly presented will most likely be ignored. Professional resume preparation is the best way to make your resume stand out. The process includes carefully structuring your content, re-ordering and restructuring distracting information, and incorporating keywords and bullet points. Then, a professional resume writer will format your document for maximum impact.