shocked, appalled, i dont know what to say

Hey guys,

Why is it in this day, you cannot download a usb bootable image so that you can install this on a laptop? hello? dvds and cds are old technology.

Secondly, I spent about two days trying to make the liveCD into and img so i could boot off the usb, (note i would have gladly paid for an image I could download). I had not luck so i gave up

Went to the store and bought an external dvd drive, since mine was dead. I burned the image, only to find out that I cant install from the live CD. WTF? Are you guys serious.

I knew about opensuse since 2000, I have been a freebsd user since that time and I am astonishingly appalled at the difficulty I have install this system.

Seriously, I have to wait for hours to download a 4 GB DVD??? This is crap.

Someone please explain why I shouldn’t be irate right now because I am. I am saddened, even reading your forums I see all kinds of problems with install and boot and responses of hit this key and type this and it should come up. Whoa, is this 2009 or 1999?

Just my two cents. Im sure your software is great and all that but trying to get it installed is giving me heartburn, not to mention a distaste for the product.


Hmm, sounds more like a rant than a cry for help.Moved to soapbox


unetbootin UNetbootin - Homepage and Downloads

Try and do a network install. Worked fine for me on my netbook.

im sorry to hear you are frustrated. There are two guides on the opensuse wiki in regards to installing without a cd. Ive never used either of these guides as I have always had an optical drive available for install. I hope these can point you in the right direction.

Installation without CD - openSUSE

SuSE install from USB drive - openSUSE

good luck!

It’s a problem of resources, isn’t it? If a distro is quite content knowing it can be installed from USB, it doesn’t necessarily have an incentive to throw man-hours at beautifying the process. It’s clearly possible - case in point Ubuntu, but sometimes there are more critical things to worry about.

I have to ask - did you try my suggestion in the other thread you posted in? It worked fine for me, and I’d hardly call it unreasonably complicated.

Sorry to read of your disappointment.

I hope the suggestions provided above are helpful.

USB sticks have come a long ways fast, and putting an installable OS on a fast memory stick was not something easily implementable a few years ago. It takes time and effort to create an easy/reliable installation method by USB and resources and contributors are needed by community users to create this.

Who you may ask, are these community users? They are people like you and me who take the time to contribute into the things that are important to them in Linux (or contribute to Linux in another way best they can).

Linux needs volunteers and if all the community users only “take” and not contribute, then Linux as an OS will fade away.

So if you see a deficiency, then yes please, point it out and recommend improvements. But please also go a step further and provide sustained technical contributions. Sustained technical contributors are necessary for the Linux OS to succeed.

In this case, if a USB install is that important to you, then maybe you can take the time to study how a USB installation can be made easier. … or help out elsewhere else in Linux so as to lighten the load of someone else, who directly or indirectly may then contribute such that the coding/packaging necessary to create a USB installable package. (Note there are already many different installable versions of openSUSE, and adding another is not something that can be done with minimal effort).

There is likely a reason why this is the case. Can you provide more information on this? ie was your CD reader not recognized? Did your PC have too little RAM for an install? Was there some other problem?

There are likely many volunteers willing to try help. Please start a thread on this subject asking for help.

Download unetbootin + openSUSE 11.0/11.1 DVD -> let unetbootin create the usb stick, you’re done. Alternatively, download unetbootin + openSUSE 11.1 NET installation image -> let unetbootin create the usb stick, you’re done.

Total time that it took me to test this was 2 minutes, about 15 seconds to install unetbootin and 1:45 to download the NET iso and create the stick.

Have fun.

Greetings people,

Wow great responses, I am so glad to see that.

Confuseling, I did try unetbootin, about 6 times. for some reason that failed to work. Dont know why but I get machine characters and the screen is blank when it boots (corrupt image maybe?)

Also, I have no windows box and was tryin to install from freebsd. So instead I borrowed my friends xp laptop. Which as you may have guesssed added to my frustration.

So far I have downloaded the NET cd and have booted up off the external drive. Now I have one small config problem.

I need to manually setup the network ip and default router. Mine router cant do dhcp, Only I dont know how, if any one knows I am in expert config and change config.

Also to oldcpu, thank you. Not having been a member of the linux community, (10+years as a freebsd freak) I would be glad if I could contribute something. Seriously, a usb image that could be downloaded and dd’d to a usb drive would be slick. And I will see what I can come up with. Now, though it seems as though there will be a steep learning curve to learn to diffs btw the 2 OS OS’s but not to difficult to overcome.

As for not being able to install off the liveCD I was not presented with an installation option even after hitting f4 so there was no option to install.

The cd booted fine though.

OK so now that I have a specific question (ie how do I change the ip address and router in the net-install config menu?) I will post it in the help section.

Piminic, I will try those to pages when I revisit the usb install. in the meantime I have to work on other things.

Chrysantine, SO i have to wait hours downloading the DVD to burn. My internet connection is super slow and I dont necessarily have that much time. Is there a way to install off a cd instead? Much smaller download image and much less time?

Thank you guys and nice to meet you all.


I downloaded the Beineri KDE 4.2.2 CD “11.1 Reloaded” , I will give it a shot later today or maybe tomorrow morning and see if I can USB-ify it with my normal 16GB stick.

As I recall there were some issues with the LiveCD being just “written” to the stick but without some further testing I cannot be sure. With the impending release of the SuSE Studio you should be able to create your own USB/CD media installation kits “on the fly” but it’s still beta phase and closed to public audience afaik.

anyone know when suse studio is going into beta? or when they will be accepting more alpha testers?

Hmmm… its been a while since I looked at this, but I thought after booting to the liveCD, there was an icon on the desktop that one clicked in order to do the liveCD install. …Guess my memory is fading and I need to try this again sometime.

your memory’s not fadin… its a big ole button on the desktop when you boot from the livecd

Oh well, look on the bright side, now you have a nice shiny new external DVD drive ;).

Just unetbootining (is that a verb? :)) the ISO wouldn’t work for me, but replacing config.isoclient with config.gnome.isoclient / config.kde.isoclient as appropriate did. There are other tricks on the link I gave in the other thread (How to Make openSUSE 11.1 LiveUSB | Spirit of Change).

Some of the other images work directly in unetbootin without any jiggery pokery as noted above - the unofficial KDE 3.5 USB image would allow you, once installed, to install whatever desktop environment you wanted.

confuseling, yeah that wouldn’t work for me, I think that the initrdud does not work, anyway I got it installed via the livecd

call me dumb, but I didn’t see the big huge button on the startup screen. So after staring at a black screen for about 2 hours I hit the power button on my laptop, loh and behold, this logged me out of kde and from there I found an option for command line login logged in and ran yast and got it on. Im typing from it now.

Which leads me to a funny story about command line vs gui and the infamous one big button that can do everything for you without any input on your part. Read it here


It may be best to download it as text for easier reading, at least I found it so.
-G still in my first day of using linux on my laptop.

Glad you got it sorted!

I’m sure we can all appreciate your frustration - I spent literally two weeks trying to get SUSE 11.0 onto an SDHC card from a USB stick without having a clue what I was doing. Everywhere I read different advice, different “magic solutions”. People stated that they worked, and they did nothing for me except spit out incomprehensible error messages. I very nearly gave up.

Sadly, the technology of installing from USB is relatively new, and still quite in flux. Still, I suspect eventually someone will code a really simple universal way to do it - unetbootin is a really good start - and this will all be a footnote.

I’m sure you’ll have better luck now you’re through the door (heck, if you can figure out BSD you must be doing fairly well :)). Have fun.

Oh and thanks for the link - I’ve just nearly finished reading Snow Crash. It’s awesome. :slight_smile:

> ‘C R Y P T O N O M I C O N’
> (

thanks for that pointer…
interesting diatribe.