Share firefox profile between opensuse and windows xp

Hi!

I try to use the same firefox/thunderbird profile in opensuse and in windows, but if i give the windows profile to the suse firefox, it says to me: "profile is already used/ firefox is already running " Is there any workaroud for this?
Btw the profile sharing works well with ubuntu. I use opensuse 11.1 kde4 reloaded and the installer mounted my windows partition to /windows/c

Thanks :slight_smile:

I’ve never done it but can’t see why it wouldn’t work you could create a symlink…

So you symlink the ones on /home to the ones on /windows/C
man ln

I tried the symlink method, and it didn’t work. I look around a little, and only the owner (root) can read and write the mounted windows partitions, the group and the others only can read. I tried to change the permissions and later the ownership but i can’t. Neither in Dolphin nor in the console. Any idea ?

pasja

I’ve changed the /etc/fstab options, so i can now read/write the partition and set the firefox to that profile. But it don’t bring my extensions :frowning: I need to work on that.

use the Firefox FEBE extension, schedule it to backup on browser shutdown to your mounted windows partition. Config it on both your linux and windows installs of firefox.

Then you can one-click recover your FEBE backup, and your backups are auto created.

Not automatic, but one click is as close as you’re going to get.

Thanks ! That’s a good idea. I used this extension earlier, but i forgot it totally :slight_smile:

Are you sure about that?

I just came across this thread, looking for a solution to my problem. I’m trying out openSUSE, in a dual boot system with Windows XP. Like the original poster, I, too, am trying to share a Firefox profile between the two operating systems. I have set up openSUSE to have automatic read/write access to my NTFS partition upon startup. My openSUSE version of Firefox is pointing to the Firefox profile on my Windows partition. However, when I try to open Firefox within openSUSE, I see the message “Firefox is already running, but is not responding.”

I had this same problem with Ubuntu.

However…I had a dual boot configuration for a while with Windows XP and PCLinuxOS. The PCLinuxOS version of Firefox was able to use my Windows Firefox profile and to start with no difficulty, giving me Firefox with all the bookmarks and settings I had set up in Windows; no extra configuration was needed.

This tells me that there must be a way to do this in openSUSE as well. However, so far I have been unable either to figure out how to do it or to find a solution online.

Being able to share profiles between Windows and Linux versions of Firefox and Thunderbird is one of my most important criteria for evaluating a Linux distribution. If I can’t get this sorted out, I’m afraid that openSUSE, for all its other apparent virtues, will have to make a hasty exit from my computer. Any help would be appreciated!

It’s much easier:

Edit the profile.ini in the .mozilla folders and point it to the place of you windu mozilla folders. Mind, you windu folders have to be on a read/write mounted partition.
This way, both linux and the windu versions write their data in the same files. The suggested way makes it very easy to sync the wrong way around with unwanted results.

Please copy your .mozilla and windu equivalents before you start experimenting. If all works, still backup.

Thanks, Knurpht. I’ll try this when I get home from work, and will post the results.

I’m not sure what you mean by “the suggested way,” or how it “makes it very easy to sync the wrong way around.” I used Firefox’s Profile Manager (in Linux) to select my Windows Firefox profile. Again, this worked flawlessly for me in PCLinuxOS, but not in openSUSE or Ubuntu. Nonetheless, I’ll try editing my openSUSE Firefox profile.ini file, as you suggest.

Knurpht, thank you again for your suggestion. However, I opened the profiles.ini file associated with my openSUSE version of Firefox, and found that, as I suspected, it is already pointing to the correct Firefox profile (the one on my Windows XP partition).

Any further suggestions regarding possible causes of the “Firefox is already running” error that I am experiencing in openSuse, and steps I might be able to take to prevent further occurrences of this error, would be most welcome. Thanks in advance!

Breakthrough: By logging in to openSUSE as “root,” I was able to open Firefox with my Windows XP Firefox profile. Now I know that I just have to set up my Windows Firefox profile folder so that I have read/write access from openSUSE…

This seems to be a question of “correctly” mounting the win data partition. Take a look at

man 8 mount.ntfs-3g

The ways *ix and win manage file ownership and permissions are not quite compatible. Therefore you have to set the ownership etc. at mount time, like

mount -t ntfs-3g -o uid=<your uid/name> /dev/<your windrive> /mountpoint

Maybe you need to tweak umask/fmask/dmask as well…

The other distributions you tried might have done that automatically.

Hope this helps.
Felix

On Tue, 26 Jan 2010 01:36:01 GMT, joesilver <joesilver@no-mx.forums.opensuse.org> wrote:

>
>Breakthrough: By logging in to openSUSE as “root,” I was able to open
>Firefox with my Windows XP Firefox profile. Now I know that I just have
>to set up my Windows Firefox profile folder so that I have read/write
>access from openSUSE…

Don’t use a root login to get around not properly setting file ownership,
it just aggravates the problem.

Use ntfs-3g with options ‘default 0 0’, that should be OK.

The FF is already running, should be solved by updating to latest FF and KDE4 4.3.5 or 4.4 RC3. At least on all machines running either one of those the phenomenon is gone.