Shadowsocks QT5 not work correctly in Leap15

Last week,I needed to work with my company DB through the socks5 connection and found that Shadowsocks QT5 was not work correctly in Leap 15.
shutdown the firewall ,turned to the proxy-setting in YAST , and it still not work.
at the same time ,Shadowsocks QT5 worked fine in other dist(like Fedora and Debian ).
here is the screen-shoot while Shaodwsocks QT5 work in leap15 and the proxy setting.
the setting…
and here is the screen-shoot in Fedora 29, It worked fine with the same setting.的屏幕截图.png的屏幕截图.png

Is there any solution for me?

Hi, welcome

Please use ‘language’ instead of a bunch of screenshots. Explain what you’re trying to achieve, what you expect as a result and what the actual result is.

I’re trying to connect the network(or internet ,the example above is visit the through the Shadowsocks QT5 .
The actual result is I didn’t connect the network( or Internet ) through the Shadowsocks QT5 ,while the Shadowsocks QT5 have connected to the remote server and started the local http-proxy services.

Have you found the solution?

Is seem that opensuse has something differences form other dist in Network Setting.