Severe NFS Problem: NFS shows large directories as empty after recent kernel update

After last kernel update from 5.3.18-lp152.95 to 5.3.18-lp152.98 with no other changes done,

NFS mounts show severe erroneous behavior. Directories which contain a medium to large number of entries are shown as entirely empty.
I could not find out the exact amount from which on this behavior happens. I decimated the entries in a test directory from 16 thousand to much smaller quantities but only a very low number like 20 is shown properly. I tried several options in mount command as nordirplus and caches, but without any impact on the error. On the server the files are visible at all times. NFS4 and NFS3 show the same behavior.
There is no omitting: The content is shown completely or not at all.
No errors appear while mounting or accessing the directories neither in journal nor dmesg, the whole thing does not leave any trace.

Switching back to the “old” kernel 5.3.18-lp152.95 via bootloader remedies the error immediately.

Can anybody confirm this problem? Where should things like these be posted?


It looks as you have tested against the older kernel, thus looks like a bug. Which you can report n the bugzilla:
(same username/password as here)

At least add your /etc/fstab entry/ies to that bug report.

BTW, I have two openSUSE 15.2 systems here using NFS.

henk@boven:~> uname -r 

The client shows directories with more then 100 files in them correct. In other words, I can not confirm your problem.

I had exactly the same problem. After several hours of searching for the error at the client and server side I realized it could only be caused by the new kernel version. Switching back to the old kernel solved it. The NFS client is openSUSE Leap 15.2, the server 15.0.

I suggest that you file a bug report.

I am not seeing a problem with Leap 15.3.

It is already confirmed:

Same issue for me…

**antares:/etc #** df -h 
Filesystem     Type      Size  Used Avail Use% Mounted on 
/dev/sdc6      vfat      306G  284G   23G  93% /nfsshares/Datas2 
/dev/sdc5      vfat      160G   65G   96G  41% /nfsshares/Datas1 
/dev/sda4      vfat      276G   23G  254G   9% /nfsshares/Linux 
/dev/sdd6      fuseblk    60G   33G   27G  56% /nfsshares/Datas3 
/dev/sdd5      fuseblk   9.0G   64M  9.0G   1% /nfsshares/BackUp 
/dev/sda2      ext4       14G  6.6G  6.5G  51% /nfsshares/Datas4 
/dev/sdb2      btrfs     512G  448G   64G  88% /nfsshares/BTRFS2 
/dev/sdb3      btrfs     840G  734G  105G  88% /nfsshares/BTRFS3 
/dev/sdb1      btrfs     512G  289G  223G  57% /nfsshares/BTRFS1 

Seems to be related to vfat file systems… the files are “partially” mounted on some vfat shares :{
The ext4 partition works ok… some folders on btrfs2 are not accessible.
No issues with NTFS partitions.

You really mean you have NFS exports from non-Linux file system?

Issue solved by rolling back at previous snapshot…

Client 15.2, server 15.1.