Severe Boot Problem after Today's Updates

So today I rebooted and I had several updates for my openSUSE 11.1 install. One of them was a kernel upgrade, I believe from .19 to .23.

After restarting from the updates, the screen goes black when it goes to load xwindows. I can get the PC to boot in runlevel3 and login fine. I tried to manually start xwindows by using ‘startx’ and got the same problem. Screen goes black, can’t control-alt-backspace out of it, have to power down system and reboot. I tried to let it sit for 20 minutes, and it sat there at a black screen.

What steps of recovering my system do I have available? I have never had this issue with any of the linux distros I have had (Ubuntu, Slackare, Fedora, etc). I am not sure what is wrong or what could be causing it.

Please help :frowning:

I also wanted to add that I get no error messages, and nothing in /var/log/messages that would indicate any problems. The last thing that shows in messages is vmware items that were successful. My xorg.conf is the same one that has worked for months.

Did you manually compile your graphics driver? If so and you had a kernel update this would be the cause to see rpm -qa --last

Is it the same using the failsafe option? This should use a default boot iirc it will skip any graphic drivers and use the vesa one.

Also have you tried to re-write an xorg conf using sax2 -r -m 0=vesa

As for restarting the xserver iirc it is disabled so you have to enable it. You need in Section “ServerFlags”

Option          "DontZap"               "false"

But in this instance it wouldn’t of helped as it will just restart it, what you could of done is gone back to the the tty you started it from and sent it a ctrl c. I suspect you would of started it from ctrl alt f1.

Thank you for your reply.

I believe I did manually compile the graphics driver, it doesn’t show in the list.

I had no luck with the failsafe option either, although I did try to use the default xorg.conf that came installed on opensuse with no luck.

I haven’t used that sax2 command yet, but I can try it and see.

If you manually(the hard way) did it then you’ll have to do it again the sax2 command should solve it though and get you some kind of desktop back.

Though I thought the default used the vesa driver or one of the free drivers any way. Do you have any feedback on the tty you try to start startx from?

Might be worth looking at the xorg log try
grep EE /var/log/Xorg.0.log

Guess what? I fixed it.

It was resolved by re-installing the ATI drivers and then recompiling fglrx. Rebooted and it came up perfectly.

Thanks for the ideas which lead me to doing that and recompiling, it saved me a lot of time.

Glad you solved it.