Setup privat and standalone OBS instance

Hi forum,

would like to ask for help with OBS 2.4:

I tried to install a privat and standalone OBS Server 2.4 at SLE11-SP2 - but cannot get it working finally.

zypper ar

zypper in obs-server obs-worker obs-api obs-utils build osc

  • Configured Server like described in /usr/share/doc/packages/obs-api/README.SETUP

But because the server is behind a Firewall the cli-command only worked if a proxy is set via
Enviroment (*_proxy=…).

The Target is to build packages in production for SLE11_SP2 and later for RHEL6.
Important: Therefor the OBS must not go to internet.

For this we want to use our own install-repositories with all binary-packages including SDK,
at a local server in the same subnet.

The Web-UI seems working properly, it’s possible to work with projects, subprojects, packages, files, user, groups, …

I added a sub-project to my (test-)users home-project, added a package and in the package a source.tgz and a spec-file.

But now I have to define a “build target” for that packet. (*The project this package belongs to currently has no build targets defined.)
*If I use that link in the UI, I get “There are no distributions configured! Check out Configuration > Interconnect
But there I only can add other OBS Instances!?

How can I work this out, without connection to remote OBS?

Has anybody a hint what’s to do or what I’ve missed?
Thanks for help.


Solved. thanks.